summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-12-16 10:30:56 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-12-16 10:30:56 +0000
commit511730da021772bd0471e6587e70a87ce0d99f67 (patch)
tree88baf94be9440c78af5e615ddb15b449f2214e69 /net-mail/libpst
parentget_libdir support for multilib archs. (Manifest recommit) (diff)
downloadgentoo-2-511730da021772bd0471e6587e70a87ce0d99f67.tar.gz
gentoo-2-511730da021772bd0471e6587e70a87ce0d99f67.tar.bz2
gentoo-2-511730da021772bd0471e6587e70a87ce0d99f67.zip
Version bump ; new upstream maintainer (w/ a working homepage too!). Closes bug 74556.
Diffstat (limited to 'net-mail/libpst')
-rw-r--r--net-mail/libpst/ChangeLog9
-rw-r--r--net-mail/libpst/Manifest15
-rw-r--r--net-mail/libpst/files/digest-libpst-0.5.11
-rw-r--r--net-mail/libpst/files/libpst-0.5.1-gentoo.diff110
-rw-r--r--net-mail/libpst/libpst-0.5.1.ebuild32
5 files changed, 155 insertions, 12 deletions
diff --git a/net-mail/libpst/ChangeLog b/net-mail/libpst/ChangeLog
index 4382907fb1f3..844d60cddf16 100644
--- a/net-mail/libpst/ChangeLog
+++ b/net-mail/libpst/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/libpst
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.4 2004/12/15 10:24:30 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.5 2004/12/16 10:30:56 ka0ttic Exp $
+
+*libpst-0.5.1 (16 Dec 2004)
+
+ 16 Dec 2004; Aaron Walker <ka0ttic@gentoo.org>
+ +files/libpst-0.5.1-gentoo.diff, +libpst-0.5.1.ebuild:
+ Version bump ; new upstream maintainer (w/ a working homepage too!). Closes
+ bug 74556.
*libpst-0.4.1-r1 (15 Dec 2004)
diff --git a/net-mail/libpst/Manifest b/net-mail/libpst/Manifest
index 810e6fa615ef..ca6751985fa6 100644
--- a/net-mail/libpst/Manifest
+++ b/net-mail/libpst/Manifest
@@ -1,17 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 d6c5544a4e5ee4767b2c0ccb7ddab393 libpst-0.5.1.ebuild 843
MD5 34c376a264b7c1e405871017a1a1f4af libpst-0.4.1-r1.ebuild 847
MD5 57f77bb0c1a6899ea8e2e15f57dbd0e7 libpst-0.3.4.ebuild 827
-MD5 c3ac2686d27d803476f081df08e0948a ChangeLog 820
+MD5 75d884a499349ae7783b07f67033d901 ChangeLog 1047
MD5 768a13691288420664ddb9cb57d80098 metadata.xml 163
MD5 3df3e0e228260617e3fc04ade8e76ac8 files/libpst-0.4.1-gentoo.diff 2459
MD5 d621aa03d78f16aafbe1997329cdab1c files/digest-libpst-0.3.4 60
+MD5 f728efbe5e346ceb230df109dae65b30 files/digest-libpst-0.5.1 63
+MD5 6c01d3d2e0e8d62fb740a4e8aedad57b files/libpst-0.5.1-gentoo.diff 3961
MD5 2963ca6f8a38b54cd58daa16910ecdcd files/digest-libpst-0.4.1-r1 60
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBwBELEZCkKN40op4RAqWyAJ96CL7p77YdzhM826gcx47b1anTZwCdEwNw
-EqS9RMTbaSD4SzLozRnx518=
-=kG6Q
------END PGP SIGNATURE-----
diff --git a/net-mail/libpst/files/digest-libpst-0.5.1 b/net-mail/libpst/files/digest-libpst-0.5.1
new file mode 100644
index 000000000000..6a08735fadcc
--- /dev/null
+++ b/net-mail/libpst/files/digest-libpst-0.5.1
@@ -0,0 +1 @@
+MD5 0a80562bf7c503f9d3fdd96e0de10408 libpst-0.5.1.tar.gz 89256
diff --git a/net-mail/libpst/files/libpst-0.5.1-gentoo.diff b/net-mail/libpst/files/libpst-0.5.1-gentoo.diff
new file mode 100644
index 000000000000..7c0daff7eb62
--- /dev/null
+++ b/net-mail/libpst/files/libpst-0.5.1-gentoo.diff
@@ -0,0 +1,110 @@
+diff -urN libpst-0.5.1.orig/libpst.c libpst-0.5.1/libpst.c
+--- libpst-0.5.1.orig/libpst.c 2004-12-15 23:23:52.000000000 -0500
++++ libpst-0.5.1/libpst.c 2004-12-16 00:06:24.630215120 -0500
+@@ -261,7 +261,7 @@
+ int32_t pst_attach_to_file(pst_file *pf, pst_item_attach *attach, FILE* fp) {
+ pst_index_ll *ptr;
+ struct holder h = {NULL, fp, 0, "", 0};
+- int32_t size;
++ int32_t size = 0;
+ DEBUG_ENT("pst_attach_to_file");
+ if (attach->id_val != -1) {
+ ptr = _pst_getID(pf, attach->id_val);
+@@ -283,7 +283,7 @@
+ int32_t pst_attach_to_file_base64(pst_file *pf, pst_item_attach *attach, FILE* fp) {
+ pst_index_ll *ptr;
+ struct holder h = {NULL, fp, 1, "", 0};
+- int32_t size;
++ int32_t size = 0;
+ char *c;
+ DEBUG_ENT("pst_attach_to_file_base64");
+ if (attach->id_val != -1) {
+@@ -373,10 +373,10 @@
+ pst_desc_ll *p;
+ pst_num_array *na;
+ // pst_index_ll *list;
+- pst_index2_ll *list2;//, *t;
++ pst_index2_ll *list2 = NULL;//, *t;
+ unsigned char * buffer=NULL, *headerbuffer=NULL;//, *tc;
+ pst_x_attrib xattrib;
+- int32_t bptr = 0, bsize, hsize, tint, err=0, x;
++ int32_t bptr = 0, bsize=0, hsize=0, tint, err=0, x;
+ pst_x_attrib_ll *ptr, *p_head=NULL, *p_sh=NULL, *p_sh2=NULL;
+ char *wt;
+
+diff -urN libpst-0.5.1.orig/lspst.c libpst-0.5.1/lspst.c
+--- libpst-0.5.1.orig/lspst.c 2004-12-15 23:23:52.000000000 -0500
++++ libpst-0.5.1/lspst.c 2004-12-16 00:08:07.554568240 -0500
+@@ -37,7 +37,10 @@
+ char *rfc2426_escape(char *str);
+ char *rfc2445_datetime_format(FILETIME *ft);
+ // }}}1
+-#define DEBUG_MAIN(x) debug_print x;
++#ifdef DEBUG_MAIN
++# undef DEBUG_MAIN
++# define DEBUG_MAIN(x) debug_print x;
++#endif /* DEBUG_MAIN */
+ // int main(int argc, char** argv) {{{1
+ int main(int argc, char** argv) {
+
+@@ -47,7 +50,7 @@
+ pst_desc_ll *d_ptr;
+ char *temp = NULL; //temporary char pointer
+ int skip_child = 0;
+- struct file_ll *f, *head;
++ struct file_ll *f = NULL, *head = NULL;
+ // }}}2
+
+ if (argc <= 1)
+diff -urN libpst-0.5.1.orig/Makefile libpst-0.5.1/Makefile
+--- libpst-0.5.1.orig/Makefile 2004-12-15 23:23:52.000000000 -0500
++++ libpst-0.5.1/Makefile 2004-12-16 00:12:08.190985944 -0500
+@@ -1,7 +1,8 @@
+ #!/usr/bin/make -f
+
+-CFLAGS ?= -g -Wall
+-PREFIX ?= /usr/local
++CC ?= gcc
++CFLAGS += -Wall
++PREFIX ?= /usr
+ INSTALL ?= install
+
+ #---------------- Do not modify below this point ------------------
+@@ -58,8 +59,6 @@
+ $(INSTALL_PROGRAM) readpst{,log} $(DESTDIR)$(PREFIX)/bin
+ $(INSTALL_DIR) $(DESTDIR)$(PREFIX)/share/man/man1
+ $(INSTALL_FILE) readpst{,log}.1 $(DESTDIR)$(PREFIX)/share/man/man1/
+- $(INSTALL_DIR) $(DESTDIR)$(PREFIX)/share/doc/libpst
+- $(INSTALL_FILE) $(DOCS) $(DESTDIR)$(PREFIX)/share/doc/libpst/
+
+ uninstall:
+ -rm -f $(DESTDIR)$(PREFIX)/bin/readpst{,log}
+diff -urN libpst-0.5.1.orig/readpst.c libpst-0.5.1/readpst.c
+--- libpst-0.5.1.orig/readpst.c 2004-12-15 23:23:52.000000000 -0500
++++ libpst-0.5.1/readpst.c 2004-12-15 23:59:05.334998144 -0500
+@@ -144,7 +144,7 @@
+ int base64_body = 0;
+ // int encrypt = 0;
+ FILE *fp;
+- char *enc; // base64 encoded attachment
++ char *enc = NULL; // base64 encoded attachment
+ char *boundary = NULL, *b1, *b2; // the boundary marker between multipart sections
+ char *temp = NULL; //temporary char pointer
+ int attach_num = 0;
+diff -urN libpst-0.5.1.orig/readpstlog.c libpst-0.5.1/readpstlog.c
+--- libpst-0.5.1.orig/readpstlog.c 2004-12-15 23:23:52.000000000 -0500
++++ libpst-0.5.1/readpstlog.c 2004-12-16 00:04:38.368369376 -0500
+@@ -21,11 +21,11 @@
+
+ int main(int argc, char** argv) {
+ int *i=NULL, x, ptr, stop=0, flag;
+- char *fname, *buf, format, rec_type;
++ char *fname, *buf, format=0, rec_type;
+ unsigned char version;
+ int *show_type=NULL, show_size=0;
+ int *ex_type=NULL, ex_size=0;
+- unsigned int funcname, filename, text, end, dtype, line, c;
++ unsigned int funcname=0, filename=0, text=0, end=0, dtype=0, line=0, c=0;
+ FILE *fp;
+ struct _debug_file_rec_m mfile_rec;
+ struct _debug_file_rec_l lfile_rec;
diff --git a/net-mail/libpst/libpst-0.5.1.ebuild b/net-mail/libpst/libpst-0.5.1.ebuild
new file mode 100644
index 000000000000..3b2a3dea689e
--- /dev/null
+++ b/net-mail/libpst/libpst-0.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/libpst-0.5.1.ebuild,v 1.1 2004/12/16 10:30:56 ka0ttic Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tools and library for reading Outlook files (.pst format)"
+HOMEPAGE="http://alioth.debian.org/projects/libpst/"
+SRC_URI="http://alioth.debian.org/download.php/844/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS CREDITS TODO FILE-FORMAT || die "dodoc failed"
+ dohtml FILE-FORMAT.html || die "dohtml failed"
+}