summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-01-09 08:25:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-01-09 08:25:59 +0000
commit6f2bf0e0f46005eb60e291a3c8965d02907a14c8 (patch)
tree0e0f3930538da6986419a1944841fbf3ba7ba323 /net-mail/mlmmj
parentVersion bump. (diff)
downloadgentoo-2-6f2bf0e0f46005eb60e291a3c8965d02907a14c8.tar.gz
gentoo-2-6f2bf0e0f46005eb60e291a3c8965d02907a14c8.tar.bz2
gentoo-2-6f2bf0e0f46005eb60e291a3c8965d02907a14c8.zip
Hopefully fix bug 141904 that is causing mail loss on the Gentoo lists.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'net-mail/mlmmj')
-rw-r--r--net-mail/mlmmj/ChangeLog8
-rw-r--r--net-mail/mlmmj/files/digest-mlmmj-1.2.15-r13
-rw-r--r--net-mail/mlmmj/files/mlmmj-1.2.15_mmap_zero_byte.patch41
-rw-r--r--net-mail/mlmmj/mlmmj-1.2.15-r1.ebuild63
4 files changed, 114 insertions, 1 deletions
diff --git a/net-mail/mlmmj/ChangeLog b/net-mail/mlmmj/ChangeLog
index 18ff7100fa92..9954c41d92d6 100644
--- a/net-mail/mlmmj/ChangeLog
+++ b/net-mail/mlmmj/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/mlmmj
# Copyright 2004-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mlmmj/ChangeLog,v 1.24 2008/01/04 07:26:54 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mlmmj/ChangeLog,v 1.25 2008/01/09 08:25:58 robbat2 Exp $
+
+*mlmmj-1.2.15-r1 (09 Jan 2008)
+
+ 09 Jan 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/mlmmj-1.2.15_mmap_zero_byte.patch, +mlmmj-1.2.15-r1.ebuild:
+ Hopefully fix bug 141904 that is causing mail loss on the Gentoo lists.
*mlmmj-1.2.15 (04 Jan 2008)
diff --git a/net-mail/mlmmj/files/digest-mlmmj-1.2.15-r1 b/net-mail/mlmmj/files/digest-mlmmj-1.2.15-r1
new file mode 100644
index 000000000000..60f62496198a
--- /dev/null
+++ b/net-mail/mlmmj/files/digest-mlmmj-1.2.15-r1
@@ -0,0 +1,3 @@
+MD5 465b01218c3834346ecc7b25a9d9208d mlmmj-1.2.15.tar.bz2 168232
+RMD160 084837f79ec7326964dacdcabeb85aa5c36f4b37 mlmmj-1.2.15.tar.bz2 168232
+SHA256 5607ce673be1d5c9b8094336bb3210515d59dfc6c4a0b560d3a428f63efb35f3 mlmmj-1.2.15.tar.bz2 168232
diff --git a/net-mail/mlmmj/files/mlmmj-1.2.15_mmap_zero_byte.patch b/net-mail/mlmmj/files/mlmmj-1.2.15_mmap_zero_byte.patch
new file mode 100644
index 000000000000..d6537ecc0559
--- /dev/null
+++ b/net-mail/mlmmj/files/mlmmj-1.2.15_mmap_zero_byte.patch
@@ -0,0 +1,41 @@
+Since 2.6.12, mmap() on a zero-byte file will fail.
+If you have unsubscribed users from a list, you might be left with zero-byte
+subscriber list files, which will cause parsing the full subscriber to fail,
+and mail will only be delivered to some subset of subscribers.
+
+mlmmj-list uses similar logic, but would give a failure instead of counting the
+subscribers properly.
+
+Gentoo-BugID: 141904
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+Date: Wed, 09 Jan 2008 08:25:04 +0000
+
+diff -Nuar mlmmj-1.2.15.orig/src/getaddrsfromfd.c mlmmj-1.2.15/src/getaddrsfromfd.c
+--- mlmmj-1.2.15.orig/src/getaddrsfromfd.c 2005-02-14 14:56:44.000000000 -0800
++++ mlmmj-1.2.15/src/getaddrsfromfd.c 2008-01-09 00:15:14.690251914 -0800
+@@ -21,6 +21,10 @@
+ log_error(LOG_ARGS, "Could not fstat fd");
+ return -1;
+ }
++ /* mmap of 0-bytes is invalid */
++ if(st.st_size == 0) {
++ return 0;
++ }
+
+ start = mmap(0, st.st_size, PROT_READ, MAP_SHARED, fd, 0);
+ if(start == MAP_FAILED) {
+diff -Nuar mlmmj-1.2.15.orig/src/mlmmj-list.c mlmmj-1.2.15/src/mlmmj-list.c
+--- mlmmj-1.2.15.orig/src/mlmmj-list.c 2004-11-28 10:46:43.000000000 -0800
++++ mlmmj-1.2.15/src/mlmmj-list.c 2008-01-09 00:16:12.719781510 -0800
+@@ -68,6 +68,11 @@
+
+ if(!S_ISREG(st.st_mode))
+ return -1;
++
++ /* Nobody there */
++ if(st.st_size == 0) {
++ return 0;
++ }
+
+ start = mmap(0, st.st_size, PROT_READ, MAP_SHARED, fd, 0);
+ if(start == MAP_FAILED)
diff --git a/net-mail/mlmmj/mlmmj-1.2.15-r1.ebuild b/net-mail/mlmmj/mlmmj-1.2.15-r1.ebuild
new file mode 100644
index 000000000000..db46d144d1ec
--- /dev/null
+++ b/net-mail/mlmmj/mlmmj-1.2.15-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mlmmj/mlmmj-1.2.15-r1.ebuild,v 1.1 2008/01/09 08:25:58 robbat2 Exp $
+
+inherit eutils
+
+MY_PV="${PV/_rc/-RC}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Mailing list managing made joyful"
+HOMEPAGE="http://mlmmj.mmj.dk/"
+SRC_URI="http://mlmmj.mmj.dk/files/${MY_P}.tar.bz2"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~ppc-macos ~amd64"
+IUSE=""
+DEPEND="virtual/mta"
+#RDEPEND=""
+S="${WORKDIR}/${MY_P}"
+SHAREDIR="/usr/share/mlmmj"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}_mmap_zero_byte.patch
+ cd "${S}"
+ for i in "${S}" "${S}"/contrib/recievestrip ; do
+ pushd "${i}"
+ # Ignore errors
+ emake -j1 distclean 2>/dev/null 1>/dev/null
+ popd
+ done
+}
+
+src_compile() {
+ econf
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodir ${SHAREDIR}
+ dodir ${SHAREDIR}/texts
+ insinto ${SHAREDIR}/texts
+ doins listtexts/*
+
+ dodoc AUTHORS ChangeLog FAQ README
+ dodoc TODO TUNABLES UPGRADE VERSION README.access
+ dodoc README.sendmail README.exim4 README.security
+
+ insinto /usr/share/mlmmj
+ cd "${S}"/contrib/web
+ doins -r *
+
+ dobin "${S}"/contrib/recievestrip
+}
+
+pkg_postinst() {
+ elog "mlmmj comes with serveral webinterfaces:"
+ elog "- One for user subscribing/unsubscribing"
+ elog "- One for admin tasks"
+ elog "both available in a php and perl module."
+ elog "For more info have a look in /usr/share/mlmmj"
+}