summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-10-08 07:44:43 +0000
committerThomas Kahle <tomka@gentoo.org>2013-10-08 07:44:43 +0000
commitb1d3c1f5d8fb43d7cf2092b254a33600fde70439 (patch)
tree5d093058ae7be4c0d4f71b20bf2ee6390ef3c598 /net-mail/offlineimap
parentRemove pkgconfig workaround. (diff)
downloadgentoo-2-b1d3c1f5d8fb43d7cf2092b254a33600fde70439.tar.gz
gentoo-2-b1d3c1f5d8fb43d7cf2092b254a33600fde70439.tar.bz2
gentoo-2-b1d3c1f5d8fb43d7cf2092b254a33600fde70439.zip
bump to 6.5.5
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'net-mail/offlineimap')
-rw-r--r--net-mail/offlineimap/ChangeLog7
-rw-r--r--net-mail/offlineimap/offlineimap-6.5.5.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/net-mail/offlineimap/ChangeLog b/net-mail/offlineimap/ChangeLog
index 7d2f7a13dd1e..19ca96022e0d 100644
--- a/net-mail/offlineimap/ChangeLog
+++ b/net-mail/offlineimap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/offlineimap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/ChangeLog,v 1.92 2013/02/14 22:11:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/ChangeLog,v 1.93 2013/10/08 07:44:43 tomka Exp $
+
+*offlineimap-6.5.5 (08 Oct 2013)
+
+ 08 Oct 2013; Thomas Kahle <tomka@gentoo.org> +offlineimap-6.5.5.ebuild:
+ bump to 6.5.5
14 Feb 2013; Agostino Sarubbo <ago@gentoo.org> offlineimap-6.5.4-r1.ebuild:
Stable for ppc, wrt bug #457434
diff --git a/net-mail/offlineimap/offlineimap-6.5.5.ebuild b/net-mail/offlineimap/offlineimap-6.5.5.ebuild
new file mode 100644
index 000000000000..82dcb0dfd051
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-6.5.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/offlineimap-6.5.5.ebuild,v 1.1 2013/10/08 07:44:43 tomka Exp $
+
+EAPI=5
+
+# Normally you need only one version of this.
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="threads,sqlite?,ssl?"
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+SRC_URI="https://github.com/OfflineIMAP/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl sqlite"
+
+RDEPEND=""
+DEPEND="doc? ( dev-python/docutils )"
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}/"
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+ epatch "${FILESDIR}"/"${PN}-6.5.3.1"-darwin10.patch
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ if use doc ; then
+ cd docs
+ rst2man.py MANUAL.rst offlineimap.1 || die "building manpage failed"
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ if use doc ; then
+ cd docs
+ doman offlineimap.1 || die "installing manpage failed"
+ fi
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-6.4" ; then
+ elog "If you upgraded from 6.3.* then you may need to update your config:"
+ elog ""
+ elog "If you use nametrans= settings on a remote repository, you will have"
+ elog "to add a \"reverse\" nametrans setting to the local repository, so that"
+ elog "it knows which folders it should (not) create on the remote side."
+ elog ""
+ fi
+}
+
+pkg_postinst() {
+ elog ""
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ elog ""
+
+ if use sqlite ; then
+ elog "The sqlite USE flag only enables a dependency on sqlite. To use"
+ elog "the sqlite backend you need to enable it in your .offlineimaprc"
+ fi
+}