summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-21 06:12:47 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-21 06:12:47 +0000
commit7c686aafc96ad7e4a18d93aabcb14417355ad154 (patch)
treeef9efbb3d0281bc47f081a41740ef9e9b3c25fa5 /net-mail/peephole
parentRemove old version. (diff)
downloadgentoo-2-7c686aafc96ad7e4a18d93aabcb14417355ad154.tar.gz
gentoo-2-7c686aafc96ad7e4a18d93aabcb14417355ad154.tar.bz2
gentoo-2-7c686aafc96ad7e4a18d93aabcb14417355ad154.zip
Version bump. Update to EAPI 4 and add static-libs use flag.
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/peephole')
-rw-r--r--net-mail/peephole/ChangeLog9
-rw-r--r--net-mail/peephole/peephole-1.5.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/net-mail/peephole/ChangeLog b/net-mail/peephole/ChangeLog
index 5904dadfdae9..3934f776c0bd 100644
--- a/net-mail/peephole/ChangeLog
+++ b/net-mail/peephole/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/peephole
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/peephole/ChangeLog,v 1.11 2007/06/12 12:58:47 genone Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/peephole/ChangeLog,v 1.12 2011/09/21 06:12:47 radhermit Exp $
+
+*peephole-1.5 (21 Sep 2011)
+
+ 21 Sep 2011; Tim Harder <radhermit@gentoo.org> +peephole-1.5.ebuild:
+ Version bump. Update to EAPI 4 and add static-libs use flag.
12 Jun 2007; Marius Mauch <genone@gentoo.org> peephole-1.4.ebuild:
Replacing einfo with elog
diff --git a/net-mail/peephole/peephole-1.5.ebuild b/net-mail/peephole/peephole-1.5.ebuild
new file mode 100644
index 000000000000..e50f01bf78ce
--- /dev/null
+++ b/net-mail/peephole/peephole-1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/peephole/peephole-1.5.ebuild,v 1.1 2011/09/21 06:12:47 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="A daemon that polls your POP servers, checking if there are messages from specific people"
+HOMEPAGE="http://peephole.sourceforge.net/"
+SRC_URI="mirror://sourceforge/peephole/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/openssl-0.9.7d-r1"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4-gcc4.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+pkg_postinst() {
+ elog "Before you can use peephole you must copy"
+ elog "/etc/skel/.peephole.providers and /etc/skel/.peepholerc"
+ elog "to your home dir and edit them to suit your needs."
+}