summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-10-28 16:46:12 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-10-28 16:46:12 +0000
commitd10d7c183b559f2446d5ee696f79fa2f02f02518 (patch)
treeb44964f7fb38abaf15c41fb1d76e1682056224e6 /net-mail/procmail
parentFix for #9767 (diff)
downloadgentoo-2-d10d7c183b559f2446d5ee696f79fa2f02f02518.tar.gz
gentoo-2-d10d7c183b559f2446d5ee696f79fa2f02f02518.tar.bz2
gentoo-2-d10d7c183b559f2446d5ee696f79fa2f02f02518.zip
fixo
Diffstat (limited to 'net-mail/procmail')
-rw-r--r--net-mail/procmail/ChangeLog12
-rw-r--r--net-mail/procmail/files/digest-procmail-3.22-r51
-rw-r--r--net-mail/procmail/procmail-3.22-r5.ebuild70
3 files changed, 82 insertions, 1 deletions
diff --git a/net-mail/procmail/ChangeLog b/net-mail/procmail/ChangeLog
index 2c18b35b7e0b..a051baa89166 100644
--- a/net-mail/procmail/ChangeLog
+++ b/net-mail/procmail/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-mail/procmail
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/procmail/ChangeLog,v 1.7 2002/09/06 04:29:57 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/procmail/ChangeLog,v 1.8 2002/10/28 16:46:12 g2boojum Exp $
+
+*procmail-3.22-r5 (28 Oct 2002)
+
+ 28 Oct 2002; Grant Goodyear <g2boojum@gentoo.org> procmail-3.22-r5.ebuild :
+
+ It seems that _both_ the /etc/procmailrc entry and the patch are required
+ for procmail to deliver to ${HOME}/.maildir properly. At least, w/o the
+ /etc/procmailrc entry my mail was being delivered to ~/.maildir but not
+ in maildir form (meaning messages were dumped into ~/.maildir instead of
+ ~/.maildir/new. So, I restored the creation of /etc/procmailrc.
*procmail-3.22-r4 (5 Sep 2002)
diff --git a/net-mail/procmail/files/digest-procmail-3.22-r5 b/net-mail/procmail/files/digest-procmail-3.22-r5
new file mode 100644
index 000000000000..d14b9662a1d7
--- /dev/null
+++ b/net-mail/procmail/files/digest-procmail-3.22-r5
@@ -0,0 +1 @@
+MD5 1678ea99b973eb77eda4ecf6acae53f1 procmail-3.22.tar.gz 226817
diff --git a/net-mail/procmail/procmail-3.22-r5.ebuild b/net-mail/procmail/procmail-3.22-r5.ebuild
new file mode 100644
index 000000000000..a6bcdeb98da5
--- /dev/null
+++ b/net-mail/procmail/procmail-3.22-r5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/procmail/procmail-3.22-r5.ebuild,v 1.1 2002/10/28 16:46:12 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Mail delivery agent/filter"
+SRC_URI="http://www.procmail.org/${P}.tar.gz"
+HOMEPAGE="http://www.procmail.org/"
+
+DEPEND="virtual/glibc
+ virtual/mta"
+
+RDEPEND="virtual/glibc"
+
+PROVIDE="virtual/mda"
+
+SLOT="0"
+LICENSE="Artistic | GPL"
+KEYWORDS="x86 ppc sparc sparc64"
+
+src_compile() {
+
+ cp Makefile Makefile.orig
+# Added a -O2 at the end of CFLAGS to overcome what seems to be a
+# gcc-3.1 strstr() bug with more aggressive optimization flags
+# The order of the flags matters as the last flag passed clobbers
+# the first flag. i.e. if -O2 was placed before ${CFLAGS},
+# whatever optimization that is in ${CFLAGS} would clobber -O2
+ sed -e "s:CFLAGS0 = -O:CFLAGS0 = ${CFLAGS} -O2:" \
+ -e "s:LOCKINGTEST=__defaults__:#LOCKINGTEST=__defaults__:" \
+ -e "s:#LOCKINGTEST=/tmp:LOCKINGTEST=/tmp:" Makefile.orig > Makefile
+
+ if [ -z "`use mbox`" ];
+ then
+ echo "# Use maildir-style mailbox in user's home directory" > ${S}/procmailrc
+ echo 'DEFAULT=$HOME/.maildir/' >> ${S}/procmailrc
+ cd ${S}
+ patch -p1 <${FILESDIR}/gentoo-maildir.diff
+
+ else
+ echo '# Use mbox-style mailbox in /var/spool/mail' > ${S}/procmail
+ echo 'DEFAULT=/var/spool/mail/$LOGNAME' >> ${S}/procmailrc
+ fi
+
+ emake || die
+}
+
+src_install () {
+ cd ${S}/new
+ insinto /usr/bin
+ insopts -m 6755
+ doins procmail
+
+ insopts -m 2755
+ doins lockfile
+
+ dobin formail mailstat
+
+ doman *.1 *.5
+
+ cd ${S}
+ dodoc Artistic COPYING FAQ FEATURES HISTORY INSTALL KNOWN_BUGS README
+
+ insinto /etc
+ doins procmailrc
+
+ docinto examples
+ dodoc examples/*
+}
+