summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-09-05 13:18:39 +0000
committerRoy Marples <uberlord@gentoo.org>2006-09-05 13:18:39 +0000
commit2c5c9fb9b2fc2de1bd5cb911543bddf0143a09ff (patch)
treeed3eb791440e682ddb6d251425869ec9be1284a0 /net-mail
parentStable on sparc (diff)
downloadgentoo-2-2c5c9fb9b2fc2de1bd5cb911543bddf0143a09ff.tar.gz
gentoo-2-2c5c9fb9b2fc2de1bd5cb911543bddf0143a09ff.tar.bz2
gentoo-2-2c5c9fb9b2fc2de1bd5cb911543bddf0143a09ff.zip
Only install developer documentation with doc USE flag, #145433.
(Portage version: 2.1.1_rc1-r4)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot/ChangeLog5
-rw-r--r--net-mail/dovecot/dovecot-1.0_rc7.ebuild27
2 files changed, 24 insertions, 8 deletions
diff --git a/net-mail/dovecot/ChangeLog b/net-mail/dovecot/ChangeLog
index c9a930bcb238..ec95aec77c52 100644
--- a/net-mail/dovecot/ChangeLog
+++ b/net-mail/dovecot/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/dovecot
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.63 2006/08/30 07:47:47 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.64 2006/09/05 13:18:39 uberlord Exp $
+
+ 05 Sep 2006; Roy Marples <uberlord@gentoo.org> dovecot-1.0_rc7.ebuild:
+ Only install developer documentation with doc USE flag, #145433.
30 Aug 2006; <blubb@gentoo.org> dovecot-1.0_beta8.ebuild:
stable on amd64
diff --git a/net-mail/dovecot/dovecot-1.0_rc7.ebuild b/net-mail/dovecot/dovecot-1.0_rc7.ebuild
index 57c8209343c6..91e7dc271eed 100644
--- a/net-mail/dovecot/dovecot-1.0_rc7.ebuild
+++ b/net-mail/dovecot/dovecot-1.0_rc7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0_rc7.ebuild,v 1.2 2006/08/20 12:28:03 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0_rc7.ebuild,v 1.3 2006/09/05 13:18:39 uberlord Exp $
inherit autotools eutils
@@ -16,6 +16,9 @@ KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
IUSE="debug doc ipv6 kerberos ldap mbox mysql pop3d pam postgres ssl vpopmail"
+# Developer documentation, controlled by the doc USE flag
+DEVDOCS="auth-protocol index multiaccess securecoding"
+
DEPEND=">=sys-apps/sed-4
kerberos? ( virtual/krb5 )
ldap? ( net-nds/openldap )
@@ -58,6 +61,19 @@ src_install () {
newinitd "${FILESDIR}"/dovecot.init dovecot
+ # Documentation
+ rm -rf "${D}"/usr/share/doc/dovecot
+ dodoc AUTHORS NEWS README TODO dovecot-example.conf
+ if use doc ; then
+ dodoc doc/*.txt
+ else
+ local x= n=
+ for x in doc/*.txt ; do
+ n=$(basename "${x}" .txt)
+ [[ " ${DEVDOCS} " != *" ${n} "* ]] && dodoc "${x}"
+ done
+ fi
+
# Create the dovecot.conf file from the dovecot-example.conf file that
# the dovecot folks nicely left for us....
local conf="${D}/etc/dovecot/dovecot.conf"
@@ -90,6 +106,7 @@ src_install () {
cp doc/dovecot-sql.conf "${D}"/etc/dovecot
fperms 600 /etc/dovecot/dovecot-sql.conf
sed -i -e '/db sql/,/args/ s|=|= /etc/dovecot-sql.conf|' "${conf}"
+ dodoc doc/dovecot-sql.conf
fi
# Install LDAP configuration
@@ -97,14 +114,9 @@ src_install () {
cp doc/dovecot-ldap.conf "${D}"/etc/dovecot
fperms 600 /etc/dovecot/dovecot-ldap.conf
sed -i -e '/db ldap/,/args/ s|=|= /etc/dovecot-ldap.conf|' "${conf}"
+ dodoc doc/dovecot-ldap.conf
fi
- # Documentation
- rm -rf "${D}"/usr/share/doc/dovecot
- if use doc ; then
- dodoc AUTHORS NEWS README TODO dovecot-example.conf
- dodoc doc/*.txt doc/*.conf doc/*.cnf doc/mkcert.sh
- fi
# Create SSL certificates
if use ssl ; then
@@ -118,6 +130,7 @@ src_install () {
SSLDIR="${D}"/etc/ssl sh mkcert.sh && \
popd >/dev/null
fi
+ dodoc doc/*.cnf doc/mkcert.sh
fi
dodir /var/run/dovecot