summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-05-31 08:39:53 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-05-31 08:39:53 +0000
commit3925be1e1ae14372b38cd11c039ea973ebb96f6f (patch)
treead2206d92a8237a0e83b7cb7c63a40ad3263a7e7 /net-mail
parentUpdated links with patch to hopefully fix libsvga gpm bug (diff)
downloadgentoo-2-3925be1e1ae14372b38cd11c039ea973ebb96f6f.tar.gz
gentoo-2-3925be1e1ae14372b38cd11c039ea973ebb96f6f.tar.bz2
gentoo-2-3925be1e1ae14372b38cd11c039ea973ebb96f6f.zip
New package. Fixes #2949
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/exmh/ChangeLog14
-rw-r--r--net-mail/exmh/exmh-2.5.ebuild53
-rw-r--r--net-mail/exmh/files/exmh-2.5-conf.patch108
3 files changed, 175 insertions, 0 deletions
diff --git a/net-mail/exmh/ChangeLog b/net-mail/exmh/ChangeLog
new file mode 100644
index 000000000000..f6f40a705961
--- /dev/null
+++ b/net-mail/exmh/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for net-mail/exmh
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-mail/exmh/ChangeLog,v 1.1 2002/05/31 08:39:53 rphillips Exp $
+
+*exmh-2.5 (31 May 2002)
+
+ 31 May 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
+
diff --git a/net-mail/exmh/exmh-2.5.ebuild b/net-mail/exmh/exmh-2.5.ebuild
new file mode 100644
index 000000000000..f0b24f1596b5
--- /dev/null
+++ b/net-mail/exmh/exmh-2.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/exmh/exmh-2.5.ebuild,v 1.1 2002/05/31 08:39:53 rphillips Exp $
+
+DESCRIPTION="An X user interface for MH mail"
+SRC_URI="ftp://ftp.scriptics.com/pub/tcl/${PN}/${PN}-${PV}.tar.gz"
+HOMEPAGE="http://beedub.com/exmh/"
+LICENSE="as-is"
+
+DEPEND="net-mail/nmh
+ dev-tcltk/expect
+ net-mail/mailbase
+ crypto? ( app-crypt/gnupg )
+ net-mail/metamail
+ >=dev-lang/tcl-8.2
+ >=dev-lang/tk-8.2"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ for i in *.MASTER; do cp $i ${i%%.MASTER}; done
+ mv exmh.l exmh.1
+ patch -p1 < ${FILESDIR}/exmh-2.5-conf.patch
+ cd misc
+ rm -rf RPM *tar* *gbuffy*
+ for i in *
+ do
+ mv $i $i.orig
+ sed -e "s:/usr/local/bin:/usr/bin:" $i.orig > $i
+ mv $i $i.orig
+ sed -e "s:/usr/local/nmh/bin:/usr/bin:" $i.orig > $i
+ mv $i $i.orig
+ sed -e "s:/usr/local/nmh/lib:/usr/bin:" $i.orig > $i
+ rm $i.orig
+ done
+}
+
+src_compile() {
+ echo 'auto_mkindex ./lib *.tcl' | tclsh
+}
+
+src_install() {
+ into /usr
+ dobin exmh exmh-bg exmh-async ftp.expect
+
+ doman exmh.1
+
+ dodoc COPYRIGHT exmh.CHANGES exmh.README misc/*
+
+ mkdir -p ${D}/usr/lib/${PN}-${PV}
+ install -m 644 lib/* ${D}/usr/lib/${PN}-${PV}
+}
diff --git a/net-mail/exmh/files/exmh-2.5-conf.patch b/net-mail/exmh/files/exmh-2.5-conf.patch
new file mode 100644
index 000000000000..96489601444b
--- /dev/null
+++ b/net-mail/exmh/files/exmh-2.5-conf.patch
@@ -0,0 +1,108 @@
+diff -urN exmh-2.5/exmh exmh-2.5.conf/exmh
+--- exmh-2.5/exmh Thu May 23 10:20:22 2002
++++ exmh-2.5.conf/exmh Thu May 23 10:17:46 2002
+@@ -1,4 +1,4 @@
+-#!wish -f
++#!/usr/bin/wish -f
+ #
+ # TK interface to the MH Mail utility
+ # Brent Welch <welch@acm.org>
+@@ -17,6 +17,34 @@
+
+ # The following lines are patched by exmh.install
+ #CONFIGURATION
++set wish /usr/bin/wish
++set exmh(version) {version 2.5 07/13/2001}
++set exmh(name) exmh
++set exmh(maintainer) welch@acm.org
++set mh_path /usr/bin
++set exmh(slocal) /usr/bin/slocal
++set mime(dir) /usr/bin
++set mailcap_default /etc/mailcap
++set mimetypes_default /etc/mime.types
++set exmh(expect) /usr/bin/expect
++set exmh(expectk) /usr/bin/expectk
++set faces(dir) /usr/lib/faces
++set faces(set,user) {local users usenix misc}
++set faces(set,unknown) {domains unknown}
++set faces(set,news) news
++set faces(defaultDomain) eng.sun.com
++set faces(suffix) {xpm gif xbm}
++set pgp(pgp,path) /usr/bin
++set pgp(pgp5,path) /usr/bin
++set pgp(gpg,path) /usr/bin
++set pgp(pgp6,path) /usr/bin
++set glimpse(path) /usr/bin
++set sound(cmd) /usr/bin/play
++set exmh(library) /usr/lib/exmh-2.5
++set install(dir,bin) /usr/bin
++set install(dir,man) /usr/share/man/man1
++set install(dir,lib) /usr/lib/exmh-2.5
++
+ #END CONFIGURATION
+
+ if [catch {file join a b}] {
+diff -urN exmh-2.5/exmh-async exmh-2.5.conf/exmh-async
+--- exmh-2.5/exmh-async Thu May 23 10:20:22 2002
++++ exmh-2.5.conf/exmh-async Thu May 23 09:55:34 2002
+@@ -1,4 +1,4 @@
+-#!wish -f
++#!/usr/bin/wish -f
+ #
+ # async editor frontend for exmh
+ # Arg1: invoking interpreter's name (from [winfo name .])
+diff -urN exmh-2.5/exmh-bg exmh-2.5.conf/exmh-bg
+--- exmh-2.5/exmh-bg Thu May 23 10:20:22 2002
++++ exmh-2.5.conf/exmh-bg Thu May 23 10:18:18 2002
+@@ -1,4 +1,4 @@
+-#!wish -f
++#!/usr/bin/wish -f
+ #
+ # Background processing script for exmh.
+ # This does stuff and then sends messages to the background module
+@@ -17,6 +17,34 @@
+ # any specification.
+
+ #CONFIGURATION
++set wish /usr/bin/wish
++set exmh(version) {version 2.5 07/13/2001}
++set exmh(name) exmh
++set exmh(maintainer) welch@acm.org
++set mh_path /usr/bin
++set exmh(slocal) /usr/bin/slocal
++set mime(dir) /usr/bin
++set mailcap_default /etc/mailcap
++set mimetypes_default /etc/mime.types
++set exmh(expect) /usr/bin/expect
++set exmh(expectk) /usr/bin/expectk
++set faces(dir) /usr/lib/faces
++set faces(set,user) {local users usenix misc}
++set faces(set,unknown) {domains unknown}
++set faces(set,news) news
++set faces(defaultDomain) eng.sun.com
++set faces(suffix) {xpm gif xbm}
++set pgp(pgp,path) /usr/bin
++set pgp(pgp5,path) /usr/bin
++set pgp(gpg,path) /usr/bin
++set pgp(pgp6,path) /usr/bin
++set glimpse(path) /usr/bin
++set sound(cmd) /usr/bin/play
++set exmh(library) /usr/lib/exmh-2.5
++set install(dir,bin) /usr/bin
++set install(dir,man) /usr/share/man/man1
++set install(dir,lib) /usr/lib/exmh-2.5
++
+ #END CONFIGURATION
+
+ wm withdraw .
+diff -urN exmh-2.5/ftp.expect exmh-2.5.conf/ftp.expect
+--- exmh-2.5/ftp.expect Thu May 23 10:20:22 2002
++++ exmh-2.5.conf/ftp.expect Thu May 23 09:55:34 2002
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+ # \
+-exec expect -f
++exec /usr/bin/expect -f
+
+ set site [lindex $argv 0]
+ set dir [lindex $argv 1]