summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-10-06 08:42:13 +0000
committerPacho Ramos <pacho@gentoo.org>2013-10-06 08:42:13 +0000
commit8e4f909e73970d19c387149113f6e4bf4f813576 (patch)
tree875b3f79f55126aa39c65dd1f0fe8d1d61253001 /net-mail
parentMake autoreconf work with latest automake (#487042 by Arfrever Frehtes Taifer... (diff)
downloadgentoo-2-8e4f909e73970d19c387149113f6e4bf4f813576.tar.gz
gentoo-2-8e4f909e73970d19c387149113f6e4bf4f813576.tar.bz2
gentoo-2-8e4f909e73970d19c387149113f6e4bf4f813576.zip
Add unit file (#487070)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/ChangeLog8
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.26-r2.ebuild99
-rw-r--r--net-mail/fetchmail/files/fetchmail.conf1
-rw-r--r--net-mail/fetchmail/files/fetchmail.service11
4 files changed, 118 insertions, 1 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index 70b0b687ea90..14833c643b81 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/fetchmail
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.262 2013/08/06 13:09:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.263 2013/10/06 08:42:13 pacho Exp $
+
+*fetchmail-6.3.26-r2 (06 Oct 2013)
+
+ 06 Oct 2013; Pacho Ramos <pacho@gentoo.org> +fetchmail-6.3.26-r2.ebuild,
+ +files/fetchmail.conf, +files/fetchmail.service:
+ Add unit file (#487070)
06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> fetchmail-6.3.26-r1.ebuild:
Stable for s390, wrt bug #477574
diff --git a/net-mail/fetchmail/fetchmail-6.3.26-r2.ebuild b/net-mail/fetchmail/fetchmail-6.3.26-r2.ebuild
new file mode 100644
index 000000000000..e6140d184022
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.3.26-r2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.26-r2.ebuild,v 1.1 2013/10/06 08:42:13 pacho Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{6,7} )
+PYTHON_REQ_USE="tk"
+
+inherit python-single-r1 user systemd toolchain-funcs autotools eutils
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://fetchmail.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl nls kerberos hesiod tk socks"
+REQUIRED_USE="tk? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( virtual/krb5 >=dev-libs/openssl-0.9.6 )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-libs/e2fsprogs-libs )
+ socks? ( net-proxy/dante )
+ tk? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+
+ use tk && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # don't compile during src_install
+ use tk && : > "${S}"/py-compile
+
+ epatch "${FILESDIR}"/${P}-python-optional.patch
+ epatch "${FILESDIR}"/${P}-tests.patch
+ eautoreconf
+}
+
+src_configure() {
+ use tk || export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use kerberos && echo "--with-ssl=${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ $(use_with hesiod) \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ # fetchmail's homedir (holds fetchmail's .fetchids)
+ keepdir /var/lib/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN}
+ fperms 700 /var/lib/${PN}
+
+ default
+
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_dotmpfilesd "${FILESDIR}"/${PN}.conf
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+
+ use tk && python_optimize
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}
diff --git a/net-mail/fetchmail/files/fetchmail.conf b/net-mail/fetchmail/files/fetchmail.conf
new file mode 100644
index 000000000000..07945f876468
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail.conf
@@ -0,0 +1 @@
+d /run/fetchmail 700 fetchmail nobody
diff --git a/net-mail/fetchmail/files/fetchmail.service b/net-mail/fetchmail/files/fetchmail.service
new file mode 100644
index 000000000000..954f06e27be0
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=A remote-mail retrieval utility
+After=network.target
+
+[Service]
+User=fetchmail
+ExecStart=/usr/bin/fetchmail -d 60 -f /etc/fetchmailrc
+RestartSec=1
+
+[Install]
+WantedBy=multi-user.target