summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-08-08 09:46:28 +0000
committerRoy Marples <uberlord@gentoo.org>2006-08-08 09:46:28 +0000
commita552be14d5ee7e4f9aae143e7dd64d6cc3c6b747 (patch)
treec9960c0957a1ee45b9d6fe5b8a1c21b00e0b35bc /net-mail
parentStable on hppa. See bug #143093. (diff)
downloadgentoo-2-a552be14d5ee7e4f9aae143e7dd64d6cc3c6b747.tar.gz
gentoo-2-a552be14d5ee7e4f9aae143e7dd64d6cc3c6b747.tar.bz2
gentoo-2-a552be14d5ee7e4f9aae143e7dd64d6cc3c6b747.zip
rc6 is out - include a patch for ssl proxies.
(Portage version: 2.1.1_pre4-r2)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot/ChangeLog8
-rw-r--r--net-mail/dovecot/dovecot-1.0_rc6.ebuild171
-rw-r--r--net-mail/dovecot/files/digest-dovecot-1.0_rc63
-rw-r--r--net-mail/dovecot/files/dovecot-1.0_rc6-proxy-ssl.patch12
4 files changed, 193 insertions, 1 deletions
diff --git a/net-mail/dovecot/ChangeLog b/net-mail/dovecot/ChangeLog
index a1cf66f964ac..66ed20d95946 100644
--- a/net-mail/dovecot/ChangeLog
+++ b/net-mail/dovecot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/dovecot
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.59 2006/08/03 09:06:45 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.60 2006/08/08 09:46:27 uberlord Exp $
+
+*dovecot-1.0_rc6 (08 Aug 2006)
+
+ 08 Aug 2006; Roy Marples <uberlord@gentoo.org>
+ +files/dovecot-1.0_rc6-proxy-ssl.patch, +dovecot-1.0_rc6.ebuild:
+ rc6 is out - include a patch for ssl proxies.
*dovecot-1.0_rc5 (03 Aug 2006)
diff --git a/net-mail/dovecot/dovecot-1.0_rc6.ebuild b/net-mail/dovecot/dovecot-1.0_rc6.ebuild
new file mode 100644
index 000000000000..ec012eb5ca69
--- /dev/null
+++ b/net-mail/dovecot/dovecot-1.0_rc6.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0_rc6.ebuild,v 1.1 2006/08/08 09:46:27 uberlord Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
+HOMEPAGE="http://dovecot.org/"
+MY_P="${P/_/.}"
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://dovecot.org/releases/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+IUSE="debug doc ipv6 kerberos ldap mbox mysql pop3d pam postgres ssl vpopmail"
+
+DEPEND=">=sys-apps/sed-4
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )
+ postgres? ( dev-db/postgresql )
+ mysql? ( dev-db/mysql )
+ vpopmail? ( net-mail/vpopmail )"
+
+RDEPEND="${DEPEND}
+ >=net-mail/mailbase-0.00-r8"
+
+pkg_setup() {
+ # Add user and group for login process (same as for fedora/redhat)
+ enewgroup dovecot 97
+ enewuser dovecot 97 -1 /dev/null dovecot
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-proxy-ssl.patch"
+}
+
+src_compile() {
+ local myconf="--with-ioloop=best --with-poll=best"
+ use ssl && myconf="${myconf} --with-ssl=openssl" \
+ || myconf="${myconf} --without-ssl"
+
+ econf --localstatedir=/var \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_with kerberos gssapi) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_with pam) \
+ $(use_with pop3d) \
+ $(use_with postgres pgsql) \
+ $(use_with vpopmail) \
+ ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ newinitd "${FILESDIR}"/dovecot.init dovecot
+
+ # Create the dovecot.conf file from the dovecot-example.conf file that
+ # the dovecot folks nicely left for us....
+ mv "${D}"/etc/dovecot-example.conf "${D}"/etc/dovecot.conf
+ fperms 0600 /etc/dovecot.conf
+
+ # .maildir is the Gentoo default, but we need to support mbox to
+ local mailenv="maildir:%h/.maildir"
+ if use mbox ; then
+ mailenv="mbox:/var/spool/mail/%u:INDEX=/var/dovecot/%u"
+ keepdir /var/dovecot
+ sed -i -e 's|#mail_extra_groups =|mail_extra_groups = mail|' \
+ "${D}"/etc/dovecot.conf
+ fi
+ sed -i -e \
+ "s|#default_mail_env =|default_mail_env = ${mailenv}|" \
+ "${D}"/etc/dovecot.conf
+
+ # We're using pam files (imap and pop3) provided by mailbase
+ if use pam ; then
+ sed -i -e '/passdb pam/, /^[ \t]*}/ s|#args = dovecot|args = "\*"|' \
+ "${D}"/etc/dovecot.conf
+ fi
+
+ # Listen on ipv6 and ipv4
+ if use ipv6 ; then
+ sed -i -e 's/^#listen = \*/listen = \[::\]/g' \
+ "${D}"/etc/dovecot.conf
+ fi
+
+ # Install SQL configuration
+ if use mysql || use postgres ; then
+ cp doc/dovecot-sql.conf "${D}"/etc
+ fperms 600 /etc/dovecot-sql.conf
+ sed -i -e '/db sql/,/args/ s|=|= /etc/dovecot-sql.conf|' \
+ "${D}"/etc/dovecot.conf
+ fi
+
+ # Install LDAP configuration
+ if use ldap ; then
+ cp doc/dovecot-ldap.conf "${D}"/etc
+ fperms 600 /etc/dovecot-ldap.conf
+ sed -i -e '/db ldap/,/args/ s|=|= /etc/dovecot-ldap.conf|' \
+ "${D}"/etc/dovecot.conf
+ fi
+
+ # Documentation
+ rm -rf "${D}"/usr/share/doc/dovecot
+ if use doc ; then
+ dodoc AUTHORS NEWS README TODO dovecot-example.conf
+ dodoc doc/*.txt doc/*.conf doc/*.cnf doc/mkcert.sh
+ fi
+
+ # Create SSL certificates
+ if use ssl ; then
+ dodir /etc/ssl/certs
+ dodir /etc/ssl/private
+ # Let's not make a new certificate if we already have one
+ if ! [[ -e /etc/ssl/certs/dovecot.pem && \
+ -e /etc/ssl/private/dovecot.pem ]]; then
+ einfo "Generating X.509 certificate for SSL"
+ pushd doc >/dev/null && \
+ SSLDIR="${D}"/etc/ssl sh mkcert.sh && \
+ popd >/dev/null
+ fi
+ fi
+
+ dodir /var/run/dovecot
+ fowners root:0 /var/run/dovecot
+ fperms 0700 /var/run/dovecot
+ keepdir /var/run/dovecot/login
+ fowners root:dovecot /var/run/dovecot/login
+ fperms 0750 /var/run/dovecot/login
+}
+
+get_config_var() {
+ sed -n 's/^[[:space:]]\?base_dir[[:space:]]*="*\([^#"]\+\)"*/\1/p' \
+ /etc/dovecot.conf
+}
+
+pkg_postinst() {
+ einfo "The dovecot configuration has vastly changed since 0.99."
+ einfo "You are encouraged to start afresh with a new configuration file."
+ einfo "see http://wiki.dovecot.org/ for configuration examples."
+
+ local base_dir="$(get_config_var base_dir)"
+ base_dir="${basedir:-/var/run/dovecot}"
+ if use ssl \
+ && [[ ! -e "${ROOT}/${base_dir}/login/ssl-parameters.dat" ]] ; then
+ einfo
+ einfo "Dovecot requires DH SSL Parameters if you use SSL connections"
+ einfo "These take some time to make, and dovecot will create them before"
+ einfo "it allows any SSL connections."
+ einfo "You can create them now before starting dovecot like so"
+ einfo " emerge --config =${PF}"
+ fi
+}
+
+pkg_config() {
+ local base_dir="$(get_config_var base_dir)"
+ base_dir="${base_dir:-/var/run/dovecot}"
+
+ einfo "Regenerating SSL parameters. This will take some time."
+ /usr/libexec/dovecot/ssl-build-param "${base_dir}/login/ssl-parameters.dat"
+}
diff --git a/net-mail/dovecot/files/digest-dovecot-1.0_rc6 b/net-mail/dovecot/files/digest-dovecot-1.0_rc6
new file mode 100644
index 000000000000..96ec78f2aa02
--- /dev/null
+++ b/net-mail/dovecot/files/digest-dovecot-1.0_rc6
@@ -0,0 +1,3 @@
+MD5 5c71b673d571e87bc084c494980e20a8 dovecot-1.0.rc6.tar.gz 1268328
+RMD160 ddf49eece71d8766f994058ead1bed8410a9ee51 dovecot-1.0.rc6.tar.gz 1268328
+SHA256 9b61a55c36975aa587ad96082e5fcf1458d6f0999455c126b3c523845b608401 dovecot-1.0.rc6.tar.gz 1268328
diff --git a/net-mail/dovecot/files/dovecot-1.0_rc6-proxy-ssl.patch b/net-mail/dovecot/files/dovecot-1.0_rc6-proxy-ssl.patch
new file mode 100644
index 000000000000..7bd1516e2b94
--- /dev/null
+++ b/net-mail/dovecot/files/dovecot-1.0_rc6-proxy-ssl.patch
@@ -0,0 +1,12 @@
+diff -ur dovecot-1.0.rc6.orig/src/login-common/ssl-proxy-openssl.c dovecot-1.0.rc6/src/login-common/ssl-proxy-openssl.c
+--- dovecot-1.0.rc6.orig/src/login-common/ssl-proxy-openssl.c 2006-08-08 10:39:34.194002880 +0100
++++ dovecot-1.0.rc6/src/login-common/ssl-proxy-openssl.c 2006-08-08 10:40:37.000000000 +0100
+@@ -654,7 +654,7 @@
+
+ unsigned int ssl_proxy_get_count(void)
+ {
+- return hash_size(ssl_proxies);
++ return ssl_proxies == NULL ? 0 : hash_size(ssl_proxies);
+ }
+
+ void ssl_proxy_init(void)