summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-04-07 00:11:12 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-04-07 00:11:12 +0000
commit811b756b276986e35513d8a6062410231ff28ae3 (patch)
tree43f6fec8e08059cf8f3294a18f8bfcc50954f073 /net-misc/adjtimex
parentBump media-sound/beets to 1.1.0_beta3, remove old version (diff)
downloadgentoo-2-811b756b276986e35513d8a6062410231ff28ae3.tar.gz
gentoo-2-811b756b276986e35513d8a6062410231ff28ae3.tar.bz2
gentoo-2-811b756b276986e35513d8a6062410231ff28ae3.zip
BL2 support per bug #395839.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-misc/adjtimex')
-rw-r--r--net-misc/adjtimex/ChangeLog11
-rw-r--r--net-misc/adjtimex/adjtimex-1.29-r1.ebuild59
-rw-r--r--net-misc/adjtimex/files/adjtimex-1.29-r1-gentoo-utc.patch30
3 files changed, 97 insertions, 3 deletions
diff --git a/net-misc/adjtimex/ChangeLog b/net-misc/adjtimex/ChangeLog
index fc5fdfdbb887..a8dc7b174a74 100644
--- a/net-misc/adjtimex/ChangeLog
+++ b/net-misc/adjtimex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/adjtimex
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/ChangeLog,v 1.26 2010/08/26 20:43:55 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/ChangeLog,v 1.27 2013/04/07 00:11:12 robbat2 Exp $
+
+*adjtimex-1.29-r1 (07 Apr 2013)
+
+ 07 Apr 2013; Robin H. Johnson <robbat2@gentoo.org> +adjtimex-1.29-r1.ebuild,
+ +files/adjtimex-1.29-r1-gentoo-utc.patch:
+ BL2 support per bug #395839.
26 Aug 2010; Jeroen Roovers <jer@gentoo.org> adjtimex-1.29.ebuild:
Remove commented patch calls.
@@ -109,4 +115,3 @@
05 Jan 2004; Robin H. Johnson <robbat2@gentoo.org> adjtimex-1.16.ebuild,
files/adjtimex.init:
initial commit, ebuild by robbat2@gentoo.org, solves bug #8459
-
diff --git a/net-misc/adjtimex/adjtimex-1.29-r1.ebuild b/net-misc/adjtimex/adjtimex-1.29-r1.ebuild
new file mode 100644
index 000000000000..572a841e0258
--- /dev/null
+++ b/net-misc/adjtimex/adjtimex-1.29-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/adjtimex-1.29-r1.ebuild,v 1.1 2013/04/07 00:11:12 robbat2 Exp $
+
+EAPI="2"
+
+inherit eutils fixheadtails toolchain-funcs
+
+DEBIAN_PV="2"
+MY_P="${P/-/_}"
+DEBIAN_URI="mirror://debian/pool/main/${PN:0:1}/${PN}"
+DEBIAN_PATCH="${MY_P}-${DEBIAN_PV}.diff.gz"
+DEBIAN_SRC="${MY_P}.orig.tar.gz"
+DESCRIPTION="display or set the kernel time variables"
+HOMEPAGE="http://www.ibiblio.org/linsearch/lsms/adjtimex.html"
+SRC_URI="${DEBIAN_URI}/${DEBIAN_PATCH}
+ ${DEBIAN_URI}/${DEBIAN_SRC}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND=""
+
+src_prepare() {
+ cd "${WORKDIR}"
+ epatch "${DISTDIR}"/${DEBIAN_PATCH}
+ cd "${S}"
+ for i in debian/adjtimexconfig debian/adjtimexconfig.8 ; do
+ sed -e 's|/etc/default/adjtimex|/etc/conf.d/adjtimex|' \
+ -i.orig ${i}
+ sed -e 's|^/sbin/adjtimex |/usr/sbin/adjtimex |' \
+ -i.orig ${i}
+ done
+ epatch "${FILESDIR}"/${PN}-1.29-r1-gentoo-utc.patch
+ ht_fix_file debian/adjtimexconfig
+ sed -i \
+ -e '/CFLAGS = -Wall -t/,/endif/d' \
+ -e '/$(CC).* -o/s|$(CFLAGS)|& $(LDFLAGS)|g' \
+ Makefile.in || die "sed Makefile.in"
+}
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dodoc README* ChangeLog
+ doman adjtimex.8 debian/adjtimexconfig.8
+ dosbin adjtimex debian/adjtimexconfig
+ newinitd "${FILESDIR}"/adjtimex.init adjtimex
+}
+
+pkg_postinst() {
+ einfo "Please run adjtimexconfig to create the configuration file"
+}
diff --git a/net-misc/adjtimex/files/adjtimex-1.29-r1-gentoo-utc.patch b/net-misc/adjtimex/files/adjtimex-1.29-r1-gentoo-utc.patch
new file mode 100644
index 000000000000..ac8730d1ee7d
--- /dev/null
+++ b/net-misc/adjtimex/files/adjtimex-1.29-r1-gentoo-utc.patch
@@ -0,0 +1,30 @@
+--- adjtimex-1.29-debian/debian/adjtimexconfig 2011-12-23 21:29:32.962449759 +0100
++++ adjtimex-1.29/debian/adjtimexconfig 2011-12-23 21:30:00.610638657 +0100
+@@ -3,6 +3,18 @@
+ conffile=/etc/default/adjtimex
+ startfile=/etc/init.d/adjtimex
+
++# Get UTC setting
++params=''
++if [ -f /etc/conf.d/clock ]; then
++ #baselayout-1
++ source /etc/conf.d/clock
++ [ "$CLOCK" == "UTC" ] && params='--utc'
++elif [ -f /etc/conf.d/hwclock ]; then
++ #baselayout-2
++ source /etc/conf.d/hwclock
++ [ "$clock" == "UTC" ] && params='--utc'
++fi
++
+ echo -n "Comparing clocks (this will take 70 sec)..."
+
+ # Get the parameters
+@@ -11,7 +23,7 @@
+ baseline=`awk '/<= tick/{print ($1+$NF)/2}' /etc/adj.adjust`
+ hz=`awk '/USER_HZ/{print $3}' /etc/adj.adjust`
+ /usr/sbin/adjtimex --tick $baseline --frequency 0
+-/usr/sbin/adjtimex --adjust --force-adjust >/etc/adj.adjust
++/usr/sbin/adjtimex ${params} --adjust --force-adjust >/etc/adj.adjust
+ echo "done."
+ ticks=`tail -n 1 /etc/adj.adjust|awk '{print $6}'`
+ freq=`tail -n 1 /etc/adj.adjust|awk '{print $7}'`