summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-08-31 00:11:41 +0000
committerMichael Weber <xmw@gentoo.org>2010-08-31 00:11:41 +0000
commitb7ca76dc3800cfda2d098ac8932fd8310e4f7d0d (patch)
tree56654344d51e03b1acf2e4b479f54492174c33ad /net-misc/aget
parentRemove wrong inherit. (diff)
downloadgentoo-2-b7ca76dc3800cfda2d098ac8932fd8310e4f7d0d.tar.gz
gentoo-2-b7ca76dc3800cfda2d098ac8932fd8310e4f7d0d.tar.bz2
gentoo-2-b7ca76dc3800cfda2d098ac8932fd8310e4f7d0d.zip
Version bump, fixed bug #327591
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/aget')
-rw-r--r--net-misc/aget/ChangeLog8
-rw-r--r--net-misc/aget/aget-0.4.1.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/net-misc/aget/ChangeLog b/net-misc/aget/ChangeLog
index 16b2ba484833..3d6339431a2b 100644
--- a/net-misc/aget/ChangeLog
+++ b/net-misc/aget/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/aget
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aget/ChangeLog,v 1.15 2010/01/07 15:45:03 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aget/ChangeLog,v 1.16 2010/08/31 00:11:41 xmw Exp $
+
+*aget-0.4.1 (30 Aug 2010)
+
+ 30 Aug 2010; Michael Weber <xmw@gentoo.org> +aget-0.4.1.ebuild:
+ Version bump, fixed bug #327591, thanks to Jens Rutschmann
+ <Jens.Rutschmann@gmx.info> for the update. Die more, respect CC.
07 Jan 2010; Christian Faulhammer <fauli@gentoo.org> aget-0.4.ebuild:
Transfer Prefix keywords
diff --git a/net-misc/aget/aget-0.4.1.ebuild b/net-misc/aget/aget-0.4.1.ebuild
new file mode 100644
index 000000000000..d1e1d4eea1f5
--- /dev/null
+++ b/net-misc/aget/aget-0.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aget/aget-0.4.1.ebuild,v 1.1 2010/08/31 00:11:41 xmw Exp $
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="multithreaded HTTP download accelerator"
+HOMEPAGE="http://www.enderunix.org/aget/"
+SRC_URI="http://www.enderunix.org/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e '3s/$/DESTDIR =/' \
+ -e '/^CFLAGS/s:=.*:+= -Wall $(CPPFLAGS):' \
+ -e '/^LDFLAGS/s:=:+=:' \
+ -e '/^\tcp -f aget /s:\/usr.*:\$(DESTDIR)\/usr\/bin:' Makefile || die
+ sed -i -e '/_XOPEN_SOURCE/d' Head.c || die
+ sed -i -e 's/http\/\//http:\/\//' Misc.c || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin aget || die
+ dodoc AUTHORS ChangeLog README* THANKS TODO || die
+ doman aget.1 || die
+}