summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-09-26 19:05:10 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-09-26 19:05:10 +0000
commita046b9fb74512be95713ed417686aac34442ec1b (patch)
treec0253417cb024c56ae8d47872458f22aee137cba /net-misc/arm
parent>=sys-devel/binutils-2.21.1 exhibits -ldl problem on FreeBSD (diff)
downloadgentoo-2-a046b9fb74512be95713ed417686aac34442ec1b.tar.gz
gentoo-2-a046b9fb74512be95713ed417686aac34442ec1b.tar.bz2
gentoo-2-a046b9fb74512be95713ed417686aac34442ec1b.zip
Version bump
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/arm')
-rw-r--r--net-misc/arm/ChangeLog7
-rw-r--r--net-misc/arm/arm-1.4.4.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/net-misc/arm/ChangeLog b/net-misc/arm/ChangeLog
index a386e6eb83e7..d9b929f93d37 100644
--- a/net-misc/arm/ChangeLog
+++ b/net-misc/arm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/arm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/ChangeLog,v 1.13 2011/09/04 10:10:15 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/ChangeLog,v 1.14 2011/09/26 19:05:10 blueness Exp $
+
+*arm-1.4.4.0 (26 Sep 2011)
+
+ 26 Sep 2011; Anthony G. Basile <blueness@gentoo.org> +arm-1.4.4.0.ebuild:
+ Version bump
04 Sep 2011; Markus Meier <maekke@gentoo.org> arm-1.4.3.0.ebuild:
x86 stable, bug #380075
diff --git a/net-misc/arm/arm-1.4.4.0.ebuild b/net-misc/arm/arm-1.4.4.0.ebuild
new file mode 100644
index 000000000000..17a3fd054013
--- /dev/null
+++ b/net-misc/arm/arm-1.4.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/arm-1.4.4.0.ebuild,v 1.1 2011/09/26 19:05:10 blueness Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="ncurses"
+
+inherit python distutils
+
+DESCRIPTION="A ncurses-based status monitor for Tor relays"
+HOMEPAGE="http://www.atagar.com/arm/"
+SRC_URI="http://www.atagar.com/arm/resources/static/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-misc/tor-0.2.1.27"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install --docPath "${EPREFIX}"/usr/share/doc/${PF}
+}
+
+pkg_postinst() {
+ elog "Some graphing data issues have been noted in testing"
+ elog "when run as root. It is not recommended to run arm as"
+ elog "root until those issues have been isolated and fixed."
+ elog
+ elog "Trouble with graphs under app-misc/screen? Try:"
+ elog 'TERM="rxvt-unicode" arm'
+}