summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-07-17 12:52:24 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-07-17 12:52:24 +0000
commitc4b1693384adde0a13727366f480990a905b50bf (patch)
treecc89720fe99b1ed50418f0be882884c156f21e84 /net-misc/arm
parentUse pkg-config for blas/lapack detection, #262143 (diff)
downloadgentoo-2-c4b1693384adde0a13727366f480990a905b50bf.tar.gz
gentoo-2-c4b1693384adde0a13727366f480990a905b50bf.tar.bz2
gentoo-2-c4b1693384adde0a13727366f480990a905b50bf.zip
Version bump
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/arm')
-rw-r--r--net-misc/arm/ChangeLog7
-rw-r--r--net-misc/arm/arm-1.4.3.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/net-misc/arm/ChangeLog b/net-misc/arm/ChangeLog
index d7a9800718aa..d4f892079646 100644
--- a/net-misc/arm/ChangeLog
+++ b/net-misc/arm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/arm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/ChangeLog,v 1.10 2011/05/15 13:40:53 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/ChangeLog,v 1.11 2011/07/17 12:52:24 blueness Exp $
+
+*arm-1.4.3.0 (17 Jul 2011)
+
+ 17 Jul 2011; Anthony G. Basile <blueness@gentoo.org> +arm-1.4.3.0.ebuild:
+ Version bump
15 May 2011; Anthony G. Basile <blueness@gentoo.org> -arm-1.4.2.2.ebuild:
Removed older version
diff --git a/net-misc/arm/arm-1.4.3.0.ebuild b/net-misc/arm/arm-1.4.3.0.ebuild
new file mode 100644
index 000000000000..4ebc42eeb4cf
--- /dev/null
+++ b/net-misc/arm/arm-1.4.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/arm-1.4.3.0.ebuild,v 1.1 2011/07/17 12:52:24 blueness Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="ncurses"
+
+inherit python distutils
+
+DESCRIPTION="A ncurses-based status monitor for Tor relays"
+HOMEPAGE="http://www.atagar.com/arm/"
+SRC_URI="http://www.atagar.com/arm/resources/static/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-misc/tor-0.2.1.27"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install --docPath "${EPREFIX}"/usr/share/doc/${PF}
+}
+
+pkg_postinst() {
+ elog "Some graphing data issues have been noted in testing"
+ elog "when run as root. It is not recommended to run arm as"
+ elog "root until those issues have been isolated and fixed."
+ elog
+ elog "Trouble with graphs under app-misc/screen? Try:"
+ elog 'TERM="rxvt-unicode" arm'
+}