summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-09-09 18:58:28 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-09-09 18:58:28 +0000
commit979895ae788340c9c94ba36a6f7501f867db56b7 (patch)
treee063e94322c4d919623efc9a06c3d2b03d7a45e5 /net-misc/asterisk-sounds
parentMasked asterisk-sounds-1.2.0_beta1. (diff)
downloadgentoo-2-979895ae788340c9c94ba36a6f7501f867db56b7.tar.gz
gentoo-2-979895ae788340c9c94ba36a6f7501f867db56b7.tar.bz2
gentoo-2-979895ae788340c9c94ba36a6f7501f867db56b7.zip
Version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-misc/asterisk-sounds')
-rw-r--r--net-misc/asterisk-sounds/ChangeLog9
-rw-r--r--net-misc/asterisk-sounds/asterisk-sounds-1.2.0_beta1.ebuild43
-rw-r--r--net-misc/asterisk-sounds/files/asterisk-sounds-1.2.0_beta1-description.diff47
-rw-r--r--net-misc/asterisk-sounds/files/digest-asterisk-sounds-1.2.0_beta11
4 files changed, 99 insertions, 1 deletions
diff --git a/net-misc/asterisk-sounds/ChangeLog b/net-misc/asterisk-sounds/ChangeLog
index 79c935e0afb4..344261dc85c1 100644
--- a/net-misc/asterisk-sounds/ChangeLog
+++ b/net-misc/asterisk-sounds/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/asterisk-sounds
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-sounds/ChangeLog,v 1.4 2005/06/25 09:53:34 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-sounds/ChangeLog,v 1.5 2005/09/09 18:58:28 stkn Exp $
+
+*asterisk-sounds-1.2.0_beta1 (09 Sep 2005)
+
+ 09 Sep 2005; Stefan Knoblich <stkn@gentoo.org>
+ +files/asterisk-sounds-1.2.0_beta1-description.diff,
+ +asterisk-sounds-1.2.0_beta1.ebuild:
+ Version bump.
*asterisk-sounds-1.0.8 (25 Jun 2005)
diff --git a/net-misc/asterisk-sounds/asterisk-sounds-1.2.0_beta1.ebuild b/net-misc/asterisk-sounds/asterisk-sounds-1.2.0_beta1.ebuild
new file mode 100644
index 000000000000..4ae0481dd7db
--- /dev/null
+++ b/net-misc/asterisk-sounds/asterisk-sounds-1.2.0_beta1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-sounds/asterisk-sounds-1.2.0_beta1.ebuild,v 1.1 2005/09/09 18:58:28 stkn Exp $
+
+inherit eutils
+
+IUSE=""
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Additional sounds for Asterisk"
+HOMEPAGE="http://www.asterisk.org/"
+SRC_URI="http://ftp.digium.com/pub/asterisk/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~hppa ~amd64 ~ppc"
+
+DEPEND="net-misc/asterisk"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # some descriptions missing are missing the .gsm extension, fix them
+ # make install fails otherwise
+ epatch ${FILESDIR}/${P}-description.diff
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Make install failed"
+
+ dodoc README.txt sounds-extra.txt
+
+ # fix permissions
+ if has_version ">=net-misc/asterisk-1.0.5-r2"; then
+ chown -R asterisk:asterisk ${D}var/lib/asterisk
+ chmod -R u=rwX,g=rX,o= ${D}var/lib/asterisk
+ fi
+}
diff --git a/net-misc/asterisk-sounds/files/asterisk-sounds-1.2.0_beta1-description.diff b/net-misc/asterisk-sounds/files/asterisk-sounds-1.2.0_beta1-description.diff
new file mode 100644
index 000000000000..79ddcc94964b
--- /dev/null
+++ b/net-misc/asterisk-sounds/files/asterisk-sounds-1.2.0_beta1-description.diff
@@ -0,0 +1,47 @@
+--- asterisk-sounds-1.2.0-beta1/sounds-extra.txt.orig 2005-09-09 20:39:54.000000000 +0200
++++ asterisk-sounds-1.2.0-beta1/sounds-extra.txt 2005-09-09 20:40:50.000000000 +0200
+@@ -2117,30 +2117,30 @@
+ %wind-chill.gsm%wind chill
+ %winds.gsm%winds
+
+-%route-sip%Your call is being routed over SIP.
++%route-sip.gsm%Your call is being routed over SIP.
+
+-%not-yet-connected%is not yet connected.
++%not-yet-connected.gsm%is not yet connected.
+
+-%units%units
++%units.gsm%units
+
+-%sorry%We're sorry.
++%sorry.gsm%We're sorry.
+
+-%sorry2%We're sorry, but we are not able to answer your call at this time.
++%sorry2.gsm%We're sorry, but we are not able to answer your call at this time.
+
+-%thanks-for-calling-today%Thanks for calling today.
++%thanks-for-calling-today.gsm%Thanks for calling today.
+
+-%wait-moment%Please wait a moment.
++%wait-moment.gsm%Please wait a moment.
+
+-%you-have-dialed%You have dialed:
++%you-have-dialed.gsm%You have dialed:
+
+-%access-code%Access code:
++%access-code.gsm%Access code:
+
+-%portnumber%port number
++%portnumber.gsm%port number
+
+-%protocol%protocol
++%protocol.gsm%protocol
+
+-%pls-hold-silent30%Please hold (silence for 30 seconds)
++%pls-hold-silent30.gsm%Please hold (silence for 30 seconds)
+
+-%echo-test%You will now hear your own voice in an echo test.
++%echo-test.gsm%You will now hear your own voice in an echo test.
+
+-%this-call-will-end-in%This call will end in
++%this-call-will-end-in.gsm%This call will end in
diff --git a/net-misc/asterisk-sounds/files/digest-asterisk-sounds-1.2.0_beta1 b/net-misc/asterisk-sounds/files/digest-asterisk-sounds-1.2.0_beta1
new file mode 100644
index 000000000000..0dc023e242e8
--- /dev/null
+++ b/net-misc/asterisk-sounds/files/digest-asterisk-sounds-1.2.0_beta1
@@ -0,0 +1 @@
+MD5 dc8004fea4c880dbec32e08f4da07b1b asterisk-sounds-1.2.0-beta1.tar.gz 3246231