summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-08-14 20:08:55 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-08-14 20:08:55 +0000
commit999550a16324ed2671e17675b15b12cd4308dfbc (patch)
treec33c79f984ce2afde4ec71b7ded45b1830eaf6df /net-misc/bird
parentMore complete ebuild and initialization script. Now downloads the correct tar... (diff)
downloadgentoo-2-999550a16324ed2671e17675b15b12cd4308dfbc.tar.gz
gentoo-2-999550a16324ed2671e17675b15b12cd4308dfbc.tar.bz2
gentoo-2-999550a16324ed2671e17675b15b12cd4308dfbc.zip
Bump eapi on bird to latest as dicussed on council meeting. Acked by chainsaw.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/bird')
-rw-r--r--net-misc/bird/ChangeLog8
-rw-r--r--net-misc/bird/bird-1.3.8-r1.ebuild62
2 files changed, 68 insertions, 2 deletions
diff --git a/net-misc/bird/ChangeLog b/net-misc/bird/ChangeLog
index a194d0cb672f..a2b37bea4119 100644
--- a/net-misc/bird/ChangeLog
+++ b/net-misc/bird/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/bird
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/ChangeLog,v 1.20 2012/08/13 10:54:49 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/ChangeLog,v 1.21 2012/08/14 20:08:55 scarabeus Exp $
+
+*bird-1.3.8-r1 (14 Aug 2012)
+
+ 14 Aug 2012; Tomáš Chvátal <scarabeus@gentoo.org> +bird-1.3.8-r1.ebuild:
+ Bump eapi on bird to latest as dicussed on council meeting. Acked by chainsaw.
*bird-1.3.8 (13 Aug 2012)
@@ -157,4 +162,3 @@
Resurrected ebuild that was in the tree earlier. With thanks to Chet
McNeill <chet@somedec.com> in bug #122823 for an initial ebuild and patch
set.
-
diff --git a/net-misc/bird/bird-1.3.8-r1.ebuild b/net-misc/bird/bird-1.3.8-r1.ebuild
new file mode 100644
index 000000000000..87f843abaf4c
--- /dev/null
+++ b/net-misc/bird/bird-1.3.8-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/bird-1.3.8-r1.ebuild,v 1.1 2012/08/14 20:08:55 scarabeus Exp $
+
+EAPI=4
+
+DESCRIPTION="A routing daemon implementing OSPF, RIPv2 & BGP for IPv4 or IPv6"
+HOMEPAGE="http://bird.network.cz"
+SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ipv6"
+
+RDEPEND="sys-libs/ncurses
+ sys-libs/readline"
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-devel/m4"
+
+src_prepare() {
+ mkdir ipv6
+ tar c --exclude ipv6 . | tar x -C ipv6
+}
+
+src_configure() {
+ econf \
+ --enable-client \
+ --disable-ipv6 \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable debug)
+
+ if use ipv6; then
+ cd ipv6
+ econf \
+ --enable-client \
+ --enable-ipv6 \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable debug)
+ fi
+}
+
+src_compile() {
+ emake
+ if use ipv6; then
+ cd ipv6
+ emake
+ fi
+}
+
+src_install() {
+ if use ipv6; then
+ newbin ipv6/birdc birdc6
+ newbin ipv6/bird bird6
+ newinitd "${FILESDIR}/initd-v6-${P}" bird6
+ fi
+ dobin birdc
+ dosbin bird
+ newinitd "${FILESDIR}/initd-v4-${P}" bird
+ dodoc doc/bird.conf.example
+}