summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-08-24 18:53:16 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-08-24 18:53:16 +0000
commitb815a475639945f8ed1a859ff46d29000a4c5b40 (patch)
tree2d52e8d48bbb920c3d30b746901fcd26425c1df8 /net-misc/cfengine
parentAdd missing virtual/pkgconfig dep wrt bug #432616. (diff)
downloadgentoo-2-b815a475639945f8ed1a859ff46d29000a4c5b40.tar.gz
gentoo-2-b815a475639945f8ed1a859ff46d29000a4c5b40.tar.bz2
gentoo-2-b815a475639945f8ed1a859ff46d29000a4c5b40.zip
Version bump
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/cfengine')
-rw-r--r--net-misc/cfengine/ChangeLog8
-rw-r--r--net-misc/cfengine/cfengine-2.2.10-r3.ebuild107
-rw-r--r--net-misc/cfengine/cfengine-3.1.4.ebuild156
-rw-r--r--net-misc/cfengine/cfengine-3.3.5.ebuild (renamed from net-misc/cfengine/cfengine-3.3.4.ebuild)2
4 files changed, 8 insertions, 265 deletions
diff --git a/net-misc/cfengine/ChangeLog b/net-misc/cfengine/ChangeLog
index 452927a06107..cba5a0538987 100644
--- a/net-misc/cfengine/ChangeLog
+++ b/net-misc/cfengine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/cfengine
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/ChangeLog,v 1.158 2012/07/30 14:14:10 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/ChangeLog,v 1.159 2012/08/24 18:53:16 idl0r Exp $
+
+*cfengine-3.3.5 (24 Aug 2012)
+
+ 24 Aug 2012; Christian Ruppert <idl0r@gentoo.org> -cfengine-2.2.10-r3.ebuild,
+ -cfengine-3.1.4.ebuild, -cfengine-3.3.4.ebuild, +cfengine-3.3.5.ebuild:
+ Version bump
30 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
cfengine-2.2.10-r4.ebuild, cfengine-3.2.4.ebuild:
diff --git a/net-misc/cfengine/cfengine-2.2.10-r3.ebuild b/net-misc/cfengine/cfengine-2.2.10-r3.ebuild
deleted file mode 100644
index 95f68d07aab4..000000000000
--- a/net-misc/cfengine/cfengine-2.2.10-r3.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-2.2.10-r3.ebuild,v 1.7 2012/06/04 19:25:34 idl0r Exp $
-
-EAPI="2"
-
-inherit eutils multilib
-
-DESCRIPTION="An automated suite of programs for configuring and maintaining
-Unix-like computers"
-HOMEPAGE="http://www.cfengine.org/"
-SRC_URI="http://cfengine.com/source_code/download?file=${P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ~s390 sparc x86"
-IUSE="vim-syntax"
-
-DEPEND=">=sys-libs/db-4
- >=dev-libs/openssl-0.9.7
- app-portage/portage-utils"
-RDEPEND="${DEPEND}"
-PDEPEND="vim-syntax? ( app-vim/cfengine-syntax )"
-
-src_prepare() {
- # http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=520696
- # http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=511666
- # http://bugs.gentoo.org/339808
- epatch "${FILESDIR}/admit-noclass-520696.patch" \
- "${FILESDIR}/511666-segfault.patch" \
- "${FILESDIR}/${P}-snprintf_buffer_overflow.patch"
-}
-
-src_configure() {
- # Enforce /var/cfengine for historical compatibility
- econf \
- --with-workdir=/var/cfengine \
- --with-berkeleydb=/usr
-
- # Fix Makefile to skip doc,inputs, & contrib install to wrong locations
- sed -i -e 's/\(DIST_SUBDIRS.*\) contrib inputs doc/\1/' Makefile
- sed -i -e 's/\(SUBDIRS.*\) contrib inputs/\1/' Makefile
- sed -i -e 's/\(install-data-am.*\) install-docDATA/\1/' Makefile
-
- # Fix man pages
- sed -i -e 's/\/usr\/local/\/usr/' doc/*.8
-}
-
-src_install() {
- newinitd "${FILESDIR}"/cfservd.rc6 cfservd || die
- newinitd "${FILESDIR}"/cfenvd.rc6 cfenvd || die
- newinitd "${FILESDIR}"/cfexecd.rc6 cfexecd || die
-
- make DESTDIR="${D}" install || die
-
- # Remove static library and libtool file as they are not needed
- rm "${D}"/usr/$(get_libdir)/*.la
- rm "${D}"/usr/$(get_libdir)/*.a
-
- dodoc AUTHORS ChangeLog README TODO INSTALL
-
- # Manually install doc and inputs
- doman doc/*.8
- docinto examples
- doinfo doc/*.info*
- dodoc inputs/*.example
-
- # Create cfengine working directory
- mkdir -p "${D}"/var/cfengine
- fperms 700 /var/cfengine
- keepdir /var/cfengine/bin
- keepdir /var/cfengine/inputs
- dodir /var/cfengine/modules
-}
-
-pkg_postinst() {
- # Copy cfagent into the cfengine tree otherwise cfexecd won't
- # find it. Most hosts cache their copy of the cfengine
- # binaries here. This is the default search location for the
- # binaries.
-
- cp -f /usr/sbin/cf{agent,servd,execd} "${ROOT}"/var/cfengine/bin/
-
- einfo
- einfo "NOTE: The cfportage module has been deprecated in favor of the"
- einfo " upstream 'packages' action."
- einfo
- einfo "Init scripts for cfservd, cfenvd, and cfexecd are now provided."
- einfo
- einfo "To run cfengine out of cron every half hour modify your crontab:"
- einfo "0,30 * * * * /usr/sbin/cfexecd -F"
- einfo
-
- elog "You MUST generate the keys for cfengine by running:"
- elog "emerge --config ${CATEGORY}/${PN}"
-}
-
-pkg_config() {
- if [ "${ROOT}" == "/" ]; then
- if [ ! -f "/var/cfengine/ppkeys/localhost.priv" ]; then
- einfo "Generating keys for localhost."
- /usr/sbin/cfkey
- fi
- else
- die "cfengine cfkey does not support any value of ROOT other than /."
- fi
-}
diff --git a/net-misc/cfengine/cfengine-3.1.4.ebuild b/net-misc/cfengine/cfengine-3.1.4.ebuild
deleted file mode 100644
index 3c94bc992085..000000000000
--- a/net-misc/cfengine/cfengine-3.1.4.ebuild
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-3.1.4.ebuild,v 1.7 2012/05/05 21:36:03 ranger Exp $
-
-EAPI="3"
-
-MY_PV="${PV//_beta/b}"
-MY_PV="${MY_PV/_p/p}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="An automated suite of programs for configuring and maintaining
-Unix-like computers"
-HOMEPAGE="http://www.cfengine.org/"
-SRC_URI="http://cfengine.com/source_code/download?file=${MY_P}.tar.gz -> ${MY_P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="3"
-KEYWORDS="amd64 arm ppc ~s390 sparc x86"
-
-# libvirt disabled for now because it blocks stabilization etc.
-IUSE="examples gd graphviz html ldap mysql postgres qdbm selinux tests tokyocabinet vim-syntax"
-
-# libvirt? ( app-emulation/libvirt )
-DEPEND=">=sys-libs/db-4
- gd? ( media-libs/gd )
- graphviz? ( media-gfx/graphviz )
- ldap? ( net-nds/openldap )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-base )
- selinux? ( sys-libs/libselinux )
- tokyocabinet? ( dev-db/tokyocabinet )
- !tokyocabinet? ( qdbm? ( dev-db/qdbm ) )
- !tokyocabinet? ( !qdbm? ( >=sys-libs/db-4 ) )
- >=dev-libs/openssl-0.9.7
- dev-libs/libpcre"
-RDEPEND="${DEPEND}"
-PDEPEND="vim-syntax? ( app-vim/cfengine-syntax )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- local myconf
-
- if use mysql || use postgres ; then
- myconf="--with-sql"
- else
- myconf="--without-sql"
- fi
-
- # BDB by default, prefer tokyocabinet above qdbm...
- if ! use qdbm && ! use tokyocabinet; then
- myconf="${myconf} --with-berkeleydb=/usr"
- elif use qdbm && use tokyocabinet; then
- elog "QDBM and Tokyo Cabinet can't be used together, using Tokyo Cabinet by default"
- myconf="${myconf} --with-tokyocabinet"
- elif use qdbm && ! use tokyocabinet; then
- myconf="${myconf} --with-qdbm"
- elif ! use qdbm && use tokyocabinet; then
- myconf="${myconf} --with-tokyocabinet"
- fi
-
- # Enforce /var/cfengine for historical compatibility
- # $(use_with libvirt) \
- econf \
- --docdir=/usr/share/doc/"${PF}" \
- --with-workdir=/var/cfengine \
- --with-pcre \
- ${myconf} \
- $(use_with gd) \
- $(use_with graphviz) \
- $(use_with ldap) \
- $(use_enable selinux)
-
- # Fix Makefile to skip inputs, see below "examples"
- sed -i -e 's/\(SUBDIRS.*\) inputs/\1/' Makefile || die
-
- # We install documentation through portage
- sed -i -e 's/\(install-data-am.*\) install-docDATA/\1/' Makefile || die
-
- if use tests; then
- # Fix Makefiles to install tests in correct directory
- for i in file_masters file_operands units ; do
- sed -i -e "s/\(docdir.*\) =.*/\1 = \/usr\/share\/doc\/${PF}\/tests\/${i}/" \
- tests/${i}/Makefile || die
- done
- else
- sed -i -e 's/\(SUBDIRS =\).*/\1/' tests/Makefile || die
- fi
-}
-
-src_install() {
- newinitd "${FILESDIR}"/cf-serverd.rc6 cf-serverd || die
- newinitd "${FILESDIR}"/cf-monitord.rc6 cf-monitord || die
- newinitd "${FILESDIR}"/cf-execd.rc6 cf-execd || die
-
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README TODO INSTALL
-
- if use examples; then
- docinto examples
- dodoc inputs/*.cf || die
- fi
-
- # Create cfengine working directory
- dodir /var/cfengine/bin
- fperms 700 /var/cfengine
-
- # Copy cfagent into the cfengine tree otherwise cfexecd won't
- # find it. Most hosts cache their copy of the cfengine
- # binaries here. This is the default search location for the
- # binaries.
- for bin in know promises agent monitord serverd execd runagent key report; do
- dosym /usr/sbin/cf-$bin /var/cfengine/bin/cf-$bin || die
- done
-
- if use html; then
- docinto html
- dohtml -r docs/ || die
- fi
-}
-
-pkg_postinst() {
- echo
- einfo "Init scripts for cf-serverd, cf-monitord, and cf-execd are provided."
- einfo
- einfo "To run cfengine out of cron every half hour modify your crontab:"
- einfo "0,30 * * * * /usr/sbin/cf-execd -F"
- echo
-
- elog "If you run cfengine the very first time, you MUST generate the keys for cfengine by running:"
- elog "emerge --config ${CATEGORY}/${PN}"
-
- # Fix old cf-servd, remove it after some releases.
- local found=0
- for fname in $(find /etc/runlevels/ -type f -or -type l -name 'cf-servd'); do
- found=1
- rm $fname
- ln -s /etc/init.d/cf-serverd $(echo $fname | sed 's:cf-servd:cf-serverd:')
- done
-
- if [ "${found}" -eq 1 ]; then
- echo
- elog "/etc/init.d/cf-servd has been renamed to /etc/init.d/cf-serverd"
- fi
-}
-
-pkg_config() {
- if [ "${ROOT}" == "/" ]; then
- if [ ! -f "/var/cfengine/ppkeys/localhost.priv" ]; then
- einfo "Generating keys for localhost."
- /usr/sbin/cf-key
- fi
- else
- die "cfengine cfkey does not support any value of ROOT other than /."
- fi
-}
diff --git a/net-misc/cfengine/cfengine-3.3.4.ebuild b/net-misc/cfengine/cfengine-3.3.5.ebuild
index 9b4cd2ea2657..39349af3ebcf 100644
--- a/net-misc/cfengine/cfengine-3.3.4.ebuild
+++ b/net-misc/cfengine/cfengine-3.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-3.3.4.ebuild,v 1.1 2012/06/24 19:59:54 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-3.3.5.ebuild,v 1.1 2012/08/24 18:53:16 idl0r Exp $
EAPI="4"