summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-24 09:37:12 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-24 09:37:12 +0000
commit0641b2f01f55647573d90f159412a77aa57e8136 (patch)
tree6f9cc5c2966116367cb8760b9695fff9e0b2b69a /net-misc/elliptics/elliptics-2.9.6.ebuild
parentInitial commit, updated versions to follow (diff)
downloadgentoo-2-0641b2f01f55647573d90f159412a77aa57e8136.tar.gz
gentoo-2-0641b2f01f55647573d90f159412a77aa57e8136.tar.bz2
gentoo-2-0641b2f01f55647573d90f159412a77aa57e8136.zip
Initial commit, updated versions to follow
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-misc/elliptics/elliptics-2.9.6.ebuild')
-rw-r--r--net-misc/elliptics/elliptics-2.9.6.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/elliptics/elliptics-2.9.6.ebuild b/net-misc/elliptics/elliptics-2.9.6.ebuild
new file mode 100644
index 000000000000..b3ac9d9630b9
--- /dev/null
+++ b/net-misc/elliptics/elliptics-2.9.6.ebuild
@@ -0,0 +1,68 @@
+EAPI=4
+PYTHON_DEPEND="2"
+
+DESCRIPTION="Elliptics network is a fault tolerant key/value storage without dedicated metadata servers"
+HOMEPAGE="http://www.ioremap.net/projects/elliptics"
+LICENSE="GPL-2"
+SLOT="0"
+
+inherit eutils autotools python flag-o-matic
+
+KEYWORDS="~x86 ~amd64"
+IUSE="fastcgi python"
+RDEPEND="dev-libs/openssl
+ fastcgi? ( dev-libs/fcgi )
+ net-misc/elliptics-eblob
+ python? ( dev-libs/boost[python] )
+ dev-libs/libevent
+ dev-db/kyotocabinet"
+# dev-libs/libatomic
+DEPEND="${RDEPEND}"
+
+SRC_URI="http://www.ioremap.net/archive/${PN}/${P}.tar.gz"
+
+pkg_setup() {
+ enewgroup elliptics
+ enewuser elliptics -1 -1 /dev/null elliptics
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare(){
+ eautoreconf
+}
+
+src_configure(){
+ use python && filter-ldflags -Wl,--as-needed
+ econf \
+ --with-libatomic-path=/dev/null \
+ $(use_with python boost)
+ --without-eblob
+}
+
+src_install(){
+ emake install DESTDIR="${D}" || die
+ use fastcgi && example/fcgi/lighttpd-fastcgi-elliptics.conf
+ dodoc doc/design_notes.txt \
+ doc/io_storage_backend.txt \
+ example/EXAMPLE \
+ example/ioserv.conf
+
+ # init script stuff
+ newinitd "${FILESDIR}"/elliptics.initd elliptics || die
+ newconfd "${FILESDIR}"/elliptics.confd elliptics || die
+
+ # tune default config
+ sed -i 's#log = /dev/stderr#log = syslog#' ${S}/example/ioserv.conf
+ sed -i 's#root = /tmp/root#root = /var/spool/elliptics#' ${S}/example/ioserv.conf
+ sed -i 's#daemon = 0#daemon = 1#' ${S}/example/ioserv.conf
+ sed -i 's#history = /tmp/history#history = /var/run/elliptics#' ${S}/example/ioserv.conf
+
+ # configs
+ insinto /etc/elliptics
+ doins "${S}/example/ioserv.conf"
+
+ keepdir /var/{spool,run}/elliptics
+ fowners elliptics:elliptics /var/{spool,run}/elliptics
+ fperms 0750 /var/{spool,run}/elliptics
+}