summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-07-06 20:45:19 +0000
committerMike Gilbert <floppym@gentoo.org>2013-07-06 20:45:19 +0000
commit2f3d5950053c577ed10c44f3b873a22a96feb7cd (patch)
treef1c5437bfbd6eb7cf0045be858b541322ca49f97 /net-misc/flexget
parentRevision bump and remove old. Fix parallel make deps to properly install lega... (diff)
downloadgentoo-2-2f3d5950053c577ed10c44f3b873a22a96feb7cd.tar.gz
gentoo-2-2f3d5950053c577ed10c44f3b873a22a96feb7cd.tar.bz2
gentoo-2-2f3d5950053c577ed10c44f3b873a22a96feb7cd.zip
Version bump. Stop sed-ing upstream's version requirements out of pavement.py.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-misc/flexget')
-rw-r--r--net-misc/flexget/ChangeLog8
-rw-r--r--net-misc/flexget/flexget-1.1.66.ebuild72
-rw-r--r--net-misc/flexget/flexget-9999.ebuild11
3 files changed, 83 insertions, 8 deletions
diff --git a/net-misc/flexget/ChangeLog b/net-misc/flexget/ChangeLog
index 3f7ae32173ca..3c318731338e 100644
--- a/net-misc/flexget/ChangeLog
+++ b/net-misc/flexget/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/flexget
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/flexget/ChangeLog,v 1.40 2013/05/27 01:33:15 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/flexget/ChangeLog,v 1.41 2013/07/06 20:45:19 floppym Exp $
+
+*flexget-1.1.66 (06 Jul 2013)
+
+ 06 Jul 2013; Mike Gilbert <floppym@gentoo.org> +flexget-1.1.66.ebuild,
+ flexget-9999.ebuild:
+ Version bump. Stop sed-ing upstream's version requirements out of pavement.py.
*flexget-1.1.11 (27 May 2013)
diff --git a/net-misc/flexget/flexget-1.1.66.ebuild b/net-misc/flexget/flexget-1.1.66.ebuild
new file mode 100644
index 000000000000..6972e2dd0a9d
--- /dev/null
+++ b/net-misc/flexget/flexget-1.1.66.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/flexget/flexget-1.1.66.ebuild,v 1.1 2013/07/06 20:45:19 floppym Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit distutils-r1 eutils
+
+if [[ ${PV} != 9999 ]]; then
+ MY_P="FlexGet-${PV}"
+ SRC_URI="http://download.flexget.com/${MY_P}.tar.gz
+ http://download.flexget.com/archive/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+else
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/Flexget/Flexget.git
+ https://github.com/Flexget/Flexget.git"
+fi
+
+DESCRIPTION="Multipurpose automation tool for content like torrents, nzbs, podcasts, comics"
+HOMEPAGE="http://flexget.com/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ >=dev-python/feedparser-5.1.3[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.7
+ <dev-python/sqlalchemy-0.7.99
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup-4.1:4[${PYTHON_USEDEP}]
+ <dev-python/beautifulsoup-4.3:4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0[${PYTHON_USEDEP}]
+ dev-python/PyRSS2Gen[${PYTHON_USEDEP}]
+ dev-python/pynzb[${PYTHON_USEDEP}]
+ dev-python/progressbar[${PYTHON_USEDEP}]
+ dev-python/flask
+ dev-python/cherrypy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-tvrage[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0[${PYTHON_USEDEP}]
+ <dev-python/requests-1.99
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+DEPEND+=" test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+=" dev-python/paver"
+else
+ S="${WORKDIR}/${MY_P}"
+fi
+
+python_prepare_all() {
+ # Prevent setup from grabbing nose from pypi
+ sed -e /setup_requires/d -i pavement.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cp -lr tests setup.cfg "${BUILD_DIR}" || die
+ run_in_build_dir nosetests -v --attr=!online > "${T}/tests-${EPYTHON}.log" \
+ || die "Tests fail with ${EPYTHON}"
+}
diff --git a/net-misc/flexget/flexget-9999.ebuild b/net-misc/flexget/flexget-9999.ebuild
index 686c86916b44..3d77428468f9 100644
--- a/net-misc/flexget/flexget-9999.ebuild
+++ b/net-misc/flexget/flexget-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/flexget/flexget-9999.ebuild,v 1.37 2013/05/27 01:33:15 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/flexget/flexget-9999.ebuild,v 1.38 2013/07/06 20:45:19 floppym Exp $
EAPI=5
@@ -32,7 +32,8 @@ DEPEND="
<dev-python/sqlalchemy-0.7.99
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup-4.1:4[${PYTHON_USEDEP}]
+ <dev-python/beautifulsoup-4.3:4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
>=dev-python/jsonschema-2.0[${PYTHON_USEDEP}]
@@ -59,11 +60,7 @@ fi
python_prepare_all() {
# Prevent setup from grabbing nose from pypi
- sed -e /setup_requires/d \
- -e '/SQLAlchemy/s/, <0.8//' \
- -e '/BeautifulSoup/s/, <3.3//' \
- -e '/beautifulsoup4/s/, <4.2//' \
- -i pavement.py || die
+ sed -e /setup_requires/d -i pavement.py || die
distutils-r1_python_prepare_all
}