summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2009-01-03 21:38:23 +0000
committerMike Pagano <mpagano@gentoo.org>2009-01-03 21:38:23 +0000
commite1f37aa3443782a8a1771d8258968fa6369c0474 (patch)
tree3800f21b951250ff0c66294a0b68bd1e295f914e /net-misc/getdate/getdate-1.2.ebuild
parentAdd DBD-mysql-2.9007 again, because www-apps/bugzilla-2.20.6 depends on it (diff)
downloadgentoo-2-e1f37aa3443782a8a1771d8258968fa6369c0474.tar.gz
gentoo-2-e1f37aa3443782a8a1771d8258968fa6369c0474.tar.bz2
gentoo-2-e1f37aa3443782a8a1771d8258968fa6369c0474.zip
Removing the stripping of a binary as per bug #240934
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'net-misc/getdate/getdate-1.2.ebuild')
-rw-r--r--net-misc/getdate/getdate-1.2.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/net-misc/getdate/getdate-1.2.ebuild b/net-misc/getdate/getdate-1.2.ebuild
index 29e47364c156..8f75ffdb28e3 100644
--- a/net-misc/getdate/getdate-1.2.ebuild
+++ b/net-misc/getdate/getdate-1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/getdate/getdate-1.2.ebuild,v 1.9 2005/07/30 17:57:36 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/getdate/getdate-1.2.ebuild,v 1.10 2009/01/03 21:38:23 mpagano Exp $
inherit toolchain-funcs
@@ -20,12 +20,20 @@ KEYWORDS="x86 ~mips ppc"
DEPEND="virtual/libc"
RDEPEND="${DEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ #remove prestripped binary as per bug #240934
+ sed -i -e "s:install -s:install:" Makefile
+}
+
src_compile() {
- $(tc-getCC) ${CFLAGS} -DHAVE_ADJTIME -s -o getdate getdate.c || die
+ $(tc-getCC) ${CFLAGS} -DHAVE_ADJTIME -o getdate getdate.c || die
}
src_install() {
- dobin getdate
+ dobin getdate || die "dobin failed"
doman getdate.8
dodoc README getdate-cron
}