summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-04-29 16:58:43 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-04-29 16:58:43 +0000
commit2aa5998466f0da9c3f7c9cd2990fd69e602ce8c5 (patch)
tree869cdeec79f0435dc4874543036a5bdb4c1e00cc /net-misc/grive
parentRename USE flag crypt to password requested by upstream maintainer Jan KundrÃ... (diff)
downloadgentoo-2-2aa5998466f0da9c3f7c9cd2990fd69e602ce8c5.tar.gz
gentoo-2-2aa5998466f0da9c3f7c9cd2990fd69e602ce8c5.tar.bz2
gentoo-2-2aa5998466f0da9c3f7c9cd2990fd69e602ce8c5.zip
version bump to build with latest json-c (bug #508980)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'net-misc/grive')
-rw-r--r--net-misc/grive/ChangeLog8
-rw-r--r--net-misc/grive/grive-0.3.0_pre20130503.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/net-misc/grive/ChangeLog b/net-misc/grive/ChangeLog
index b5fabb53c122..6b01f81d3cec 100644
--- a/net-misc/grive/ChangeLog
+++ b/net-misc/grive/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/grive
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/grive/ChangeLog,v 1.13 2014/03/01 22:09:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/grive/ChangeLog,v 1.14 2014/04/29 16:58:43 ottxor Exp $
+
+*grive-0.3.0_pre20130503 (29 Apr 2014)
+
+ 29 Apr 2014; Christoph Junghans <ottxor@gentoo.org>
+ +grive-0.3.0_pre20130503.ebuild:
+ version bump to build with latest json-c (bug #508980)
01 Mar 2014; Michał Górny <mgorny@gentoo.org> grive-0.2.0-r1.ebuild:
Update libgcrypt dep to use slot :0.
diff --git a/net-misc/grive/grive-0.3.0_pre20130503.ebuild b/net-misc/grive/grive-0.3.0_pre20130503.ebuild
new file mode 100644
index 000000000000..94c93d1e78b8
--- /dev/null
+++ b/net-misc/grive/grive-0.3.0_pre20130503.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/grive/grive-0.3.0_pre20130503.ebuild,v 1.1 2014/04/29 16:58:43 ottxor Exp $
+
+EAPI=5
+
+inherit cmake-utils eutils multilib
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/Grive/${PN}.git"
+else
+ inherit eutils vcs-snapshot
+ COMMIT="27817e835fe115ebbda5410ec904aa49a2ad01f1"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="an open source Linux client for Google Drive"
+HOMEPAGE="http://www.lbreda.com/grive/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/expat
+ dev-libs/json-c:=
+ dev-libs/libgcrypt:0=
+ dev-libs/yajl
+ dev-qt/qtcore
+ dev-qt/qtgui
+ net-misc/curl
+ sys-devel/binutils
+ sys-libs/glibc
+ sys-libs/zlib
+ "
+
+DEPEND="${RDEPEND}"
+
+DOCS=( "README" )
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}"-0.2.0-check-bfd.h.patch
+
+ #include dir change in json-c-0.10 #462632 and #452234
+ if has_version ">=dev-libs/json-c-0.10" ; then
+ sed -i -e '/\(include\|INCLUDE\)/s@json/@json-c/@' \
+ libgrive/src/protocol/Json.cc \
+ cmake/Modules/FindJSONC.cmake || die
+ fi
+ #json-c library changed in 0.11, bug #467432
+ if has_version ">=dev-libs/json-c-0.11" ; then
+ sed -i -e '/LIBRARY/s@json)@json-c)@' \
+ cmake/Modules/FindJSONC.cmake || die
+ fi
+
+ sed -i '/grive.1/s/^/#/' bgrive/CMakeLists.txt || die
+}
+
+src_install(){
+ cmake-utils_src_install
+
+ local icon size
+ for icon in icon/*/*.png; do
+ size=${icon##*/}
+ size=${size%.png}
+ newicon -s "${size}" "${icon}" ${PN}.png
+ done
+ make_desktop_entry bgrive
+}