summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-09-09 22:47:39 +0000
committerMike Frysinger <vapier@gentoo.org>2014-09-09 22:47:39 +0000
commitbd949973097e8bbec95d5ed3dfc48fa8d09e7956 (patch)
tree6092d03af16613faa3b5d2e55ddaa172603dc041 /net-misc/gsutil
parentVersion bump. (diff)
downloadgentoo-2-bd949973097e8bbec95d5ed3dfc48fa8d09e7956.tar.gz
gentoo-2-bd949973097e8bbec95d5ed3dfc48fa8d09e7956.tar.bz2
gentoo-2-bd949973097e8bbec95d5ed3dfc48fa8d09e7956.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-misc/gsutil')
-rw-r--r--net-misc/gsutil/ChangeLog7
-rw-r--r--net-misc/gsutil/gsutil-4.6.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/net-misc/gsutil/ChangeLog b/net-misc/gsutil/ChangeLog
index 12fd5c059b22..9a14cdeffbe8 100644
--- a/net-misc/gsutil/ChangeLog
+++ b/net-misc/gsutil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/gsutil
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gsutil/ChangeLog,v 1.17 2014/08/20 04:21:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsutil/ChangeLog,v 1.18 2014/09/09 22:47:39 vapier Exp $
+
+*gsutil-4.6 (09 Sep 2014)
+
+ 09 Sep 2014; Mike Frysinger <vapier@gentoo.org> +gsutil-4.6.ebuild:
+ Version bump.
*gsutil-4.5 (20 Aug 2014)
diff --git a/net-misc/gsutil/gsutil-4.6.ebuild b/net-misc/gsutil/gsutil-4.6.ebuild
new file mode 100644
index 000000000000..246f7796bc7f
--- /dev/null
+++ b/net-misc/gsutil/gsutil-4.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsutil/gsutil-4.6.ebuild,v 1.1 2014/09/09 22:47:39 vapier Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="command line tool for interacting with cloud storage services"
+HOMEPAGE="https://github.com/GoogleCloudPlatform/gsutil"
+SRC_URI="http://commondatastorage.googleapis.com/pub/${PN}_${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=dev-python/boto-2.30.0[${PYTHON_USEDEP}]
+ >=dev-python/crcmod-1.7
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/gcs-oauth2-boto-plugin-1.8[${PYTHON_USEDEP}]
+ >=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
+ >=dev-python/python-gflags-2.0[${PYTHON_USEDEP}]
+ >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/socksipy-1.01[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( README.md CHANGES.md )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.4-use-friendy-version-checks.patch"
+ "${FILESDIR}/${PN}-3.37-drop-http_proxy-clearing.patch"
+)
+
+python_test() {
+ export BOTO_CONFIG=${FILESDIR}/dummy.boto
+ ${PYTHON} gslib/__main__.py test -u || die "tests failed"
+}