summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-02 22:02:57 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-02 22:02:57 +0000
commit684536aaeebf8950c78717b6fa447c1b0616a6f7 (patch)
tree06420e1e941bb3893aa46e4d5ba90e685bb3e797 /net-misc/iputils/iputils-021109-r3.ebuild
parentAdd a bunch of patches from Redhat, break up the Debian patch we used, and ad... (diff)
downloadgentoo-2-684536aaeebf8950c78717b6fa447c1b0616a6f7.tar.gz
gentoo-2-684536aaeebf8950c78717b6fa447c1b0616a6f7.tar.bz2
gentoo-2-684536aaeebf8950c78717b6fa447c1b0616a6f7.zip
Update the gcc-inline patch by Dave Stahl #80969 and fix lazy bindings for setuid apps #77526.
(Portage version: 2.0.51.21)
Diffstat (limited to 'net-misc/iputils/iputils-021109-r3.ebuild')
-rw-r--r--net-misc/iputils/iputils-021109-r3.ebuild41
1 files changed, 18 insertions, 23 deletions
diff --git a/net-misc/iputils/iputils-021109-r3.ebuild b/net-misc/iputils/iputils-021109-r3.ebuild
index 27193e45ca56..14afb58b0af8 100644
--- a/net-misc/iputils/iputils-021109-r3.ebuild
+++ b/net-misc/iputils/iputils-021109-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-021109-r3.ebuild,v 1.20 2005/01/21 00:17:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-021109-r3.ebuild,v 1.21 2005/05/02 22:02:57 vapier Exp $
-inherit flag-o-matic gnuconfig eutils toolchain-funcs
+inherit flag-o-matic eutils toolchain-funcs
DESCRIPTION="Network monitoring tools including ping and ping6"
HOMEPAGE="ftp://ftp.inr.ac.ru/ip-routing"
@@ -14,35 +14,30 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
IUSE="static ipv6 uclibc doc"
-DEPEND="virtual/libc
- virtual/os-headers
- dev-libs/openssl
- sys-devel/autoconf
+DEPEND="virtual/os-headers
doc? (
app-text/openjade
dev-perl/SGMLSpm
app-text/docbook-sgml-dtd
app-text/docbook-sgml-utils
)"
-RDEPEND="virtual/libc"
+RDEPEND=""
S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- cd ${S}
-
- use static && append-ldflags -static
-
- epatch ${FILESDIR}/${PV}-gcc34.patch
- epatch ${FILESDIR}/${PV}-no-pfkey-search.patch
- epatch ${FILESDIR}/${PV}-ipg-linux-2.6.patch #71756
- epatch ${FILESDIR}/${PV}-syserror.patch
- epatch ${FILESDIR}/${PV}-uclibc-no-ether_ntohost.patch
-
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc34.patch
+ epatch "${FILESDIR}"/${PV}-no-pfkey-search.patch
+ epatch "${FILESDIR}"/${PV}-ipg-linux-2.6.patch #71756
+ epatch "${FILESDIR}"/${PV}-syserror.patch
+ epatch "${FILESDIR}"/${PV}-uclibc-no-ether_ntohost.patch
+ epatch "${FILESDIR}"/${P}-bindnow.patch #77526
# make iputils work with newer glibc snapshots
- epatch ${FILESDIR}/${P}-linux-udp-header.patch
+ epatch "${FILESDIR}"/${P}-linux-udp-header.patch
+ use static && append-ldflags -static
sed -i \
-e "/^CCOPT=/s:-O2:${CFLAGS}:" \
-e "/^CC=/s:.*::" \
@@ -69,16 +64,16 @@ src_compile() {
src_install() {
into /
- dobin ping
+ dobin ping || die "ping"
use ipv6 && dobin ping6
- dosbin arping
+ dosbin arping || die "arping"
into /usr
- dosbin tracepath
+ dosbin tracepath || die "tracepath"
use ipv6 && dosbin trace{path,route}6
- dosbin clockdiff rarpd rdisc ipg tftpd
+ dosbin clockdiff rarpd rdisc ipg tftpd || die "misc sbin"
fperms 4711 /bin/ping
- use ipv6 && fperms 4711 /bin/ping6
+ use ipv6 && fperms 4711 /bin/ping6 /usr/sbin/traceroute6
dodoc INSTALL RELNOTES