summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-05-31 20:52:25 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-05-31 20:52:25 +0000
commit0318e490ce69c576e4d516dd264d4f11a924800e (patch)
tree11aa4dc2fc63ebe066d230afc35e008a5aa204fe /net-misc/leechcraft-core
parentBump LeechCraft to 0.5.70 "Hessian Blade" (diff)
downloadgentoo-2-0318e490ce69c576e4d516dd264d4f11a924800e.tar.gz
gentoo-2-0318e490ce69c576e4d516dd264d4f11a924800e.tar.bz2
gentoo-2-0318e490ce69c576e4d516dd264d4f11a924800e.zip
Bump LeechCraft to 0.5.70 "Hessian Blade"
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/leechcraft-core')
-rw-r--r--net-misc/leechcraft-core/ChangeLog8
-rw-r--r--net-misc/leechcraft-core/leechcraft-core-0.5.70.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/net-misc/leechcraft-core/ChangeLog b/net-misc/leechcraft-core/ChangeLog
index d0d6ff8d5fb3..414247705181 100644
--- a/net-misc/leechcraft-core/ChangeLog
+++ b/net-misc/leechcraft-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/leechcraft-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/ChangeLog,v 1.15 2012/05/21 20:06:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/ChangeLog,v 1.16 2012/05/31 20:52:25 maksbotan Exp $
+
+*leechcraft-core-0.5.70 (31 May 2012)
+
+ 31 May 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-core-0.5.70.ebuild:
+ Bump LeechCraft to 0.5.70 "Hessian Blade"
21 May 2012; Samuli Suominen <ssuominen@gentoo.org>
leechcraft-core-0.4.99.ebuild, leechcraft-core-0.5.0.ebuild,
diff --git a/net-misc/leechcraft-core/leechcraft-core-0.5.70.ebuild b/net-misc/leechcraft-core/leechcraft-core-0.5.70.ebuild
new file mode 100644
index 000000000000..3eb76985875d
--- /dev/null
+++ b/net-misc/leechcraft-core/leechcraft-core-0.5.70.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/leechcraft-core-0.5.70.ebuild,v 1.1 2012/05/31 20:52:25 maksbotan Exp $
+
+EAPI="4"
+
+EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git"
+EGIT_PROJECT="leechcraft-${PV}"
+
+inherit eutils confutils leechcraft
+
+DESCRIPTION="Core of LeechCraft, the modular network client"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +sqlite postgres"
+
+DEPEND=">=dev-libs/boost-1.46
+ x11-libs/qt-core
+ x11-libs/qt-gui
+ x11-libs/qt-script
+ x11-libs/qt-sql[postgres?,sqlite?]"
+RDEPEND="${DEPEND}
+ x11-libs/qt-svg"
+
+pkg_setup() {
+ confutils_require_any postgres sqlite
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DWITH_PLUGINS=False"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ make_desktop_entry leechcraft "LeechCraft" leechcraft.png
+}