summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-03-20 12:42:09 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-03-20 12:42:09 +0000
commit0b49eb21c616691d07732d87ee68c734b7f13ade (patch)
tree20007544f9978ae45ae1b240ea98e1259694d7e3 /net-misc/leechcraft-core
parentBump LeechCraft to 0.5.60, thank to 0xd34df00d (diff)
downloadgentoo-2-0b49eb21c616691d07732d87ee68c734b7f13ade.tar.gz
gentoo-2-0b49eb21c616691d07732d87ee68c734b7f13ade.tar.bz2
gentoo-2-0b49eb21c616691d07732d87ee68c734b7f13ade.zip
Bump LeechCraft to 0.5.60, thank to 0xd34df00d
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/leechcraft-core')
-rw-r--r--net-misc/leechcraft-core/ChangeLog8
-rw-r--r--net-misc/leechcraft-core/leechcraft-core-0.5.60.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/net-misc/leechcraft-core/ChangeLog b/net-misc/leechcraft-core/ChangeLog
index 5163efb6464c..657049f86352 100644
--- a/net-misc/leechcraft-core/ChangeLog
+++ b/net-misc/leechcraft-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/leechcraft-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/ChangeLog,v 1.9 2012/02/10 13:17:37 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/ChangeLog,v 1.10 2012/03/20 12:42:09 maksbotan Exp $
+
+*leechcraft-core-0.5.60 (20 Mar 2012)
+
+ 20 Mar 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-core-0.5.60.ebuild:
+ Bump LeechCraft to 0.5.60, thank to 0xd34df00d
10 Feb 2012; Maxim Koltsov <maksbotan@gentoo.org>
leechcraft-core-9999.ebuild:
diff --git a/net-misc/leechcraft-core/leechcraft-core-0.5.60.ebuild b/net-misc/leechcraft-core/leechcraft-core-0.5.60.ebuild
new file mode 100644
index 000000000000..8f4b186c7e4c
--- /dev/null
+++ b/net-misc/leechcraft-core/leechcraft-core-0.5.60.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/leechcraft-core-0.5.60.ebuild,v 1.1 2012/03/20 12:42:09 maksbotan Exp $
+
+EAPI="4"
+
+EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git"
+EGIT_PROJECT="leechcraft-${PV}"
+
+inherit confutils leechcraft
+
+DESCRIPTION="Core of LeechCraft, the modular network client"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +sqlite postgres"
+
+DEPEND=">=dev-libs/boost-1.39
+ x11-libs/qt-core
+ x11-libs/qt-gui
+ x11-libs/qt-script
+ x11-libs/qt-sql[postgres?,sqlite?]"
+RDEPEND="${DEPEND}
+ x11-libs/qt-svg"
+
+pkg_setup() {
+ confutils_require_any postgres sqlite
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DWITH_PLUGINS=False"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ make_desktop_entry leechcraft "LeechCraft" leechcraft.png
+}