summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-07-15 16:09:23 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-07-15 16:09:23 +0000
commit23a0a4bbdc1690652d3c9d88014e54fb445593ef (patch)
treed44ceb4efa799c96dd990b650460f7bd9f794a1e /net-misc/linphone
parentFixed a bad domain pointer - thanks to DaPhreak in IRC (diff)
downloadgentoo-2-23a0a4bbdc1690652d3c9d88014e54fb445593ef.tar.gz
gentoo-2-23a0a4bbdc1690652d3c9d88014e54fb445593ef.tar.bz2
gentoo-2-23a0a4bbdc1690652d3c9d88014e54fb445593ef.zip
Readded ipv6 include patch, still needed for 1.0.1, fixes #99083
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-misc/linphone')
-rw-r--r--net-misc/linphone/ChangeLog8
-rw-r--r--net-misc/linphone/files/linphone-1.0.1-ipv6-include.diff13
-rw-r--r--net-misc/linphone/linphone-1.0.1.ebuild12
3 files changed, 31 insertions, 2 deletions
diff --git a/net-misc/linphone/ChangeLog b/net-misc/linphone/ChangeLog
index 4cac11e64b76..e8db05f708b8 100644
--- a/net-misc/linphone/ChangeLog
+++ b/net-misc/linphone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/linphone
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/linphone/ChangeLog,v 1.3 2005/07/14 22:02:13 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/linphone/ChangeLog,v 1.4 2005/07/15 16:09:23 stkn Exp $
+
+ 15 Jul 2005; Stefan Knoblich <stkn@gentoo.org> linphone-1.0.1.ebuild,
+ +linphone-1.0.1-ipv6-include.diff:
+ Always include <netdb.h> in coreapi/linphonecore.c even if USE flag is set
+ -ipv6, fixes #99083. Thanks to Anders Hellgen pointing out that patch from
+ 0.12.x is still needed.
14 Jul 2005; Stefan Knoblich <stkn@gentoo.org> linphone-1.0.1.ebuild:
Indentation fixes, added missing dodoc, replaced einstall with make
diff --git a/net-misc/linphone/files/linphone-1.0.1-ipv6-include.diff b/net-misc/linphone/files/linphone-1.0.1-ipv6-include.diff
new file mode 100644
index 000000000000..6d8b0285c6e8
--- /dev/null
+++ b/net-misc/linphone/files/linphone-1.0.1-ipv6-include.diff
@@ -0,0 +1,13 @@
+--- linphone-1.0.1/coreapi/linphonecore.c.orig 2005-07-15 17:49:55.000000000 +0200
++++ linphone-1.0.1/coreapi/linphonecore.c 2005-07-15 17:50:23.000000000 +0200
+@@ -34,9 +34,8 @@
+ #include <arpa/inet.h>
+ #include <time.h>
+
+-#ifdef INET6
++/* once again, the ipv6 include fix - stkn */
+ #include <netdb.h>
+-#endif
+
+ #include "enum.h"
+
diff --git a/net-misc/linphone/linphone-1.0.1.ebuild b/net-misc/linphone/linphone-1.0.1.ebuild
index a2ef8291d937..98906813d24f 100644
--- a/net-misc/linphone/linphone-1.0.1.ebuild
+++ b/net-misc/linphone/linphone-1.0.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/linphone/linphone-1.0.1.ebuild,v 1.2 2005/07/14 22:02:13 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/linphone/linphone-1.0.1.ebuild,v 1.3 2005/07/15 16:09:23 stkn Exp $
+
+inherit eutils
MY_DPV="${PV%.*}.x"
@@ -25,6 +27,14 @@ DEPEND="dev-libs/glib
>=x11-libs/gtk+-2 )
alsa? ( media-libs/alsa-lib )"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # fix #99083
+ epatch ${FILESDIR}/${P}-ipv6-include.diff
+}
+
src_compile() {
local withgnome