summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-03-13 18:42:35 +0000
committerMichael Weber <xmw@gentoo.org>2013-03-13 18:42:35 +0000
commitf8669dcdb7f8aa3b2ca249b1fd3f31b9d9455336 (patch)
tree8c481a0149c072229310d7df15c777e0d08cfbf4 /net-misc/mosh
parentRemove obsolete mask on x11-misc/xdaf (diff)
downloadgentoo-2-f8669dcdb7f8aa3b2ca249b1fd3f31b9d9455336.tar.gz
gentoo-2-f8669dcdb7f8aa3b2ca249b1fd3f31b9d9455336.tar.bz2
gentoo-2-f8669dcdb7f8aa3b2ca249b1fd3f31b9d9455336.zip
Version bump to release candidate
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-misc/mosh')
-rw-r--r--net-misc/mosh/ChangeLog7
-rw-r--r--net-misc/mosh/mosh-1.2.3.95_rc1.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/net-misc/mosh/ChangeLog b/net-misc/mosh/ChangeLog
index 898007ca1ea5..f45019140ba4 100644
--- a/net-misc/mosh/ChangeLog
+++ b/net-misc/mosh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/mosh
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/ChangeLog,v 1.36 2013/02/19 03:42:49 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/ChangeLog,v 1.37 2013/03/13 18:42:35 xmw Exp $
+
+*mosh-1.2.3.95_rc1 (13 Mar 2013)
+
+ 13 Mar 2013; Michael Weber <xmw@gentoo.org> +mosh-1.2.3.95_rc1.ebuild:
+ Version bump to release candidate
19 Feb 2013; Zac Medico <zmedico@gentoo.org> mosh-1.2.3.ebuild:
Fix for prefix and add ~arm-linux + ~x86-linux keywords.
diff --git a/net-misc/mosh/mosh-1.2.3.95_rc1.ebuild b/net-misc/mosh/mosh-1.2.3.95_rc1.ebuild
new file mode 100644
index 000000000000..4758e09215c8
--- /dev/null
+++ b/net-misc/mosh/mosh-1.2.3.95_rc1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/mosh-1.2.3.95_rc1.ebuild,v 1.1 2013/03/13 18:42:35 xmw Exp $
+
+EAPI=4
+
+inherit autotools vcs-snapshot
+
+DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
+HOMEPAGE="http://mosh.mit.edu"
+SRC_URI="http://mosh.mit.edu/${P/_rc/rc}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86 ~arm-linux ~x86-linux"
+IUSE="bash-completion +client examples +mosh-hardening +server ufw +utempter"
+REQUIRED_USE="|| ( client server )
+ examples? ( client )"
+
+RDEPEND="dev-libs/protobuf
+ sys-libs/ncurses:5
+ virtual/ssh
+ client? ( dev-lang/perl
+ dev-perl/IO-Tty )
+ utempter? ( sys-libs/libutempter )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable bash-completion completion) \
+ $(use_enable client) \
+ $(use_enable server) \
+ $(use_enable examples) \
+ $(use_enable ufw) \
+ $(use_enable mosh-hardening hardening) \
+ $(use_with utempter)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ default
+
+ for myprog in $(find src/examples -type f -perm /0111) ; do
+ newbin ${myprog} ${PN}-$(basename ${myprog})
+ elog "${myprog} installed as ${PN}-$(basename ${myprog})"
+ done
+
+ if use bash-completion ; then
+ insinto /usr/share/bash-completion
+ doins "${ED}"/etc/bash_completion.d/mosh
+ rm -rf "${ED}"/etc/bash_completion.d
+ fi
+}