summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-12 21:41:18 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-12 21:41:18 +0000
commit742d5019b204714e3b110c69167026a17e1bea1e (patch)
tree9772fa862b8e4f05b17ea468f9431245cc91feb8 /net-misc/nut
parentChangeLog and libpng update (diff)
downloadgentoo-2-742d5019b204714e3b110c69167026a17e1bea1e.tar.gz
gentoo-2-742d5019b204714e3b110c69167026a17e1bea1e.tar.bz2
gentoo-2-742d5019b204714e3b110c69167026a17e1bea1e.zip
libpng updates
Diffstat (limited to 'net-misc/nut')
-rw-r--r--net-misc/nut/ChangeLog6
-rw-r--r--net-misc/nut/files/digest-nut-0.44.1-r11
-rw-r--r--net-misc/nut/nut-0.44.1-r1.ebuild58
3 files changed, 64 insertions, 1 deletions
diff --git a/net-misc/nut/ChangeLog b/net-misc/nut/ChangeLog
index ace89ca3ab13..810627b5ea9e 100644
--- a/net-misc/nut/ChangeLog
+++ b/net-misc/nut/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for net-misc/nut
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/ChangeLog,v 1.1 2002/02/01 21:53:35 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/ChangeLog,v 1.2 2002/04/12 21:41:18 spider Exp $
+*nut-0.44.1-r1 (12 Apr 2002)
+ 12 Apr 2002; Spider <spider@gentoo.org>
+ libpng update
+ remove RPEND tag, unnecessary. (or typo;)
*nut-0.44.1 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/net-misc/nut/files/digest-nut-0.44.1-r1 b/net-misc/nut/files/digest-nut-0.44.1-r1
new file mode 100644
index 000000000000..63c27bef9727
--- /dev/null
+++ b/net-misc/nut/files/digest-nut-0.44.1-r1
@@ -0,0 +1 @@
+MD5 f34b5c9c4fd55b9763bd801bf88f4ed5 nut-0.44.1.tar.gz 182139
diff --git a/net-misc/nut/nut-0.44.1-r1.ebuild b/net-misc/nut/nut-0.44.1-r1.ebuild
new file mode 100644
index 000000000000..c7602adf0463
--- /dev/null
+++ b/net-misc/nut/nut-0.44.1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/nut-0.44.1-r1.ebuild,v 1.1 2002/04/12 21:41:18 spider Exp $
+
+P=nut-0.44.1
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Network-UPS Tools"
+SRC_URI="http://www.exploits.org/nut/release/"${A}
+HOMEPAGE="http://www.exploits.org/nut/"
+
+DEPEND="virtual/glibc
+ >=media-libs/libgd-1.8.3
+ >=media-libs/libpng-1.2.1"
+
+
+src_compile() {
+ try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc/nut \
+ --with-user=daemon --with-group=daemon
+ try make
+ try make cgi
+}
+
+src_install() {
+ dodir /usr/bin
+ try make INSTALLROOT=${D} STATEPATH=${D}/var/state/ups \
+ install
+ cd clients
+ exeinto /usr/local/httpd/cgi-bin/nut
+ doexe *.cgi
+ into /usr
+ dolib upsfetch.o
+ insinto /usr/include
+ doins upsfetch.h
+ cd ..
+ rmdir ${D}/usr/misc
+ insinto /etc/rc.d/init.d
+ doins ${O}/files/upsd
+ dodoc COPYING CREDITS Changes QUICKSTART README
+ docinto docs
+ dodoc docs/*.txt docs/FAQ docs/Changes.trust
+ docinto cables
+ dodoc docs/cables/*.txt
+}
+
+
+pkg_config() {
+
+ . ${ROOT}/etc/rc.d/config/functions
+
+ einfo "Generating symlinks..."
+ ${ROOT}/usr/sbin/rc-update add upsd
+
+}
+
+
+