summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-07-08 18:33:20 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-07-08 18:33:20 +0000
commit0d61d3a886d08c34d38dc92d9da66c20ee43cca7 (patch)
treeb68238fef1c861ace11030f2cd52140819449f7f /net-misc/raccess
parentFixing vix.libdir (diff)
downloadgentoo-2-0d61d3a886d08c34d38dc92d9da66c20ee43cca7.tar.gz
gentoo-2-0d61d3a886d08c34d38dc92d9da66c20ee43cca7.tar.bz2
gentoo-2-0d61d3a886d08c34d38dc92d9da66c20ee43cca7.zip
Adding patch to compile with glibc-2.10. Closes bug #272509
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-misc/raccess')
-rw-r--r--net-misc/raccess/ChangeLog6
-rw-r--r--net-misc/raccess/files/raccess-0.7-glibc210.patch585
-rw-r--r--net-misc/raccess/raccess-0.7.ebuild4
3 files changed, 593 insertions, 2 deletions
diff --git a/net-misc/raccess/ChangeLog b/net-misc/raccess/ChangeLog
index 5faab0a5e4c6..4fec34c5521b 100644
--- a/net-misc/raccess/ChangeLog
+++ b/net-misc/raccess/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/raccess
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/raccess/ChangeLog,v 1.15 2009/01/05 18:28:57 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/raccess/ChangeLog,v 1.16 2009/07/08 18:33:20 vostorga Exp $
+
+ 08 Jul 2009; <vostorga@gentoo.org> +files/raccess-0.7-glibc210.patch,
+ raccess-0.7.ebuild:
+ Adding patch to compile with glibc-2.10. Closes bug #272509
05 Jan 2009; Christoph Mende <angelos@gentoo.org>
+files/raccess-0.7-asneeded.patch, raccess-0.7.ebuild:
diff --git a/net-misc/raccess/files/raccess-0.7-glibc210.patch b/net-misc/raccess/files/raccess-0.7-glibc210.patch
new file mode 100644
index 000000000000..2ffb5660ed2e
--- /dev/null
+++ b/net-misc/raccess/files/raccess-0.7-glibc210.patch
@@ -0,0 +1,585 @@
+diff -NrU5 raccess-0.7.original/exploits/wu2.5.0a.c raccess-0.7/exploits/wu2.5.0a.c
+--- raccess-0.7.original/exploits/wu2.5.0a.c 2009-07-08 17:55:35.000000000 +0000
++++ raccess-0.7/exploits/wu2.5.0a.c 2009-07-08 18:09:23.000000000 +0000
+@@ -104,11 +104,11 @@
+ int xconnect (int sockfd, struct sockaddr *serv_addr, int addrlen);
+ void sighandler (int signal);
+ struct hostent *xgethostbyname (const char *name);
+ struct hostent *xgethostbyaddr (const char *addr, int len, int type);
+ void putserv (const char *fmt, ...);
+-char *getline (void);
++char *get_line (void);
+ char *getmsg (const char *msg);
+ int wuftpd_250_sploitit (void);
+ dirptr newdir (char *name);
+ char *getdir (char *stat);
+ char *int2char (int addr);
+@@ -759,16 +759,16 @@
+ }
+
+ #define LINEBUFLEN 8192
+ char linebuf[LINEBUFLEN]; /* saves us free()ing trouble. */
+
+-/* getline
++/* get_line
+ *
+ * get next line from server or local buffer
+ */
+ char *
+-getline (void)
++get_line (void)
+ {
+ char y[2];
+ int i = 0;
+
+ memset (linebuf, '\0', sizeof (linebuf));
+@@ -776,11 +776,11 @@
+
+ while (strncmp (y, "\n", 1) != 0)
+ {
+ if (i > (sizeof (linebuf) + 2))
+ {
+- err (0, "getline() buffer full");
++ err (0, "get_line() buffer full");
+ }
+ i += xread (fd, y, 1);
+ strcat (linebuf, y);
+ }
+
+@@ -835,11 +835,11 @@
+ char *line;
+ int i = strlen (msg);
+
+ do
+ {
+- line = getline ();
++ line = get_line ();
+ }
+ while (strncmp (line, msg, i) != 0 && strncmp (line, "5", 1) != 0);
+
+ return (line);
+ }
+@@ -919,11 +919,11 @@
+ nostat = 0;
+ putserv ("STAT .\n");
+
+ while (strncmp (line, "213 ", 4) != 0)
+ {
+- line = getline ();
++ line = get_line ();
+ tmp = getdir (line);
+
+ if (tmp == NULL)
+ continue;
+ if (dirroot == NULL)
+@@ -1279,14 +1279,14 @@
+ break;
+ }
+
+ string[tesopt.dirlen] = 0;
+ putserv ("MKD %s\n", string);
+- getline ();
++ get_line ();
+
+ putserv ("CWD %s\n", string);
+- getline ();
++ get_line ();
+ }
+
+ getpwd ();
+ disp = 1;
+
+@@ -1318,11 +1318,11 @@
+
+ if (strlen (string) < 20)
+ err (0, "cwd string too short.. check for 0x0's.\n");
+
+ putserv ("CWD %s\n", string);
+- getline ();
++ get_line ();
+
+ /************ jmpbuf ***********/
+
+ if (debug > 0)
+ printf ("Sending jmpbuf\n");
+@@ -1334,11 +1334,11 @@
+ if (strlen (string) != 32)
+ err (0, "jmpbuf string too short.. check for 0x0's.\n");
+
+ putserv ("%s\n", string);
+
+- getline ();
++ get_line ();
+
+ return (1);
+ }
+
+ /* shell
+diff -NrU5 raccess-0.7.original/exploits/wu2.5.0b.c raccess-0.7/exploits/wu2.5.0b.c
+--- raccess-0.7.original/exploits/wu2.5.0b.c 2009-07-08 17:55:35.000000000 +0000
++++ raccess-0.7/exploits/wu2.5.0b.c 2009-07-08 18:12:44.000000000 +0000
+@@ -104,11 +104,11 @@
+ int xconnect (int sockfd, struct sockaddr *serv_addr, int addrlen);
+ void sighandler (int signal);
+ struct hostent *xgethostbyname (const char *name);
+ struct hostent *xgethostbyaddr (const char *addr, int len, int type);
+ void putserv (const char *fmt, ...);
+-char *getline (void);
++char *get_line (void);
+ char *getmsg (const char *msg);
+ int wuftpd_250_sploitit (void);
+ dirptr newdir (char *name);
+ char *getdir (char *stat);
+ char *int2char (int addr);
+@@ -759,16 +759,16 @@
+ }
+
+ #define LINEBUFLEN 8192
+ char linebuf[LINEBUFLEN]; /* saves us free()ing trouble. */
+
+-/* getline
++/* get_line
+ *
+ * get next line from server or local buffer
+ */
+ char *
+-getline (void)
++get_line (void)
+ {
+ char y[2];
+ int i = 0;
+
+ memset (linebuf, '\0', sizeof (linebuf));
+@@ -776,11 +776,11 @@
+
+ while (strncmp (y, "\n", 1) != 0)
+ {
+ if (i > (sizeof (linebuf) + 2))
+ {
+- err (0, "getline() buffer full");
++ err (0, "get_line() buffer full");
+ }
+ i += xread (fd, y, 1);
+ strcat (linebuf, y);
+ }
+
+@@ -835,11 +835,11 @@
+ char *line;
+ int i = strlen (msg);
+
+ do
+ {
+- line = getline ();
++ line = get_line ();
+ }
+ while (strncmp (line, msg, i) != 0 && strncmp (line, "5", 1) != 0);
+
+ return (line);
+ }
+@@ -919,11 +919,11 @@
+ nostat = 0;
+ putserv ("STAT .\n");
+
+ while (strncmp (line, "213 ", 4) != 0)
+ {
+- line = getline ();
++ line = get_line ();
+ tmp = getdir (line);
+
+ if (tmp == NULL)
+ continue;
+ if (dirroot == NULL)
+@@ -1279,14 +1279,14 @@
+ break;
+ }
+
+ string[tesopt.dirlen] = 0;
+ putserv ("MKD %s\n", string);
+- getline ();
++ get_line ();
+
+ putserv ("CWD %s\n", string);
+- getline ();
++ get_line ();
+ }
+
+ getpwd ();
+ disp = 1;
+
+@@ -1318,11 +1318,11 @@
+
+ if (strlen (string) < 20)
+ err (0, "cwd string too short.. check for 0x0's.\n");
+
+ putserv ("CWD %s\n", string);
+- getline ();
++ get_line ();
+
+ /************ jmpbuf ***********/
+
+ if (debug > 0)
+ printf ("Sending jmpbuf\n");
+@@ -1334,11 +1334,11 @@
+ if (strlen (string) != 32)
+ err (0, "jmpbuf string too short.. check for 0x0's.\n");
+
+ putserv ("%s\n", string);
+
+- getline ();
++ get_line ();
+
+ return (1);
+ }
+
+ /* shell
+diff -NrU5 raccess-0.7.original/exploits/wu2.5.0c.c raccess-0.7/exploits/wu2.5.0c.c
+--- raccess-0.7.original/exploits/wu2.5.0c.c 2009-07-08 17:55:35.000000000 +0000
++++ raccess-0.7/exploits/wu2.5.0c.c 2009-07-08 18:14:14.000000000 +0000
+@@ -104,11 +104,11 @@
+ int xconnect (int sockfd, struct sockaddr *serv_addr, int addrlen);
+ void sighandler (int signal);
+ struct hostent *xgethostbyname (const char *name);
+ struct hostent *xgethostbyaddr (const char *addr, int len, int type);
+ void putserv (const char *fmt, ...);
+-char *getline (void);
++char *get_line (void);
+ char *getmsg (const char *msg);
+ int wuftpd_250_sploitit (void);
+ dirptr newdir (char *name);
+ char *getdir (char *stat);
+ char *int2char (int addr);
+@@ -759,16 +759,16 @@
+ }
+
+ #define LINEBUFLEN 8192
+ char linebuf[LINEBUFLEN]; /* saves us free()ing trouble. */
+
+-/* getline
++/* get_line
+ *
+ * get next line from server or local buffer
+ */
+ char *
+-getline (void)
++get_line (void)
+ {
+ char y[2];
+ int i = 0;
+
+ memset (linebuf, '\0', sizeof (linebuf));
+@@ -776,11 +776,11 @@
+
+ while (strncmp (y, "\n", 1) != 0)
+ {
+ if (i > (sizeof (linebuf) + 2))
+ {
+- err (0, "getline() buffer full");
++ err (0, "get_line() buffer full");
+ }
+ i += xread (fd, y, 1);
+ strcat (linebuf, y);
+ }
+
+@@ -835,11 +835,11 @@
+ char *line;
+ int i = strlen (msg);
+
+ do
+ {
+- line = getline ();
++ line = get_line ();
+ }
+ while (strncmp (line, msg, i) != 0 && strncmp (line, "5", 1) != 0);
+
+ return (line);
+ }
+@@ -919,11 +919,11 @@
+ nostat = 0;
+ putserv ("STAT .\n");
+
+ while (strncmp (line, "213 ", 4) != 0)
+ {
+- line = getline ();
++ line = get_line ();
+ tmp = getdir (line);
+
+ if (tmp == NULL)
+ continue;
+ if (dirroot == NULL)
+@@ -1279,14 +1279,14 @@
+ break;
+ }
+
+ string[tesopt.dirlen] = 0;
+ putserv ("MKD %s\n", string);
+- getline ();
++ get_line ();
+
+ putserv ("CWD %s\n", string);
+- getline ();
++ get_line ();
+ }
+
+ getpwd ();
+ disp = 1;
+
+@@ -1318,11 +1318,11 @@
+
+ if (strlen (string) < 20)
+ err (0, "cwd string too short.. check for 0x0's.\n");
+
+ putserv ("CWD %s\n", string);
+- getline ();
++ get_line ();
+
+ /************ jmpbuf ***********/
+
+ if (debug > 0)
+ printf ("Sending jmpbuf\n");
+@@ -1334,11 +1334,11 @@
+ if (strlen (string) != 32)
+ err (0, "jmpbuf string too short.. check for 0x0's.\n");
+
+ putserv ("%s\n", string);
+
+- getline ();
++ get_line ();
+
+ return (1);
+ }
+
+ /* shell
+diff -NrU5 raccess-0.7.original/exploits/wu2.5.0d.c raccess-0.7/exploits/wu2.5.0d.c
+--- raccess-0.7.original/exploits/wu2.5.0d.c 2009-07-08 17:55:35.000000000 +0000
++++ raccess-0.7/exploits/wu2.5.0d.c 2009-07-08 18:06:24.000000000 +0000
+@@ -104,11 +104,11 @@
+ int xconnect (int sockfd, struct sockaddr *serv_addr, int addrlen);
+ void sighandler (int signal);
+ struct hostent *xgethostbyname (const char *name);
+ struct hostent *xgethostbyaddr (const char *addr, int len, int type);
+ void putserv (const char *fmt, ...);
+-char *getline (void);
++char *get_line (void);
+ char *getmsg (const char *msg);
+ int wuftpd_250_sploitit (void);
+ dirptr newdir (char *name);
+ char *getdir (char *stat);
+ char *int2char (int addr);
+@@ -759,16 +759,16 @@
+ }
+
+ #define LINEBUFLEN 8192
+ char linebuf[LINEBUFLEN]; /* saves us free()ing trouble. */
+
+-/* getline
++/* get_line
+ *
+ * get next line from server or local buffer
+ */
+ char *
+-getline (void)
++get_line (void)
+ {
+ char y[2];
+ int i = 0;
+
+ memset (linebuf, '\0', sizeof (linebuf));
+@@ -776,11 +776,11 @@
+
+ while (strncmp (y, "\n", 1) != 0)
+ {
+ if (i > (sizeof (linebuf) + 2))
+ {
+- err (0, "getline() buffer full");
++ err (0, "get_line() buffer full");
+ }
+ i += xread (fd, y, 1);
+ strcat (linebuf, y);
+ }
+
+@@ -835,11 +835,11 @@
+ char *line;
+ int i = strlen (msg);
+
+ do
+ {
+- line = getline ();
++ line = get_line ();
+ }
+ while (strncmp (line, msg, i) != 0 && strncmp (line, "5", 1) != 0);
+
+ return (line);
+ }
+@@ -919,11 +919,11 @@
+ nostat = 0;
+ putserv ("STAT .\n");
+
+ while (strncmp (line, "213 ", 4) != 0)
+ {
+- line = getline ();
++ line = get_line ();
+ tmp = getdir (line);
+
+ if (tmp == NULL)
+ continue;
+ if (dirroot == NULL)
+@@ -1279,14 +1279,14 @@
+ break;
+ }
+
+ string[tesopt.dirlen] = 0;
+ putserv ("MKD %s\n", string);
+- getline ();
++ get_line ();
+
+ putserv ("CWD %s\n", string);
+- getline ();
++ get_line ();
+ }
+
+ getpwd ();
+ disp = 1;
+
+@@ -1318,11 +1318,11 @@
+
+ if (strlen (string) < 20)
+ err (0, "cwd string too short.. check for 0x0's.\n");
+
+ putserv ("CWD %s\n", string);
+- getline ();
++ get_line ();
+
+ /************ jmpbuf ***********/
+
+ if (debug > 0)
+ printf ("Sending jmpbuf\n");
+@@ -1334,11 +1334,11 @@
+ if (strlen (string) != 32)
+ err (0, "jmpbuf string too short.. check for 0x0's.\n");
+
+ putserv ("%s\n", string);
+
+- getline ();
++ get_line ();
+
+ return (1);
+ }
+
+ /* shell
+diff -NrU5 raccess-0.7.original/exploits/wu2.5.0e.c raccess-0.7/exploits/wu2.5.0e.c
+--- raccess-0.7.original/exploits/wu2.5.0e.c 2009-07-08 17:55:35.000000000 +0000
++++ raccess-0.7/exploits/wu2.5.0e.c 2009-07-08 18:07:19.000000000 +0000
+@@ -104,11 +104,11 @@
+ int xconnect (int sockfd, struct sockaddr *serv_addr, int addrlen);
+ void sighandler (int signal);
+ struct hostent *xgethostbyname (const char *name);
+ struct hostent *xgethostbyaddr (const char *addr, int len, int type);
+ void putserv (const char *fmt, ...);
+-char *getline (void);
++char *get_line (void);
+ char *getmsg (const char *msg);
+ int wuftpd_250_sploitit (void);
+ dirptr newdir (char *name);
+ char *getdir (char *stat);
+ char *int2char (int addr);
+@@ -759,16 +759,16 @@
+ }
+
+ #define LINEBUFLEN 8192
+ char linebuf[LINEBUFLEN]; /* saves us free()ing trouble. */
+
+-/* getline
++/* get_line
+ *
+ * get next line from server or local buffer
+ */
+ char *
+-getline (void)
++get_line (void)
+ {
+ char y[2];
+ int i = 0;
+
+ memset (linebuf, '\0', sizeof (linebuf));
+@@ -776,11 +776,11 @@
+
+ while (strncmp (y, "\n", 1) != 0)
+ {
+ if (i > (sizeof (linebuf) + 2))
+ {
+- err (0, "getline() buffer full");
++ err (0, "get_line() buffer full");
+ }
+ i += xread (fd, y, 1);
+ strcat (linebuf, y);
+ }
+
+@@ -835,11 +835,11 @@
+ char *line;
+ int i = strlen (msg);
+
+ do
+ {
+- line = getline ();
++ line = get_line ();
+ }
+ while (strncmp (line, msg, i) != 0 && strncmp (line, "5", 1) != 0);
+
+ return (line);
+ }
+@@ -919,11 +919,11 @@
+ nostat = 0;
+ putserv ("STAT .\n");
+
+ while (strncmp (line, "213 ", 4) != 0)
+ {
+- line = getline ();
++ line = get_line ();
+ tmp = getdir (line);
+
+ if (tmp == NULL)
+ continue;
+ if (dirroot == NULL)
+@@ -1279,14 +1279,14 @@
+ break;
+ }
+
+ string[tesopt.dirlen] = 0;
+ putserv ("MKD %s\n", string);
+- getline ();
++ get_line ();
+
+ putserv ("CWD %s\n", string);
+- getline ();
++ get_line ();
+ }
+
+ getpwd ();
+ disp = 1;
+
+@@ -1318,11 +1318,11 @@
+
+ if (strlen (string) < 20)
+ err (0, "cwd string too short.. check for 0x0's.\n");
+
+ putserv ("CWD %s\n", string);
+- getline ();
++ get_line ();
+
+ /************ jmpbuf ***********/
+
+ if (debug > 0)
+ printf ("Sending jmpbuf\n");
+@@ -1334,11 +1334,11 @@
+ if (strlen (string) != 32)
+ err (0, "jmpbuf string too short.. check for 0x0's.\n");
+
+ putserv ("%s\n", string);
+
+- getline ();
++ get_line ();
+
+ return (1);
+ }
+
+ /* shell
diff --git a/net-misc/raccess/raccess-0.7.ebuild b/net-misc/raccess/raccess-0.7.ebuild
index 1bd17b42df77..c65ea2d28749 100644
--- a/net-misc/raccess/raccess-0.7.ebuild
+++ b/net-misc/raccess/raccess-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/raccess/raccess-0.7.ebuild,v 1.8 2009/01/05 18:28:57 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/raccess/raccess-0.7.ebuild,v 1.9 2009/07/08 18:33:20 vostorga Exp $
inherit eutils toolchain-funcs
@@ -14,6 +14,7 @@ KEYWORDS="x86 sparc ~ppc ~amd64"
IUSE=""
DEPEND="net-libs/libpcap"
+RDEPEND=""
src_unpack() {
unpack ${A}
@@ -21,6 +22,7 @@ src_unpack() {
sed -i '/^BINFILES/s:@bindir@:/usr/lib/raccess:' src/Makefile.in
sed -i '/^bindir/s:@bindir@/exploits:/usr/lib/raccess:' exploits/Makefile.in
epatch "${FILESDIR}"/${P}-asneeded.patch
+ epatch "${FILESDIR}"/${P}-glibc210.patch
}
src_compile() {