summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-01-16 00:16:41 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-01-16 00:16:41 +0000
commitd28448c7ba6ceb43157b3643c32c4b31070b6209 (patch)
treee929875e0a5edd5ab4ba9e2286db817d2d849285 /net-misc/raccess
parentresolve bug #183; add missing manpages; fail build when trying to build share... (diff)
downloadgentoo-2-d28448c7ba6ceb43157b3643c32c4b31070b6209.tar.gz
gentoo-2-d28448c7ba6ceb43157b3643c32c4b31070b6209.tar.bz2
gentoo-2-d28448c7ba6ceb43157b3643c32c4b31070b6209.zip
raccess 0.6: a security auditing tool
Diffstat (limited to 'net-misc/raccess')
-rw-r--r--net-misc/raccess/files/digest-raccess-0.61
-rw-r--r--net-misc/raccess/raccess-0.6.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/raccess/files/digest-raccess-0.6 b/net-misc/raccess/files/digest-raccess-0.6
new file mode 100644
index 000000000000..8e0d76d973fd
--- /dev/null
+++ b/net-misc/raccess/files/digest-raccess-0.6
@@ -0,0 +1 @@
+MD5 8d045a0b336f0cd635c4ab788d2872da raccess-0.6.tar.gz 225280
diff --git a/net-misc/raccess/raccess-0.6.ebuild b/net-misc/raccess/raccess-0.6.ebuild
new file mode 100644
index 000000000000..8cc9ba4f8d38
--- /dev/null
+++ b/net-misc/raccess/raccess-0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/raccess/raccess-0.6.ebuild,v 1.1 2002/01/16 00:16:41 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Remote Access Session is a security tool to analyze the integrity of systems using a library of publically available (and proven to work) exploits"
+SRC_URI="http://salix.org/raccess/${P}.tar.gz"
+HOMEPAGE="http://salix.org/raccess/"
+
+DEPEND=""
+
+src_compile() {
+
+ ./configure --prefix=/usr --sysconfdir=/etc/raccess --host=${CHOST} || die
+ make BINFILES="-DLOCATION_BIN_FILES=\\\"/usr/lib/raccess\\\"" CFGFILES="-DLOCATION_CONFIG_FILES=\\\"/etc/raccess\\\"" CFLAGS="-g ${CFLAGS}" all || die
+
+}
+
+src_install() {
+
+ dodir /etc/raccess
+ dodir /usr/lib/raccess
+
+ mv ${S}/exploits/Makefile ${S}/exploits/Makefile.old
+ sed 's/bin\/exploits/lib\/raccess/g' ${S}/exploits/Makefile.old > ${S}/exploits/Makefile
+
+ make prefix=${D}/usr mandir=${D}/usr/share/man sysconfdir=${D}/etc/raccess install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS PROJECT_PLANNING README
+
+}
+