summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-08-02 02:37:43 +0000
committerJeroen Roovers <jer@gentoo.org>2010-08-02 02:37:43 +0000
commite41f46379a13908c30c91169c2e027fe27d4bc18 (patch)
treee9fed461ddd1a46a35af98fb759a160f4c9a2dd6 /net-misc/socat/socat-2.0.0_beta4.ebuild
parentwhitespace (diff)
downloadgentoo-2-e41f46379a13908c30c91169c2e027fe27d4bc18.tar.gz
gentoo-2-e41f46379a13908c30c91169c2e027fe27d4bc18.tar.bz2
gentoo-2-e41f46379a13908c30c91169c2e027fe27d4bc18.zip
Version bump (bug #330785).
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-misc/socat/socat-2.0.0_beta4.ebuild')
-rw-r--r--net-misc/socat/socat-2.0.0_beta4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/socat/socat-2.0.0_beta4.ebuild b/net-misc/socat/socat-2.0.0_beta4.ebuild
new file mode 100644
index 000000000000..05769fa1ebc1
--- /dev/null
+++ b/net-misc/socat/socat-2.0.0_beta4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-2.0.0_beta4.ebuild,v 1.1 2010/08/02 02:37:43 jer Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+MY_P=${P/_beta/-b}
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="ssl readline ipv6 tcpd"
+
+DEPEND="
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ filter-flags -Wall -Wno-error*
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_test() {
+ TMPDIR="${T}" emake test || die 'self test failed'
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ dodoc BUGREPORTS CHANGES DEVELOPMENT \
+ FAQ FILES PORTING README SECURITY VERSION
+ docinto examples
+ dodoc EXAMPLES *.sh
+ dohtml doc/*.html doc/*.css
+}