summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-15 11:59:45 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-15 11:59:45 +0000
commit4f6b6217079090984bb4781531259bbc126e1a09 (patch)
tree777b10a4b59b283332590711f54319bbd11ad1aa /net-misc/sparkleshare
parentCleanup. (diff)
downloadgentoo-2-4f6b6217079090984bb4781531259bbc126e1a09.tar.gz
gentoo-2-4f6b6217079090984bb4781531259bbc126e1a09.tar.bz2
gentoo-2-4f6b6217079090984bb4781531259bbc126e1a09.zip
Version bump.
(Portage version: 2.1.11.17/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/sparkleshare')
-rw-r--r--net-misc/sparkleshare/ChangeLog8
-rw-r--r--net-misc/sparkleshare/sparkleshare-0.9.2.ebuild75
2 files changed, 81 insertions, 2 deletions
diff --git a/net-misc/sparkleshare/ChangeLog b/net-misc/sparkleshare/ChangeLog
index 75b4bd42e395..5fdd5598aa38 100644
--- a/net-misc/sparkleshare/ChangeLog
+++ b/net-misc/sparkleshare/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/sparkleshare
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/sparkleshare/ChangeLog,v 1.2 2012/05/05 03:20:40 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sparkleshare/ChangeLog,v 1.3 2012/09/15 11:59:45 pacho Exp $
+
+*sparkleshare-0.9.2 (15 Sep 2012)
+
+ 15 Sep 2012; Pacho Ramos <pacho@gentoo.org> +sparkleshare-0.9.2.ebuild:
+ Version bump.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> sparkleshare-0.8.4.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -12,4 +17,3 @@
New ebuild for a Dropbox-like collaboration and sharing tool (bug #362295);
thanks to Sven Mueller, Christoph Brill (egore), Aurélien Delogu, and Travis
Hansen.
-
diff --git a/net-misc/sparkleshare/sparkleshare-0.9.2.ebuild b/net-misc/sparkleshare/sparkleshare-0.9.2.ebuild
new file mode 100644
index 000000000000..d93f76f07f67
--- /dev/null
+++ b/net-misc/sparkleshare/sparkleshare-0.9.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sparkleshare/sparkleshare-0.9.2.ebuild,v 1.1 2012/09/15 11:59:45 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no" # --enable-debug does not do anything
+PYTHON_DEPEND="nautilus? 2"
+
+inherit gnome2 mono multilib python
+
+DESCRIPTION="Git-based collaboration and file sharing tool"
+HOMEPAGE="http://www.sparkleshare.org"
+SRC_URI="http://github.com/downloads/hbons/SparkleShare/${P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="nautilus" # ayatana
+
+COMMON_DEPEND=">=dev-lang/mono-2.8
+ >=dev-dotnet/glib-sharp-2.12.7
+ >=dev-dotnet/gtk-sharp-2.12.10
+ dev-dotnet/notify-sharp
+ dev-dotnet/webkit-sharp
+ nautilus? ( || (
+ (
+ >=dev-python/nautilus-python-1.1-r1
+ >=gnome-base/nautilus-3 )
+ (
+ <dev-python/nautilus-python-1.1
+ =gnome-base/nautilus-2* )
+ ) )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-vcs/git-1.7.3
+ gnome-base/gvfs
+ net-misc/curl[ssl]
+ net-misc/openssh
+ nautilus? ( || (
+ (
+ dev-python/pygobject:3
+ >=gnome-base/nautilus-3[introspection]
+ x11-libs/gtk+:3[introspection] )
+ (
+ dev-python/pygobject:2
+ dev-python/pygtk:2 )
+ ) )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+pkg_setup () {
+ DOCS="NEWS"
+ G2CONF="${G2CONF}
+ --disable-appindicator
+ $(use_enable nautilus nautilus-extension)"
+ # $(use_enable ayatana appindicator)
+ # requires >=appindicator-sharp-0.0.7
+ python_pkg_setup
+}
+
+src_compile() {
+ # FIXME: parallel make fails
+ MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use nautilus && python_mod_optimize /usr/$(get_libdir)/nautilus/extensions-2.0/python/
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ use nautilus && python_mod_cleanup /usr/$(get_libdir)/nautilus/extensions-2.0/python/
+}