summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-03-05 16:24:03 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-03-05 16:24:03 +0000
commit65654419cd7a9eb727c8658c785e50da1135c863 (patch)
tree6451bf57dedfb42377cc2f6311369f9c81263a2c /net-misc/spiped
parentFix too long DESC. (diff)
downloadgentoo-2-65654419cd7a9eb727c8658c785e50da1135c863.tar.gz
gentoo-2-65654419cd7a9eb727c8658c785e50da1135c863.tar.bz2
gentoo-2-65654419cd7a9eb727c8658c785e50da1135c863.zip
Adding spiped-1.5.0 to Portage courtesy of Tomas Mozes <hydrapolic@gmail.com>. Fix #542216.
(Portage version: 2.2.14/cvs/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'net-misc/spiped')
-rw-r--r--net-misc/spiped/ChangeLog5
-rw-r--r--net-misc/spiped/files/spiped.confd21
-rw-r--r--net-misc/spiped/files/spiped.initd46
-rw-r--r--net-misc/spiped/metadata.xml15
-rw-r--r--net-misc/spiped/spiped-1.5.0.ebuild38
5 files changed, 125 insertions, 0 deletions
diff --git a/net-misc/spiped/ChangeLog b/net-misc/spiped/ChangeLog
new file mode 100644
index 000000000000..012b579066ce
--- /dev/null
+++ b/net-misc/spiped/ChangeLog
@@ -0,0 +1,5 @@
+# ChangeLog for net-misc/ipsc
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spiped/ChangeLog,v 1.1 2015/03/05 16:24:03 monsieurp Exp $
+
+
diff --git a/net-misc/spiped/files/spiped.confd b/net-misc/spiped/files/spiped.confd
new file mode 100644
index 000000000000..117be90309c3
--- /dev/null
+++ b/net-misc/spiped/files/spiped.confd
@@ -0,0 +1,21 @@
+# /etc/conf.d/spiped
+
+# Once you're happy with your settings,
+# set IS_CONFIGURED to "yes".
+IS_CONFIGURED="no"
+
+# spiped is shipped with plenty of options.
+# Please see the man page for the complete list.
+# -e : encrypt communication
+# -d : decrypt communication
+OPTS="-e"
+
+# Address and port on which spiped should listen for incoming connections.
+# If you want it to listen on the loopback interface, do not specify "localhost"
+# but the localhost IP address instead. spiped won't start if you do so.
+SRCHOST="127.0.0.1"
+SRCPORT="12345"
+
+# Address and port to which spiped should connect
+TARGETHOST="some.domain.tld"
+TARGETPORT="1337"
diff --git a/net-misc/spiped/files/spiped.initd b/net-misc/spiped/files/spiped.initd
new file mode 100644
index 000000000000..63db72f9e457
--- /dev/null
+++ b/net-misc/spiped/files/spiped.initd
@@ -0,0 +1,46 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spiped/files/spiped.initd,v 1.1 2015/03/05 16:24:03 monsieurp Exp $
+
+KEYFILE=${KEYFILE:="/etc/spiped/keyfile"}
+SPIPED_USER=${SPIPED_USER:="nobody"}
+PIDFILE="/run/spiped/spiped.pid"
+
+command="spiped"
+command_args="${OPTS} -s [${SRCHOST}]:${SRCPORT} -t ${TARGETHOST}:${TARGETPORT} -k ${KEYFILE} -p ${PIDFILE}"
+
+depend() {
+ use net
+ before logger
+}
+
+checkconfig() {
+ if [[ ! "$IS_CONFIGURED" == "yes" ]]; then
+ eerror "You need to setup /etc/conf.d/spiped first!"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting ${SVCNAME}"
+ checkpath -d -o "${SPIPED_USER}" -m750 "$(dirname "${PIDFILE}")"
+
+ start-stop-daemon --start \
+ --user ${SPIPED_USER} \
+ --pidfile ${PIDFILE} \
+ --exec $command -- $command_args
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+
+ start-stop-daemon --stop \
+ --pidfile ${PIDFILE}
+
+ eend $?
+}
diff --git a/net-misc/spiped/metadata.xml b/net-misc/spiped/metadata.xml
new file mode 100644
index 000000000000..1b2d73180213
--- /dev/null
+++ b/net-misc/spiped/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Spiped (pronounced "ess-pipe-dee") is a utility for creating symmetrically
+ encrypted and authenticated pipes between socket addresses, so that one may
+ connect to one address (e.g., a UNIX socket on localhost) and transparently
+ have a connection established to another address (e.g., a UNIX socket on a
+ different system). This is similar to 'ssh -L' functionality, but does not
+ use SSH and requires a pre-shared symmetric key.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-misc/spiped/spiped-1.5.0.ebuild b/net-misc/spiped/spiped-1.5.0.ebuild
new file mode 100644
index 000000000000..d1c8b8b51b88
--- /dev/null
+++ b/net-misc/spiped/spiped-1.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spiped/spiped-1.5.0.ebuild,v 1.1 2015/03/05 16:24:03 monsieurp Exp $
+
+EAPI=5
+
+DESCRIPTION="secure pipe daemon"
+HOMEPAGE="http://www.tarsnap.com/spiped.html"
+SRC_URI="http://www.tarsnap.com/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl:*"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin spipe/spipe
+ dosbin spiped/spiped
+
+ doman spipe/spipe.1 spiped/spiped.1
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ dodir etc/spiped
+}
+
+pkg_postinst() {
+ elog
+ elog "You will need to configure spiped via its"
+ elog "configuration file located in /etc/conf.d/."
+ elog
+ elog "Please have a look at this file prior to starting up spiped!"
+ elog
+}