summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-01-01 02:19:05 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-01-01 02:19:05 +0000
commit6e8e4a19efe4d1f512d1a5e94ba41ab68e505659 (patch)
tree9b5d0f3d3863bd10931df2be7d3d4cbbdb12fe56 /net-misc/stone/stone-2.2d.ebuild
parentAdded ~sparc keyword. (Manifest recommit) (diff)
downloadgentoo-2-6e8e4a19efe4d1f512d1a5e94ba41ab68e505659.tar.gz
gentoo-2-6e8e4a19efe4d1f512d1a5e94ba41ab68e505659.tar.bz2
gentoo-2-6e8e4a19efe4d1f512d1a5e94ba41ab68e505659.zip
Version bumped.
Diffstat (limited to 'net-misc/stone/stone-2.2d.ebuild')
-rw-r--r--net-misc/stone/stone-2.2d.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/stone/stone-2.2d.ebuild b/net-misc/stone/stone-2.2d.ebuild
new file mode 100644
index 000000000000..6a8ed87809f7
--- /dev/null
+++ b/net-misc/stone/stone-2.2d.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stone/stone-2.2d.ebuild,v 1.1 2005/01/01 02:19:05 matsuu Exp $
+
+DESCRIPTION="A simple TCP/IP packet repeater"
+HOMEPAGE="http://www.gcd.org/sengoku/stone/"
+SRC_URI="http://www.gcd.org/sengoku/stone/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+IUSE="ssl"
+
+DEPEND="virtual/libc
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ if use ssl ; then
+ emake \
+ CFLAGS="${CFLAGS}" \
+ SSL=/usr \
+ linux-ssl || die
+ else
+ emake \
+ CFLAGS="${CFLAGS}" \
+ linux || die
+ fi
+}
+
+src_install() {
+ dobin stone
+ doman stone.1
+ dodoc README*
+}