summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2008-03-30 09:53:43 +0000
committerLars Weiler <pylon@gentoo.org>2008-03-30 09:53:43 +0000
commit3c62315250cec2daef2c7beb5ef6f5513022c4b2 (patch)
treebe61d2b3f1aac43064b2f889cd739cfb4983b1e2 /net-misc/strongswan
parentold (diff)
downloadgentoo-2-3c62315250cec2daef2c7beb5ef6f5513022c4b2.tar.gz
gentoo-2-3c62315250cec2daef2c7beb5ef6f5513022c4b2.tar.bz2
gentoo-2-3c62315250cec2daef2c7beb5ef6f5513022c4b2.zip
Version bump; bugs #211853 and #211938.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-misc/strongswan')
-rw-r--r--net-misc/strongswan/ChangeLog10
-rw-r--r--net-misc/strongswan/files/ipsec-install-4.1.11.patch21
-rw-r--r--net-misc/strongswan/strongswan-4.1.11.ebuild97
3 files changed, 126 insertions, 2 deletions
diff --git a/net-misc/strongswan/ChangeLog b/net-misc/strongswan/ChangeLog
index f863883ee50c..bef16fc29f55 100644
--- a/net-misc/strongswan/ChangeLog
+++ b/net-misc/strongswan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/strongswan
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/ChangeLog,v 1.58 2007/12/16 14:32:49 pylon Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/ChangeLog,v 1.59 2008/03/30 09:53:42 pylon Exp $
+
+*strongswan-4.1.11 (30 Mar 2008)
+
+ 30 Mar 2008; Lars Weiler <pylon@gentoo.org>
+ +files/ipsec-install-4.1.11.patch, +strongswan-4.1.11.ebuild:
+ Version bump; bugs #211853 and #211938.
*strongswan-4.1.9 (16 Dec 2007)
diff --git a/net-misc/strongswan/files/ipsec-install-4.1.11.patch b/net-misc/strongswan/files/ipsec-install-4.1.11.patch
new file mode 100644
index 000000000000..d1be25442f69
--- /dev/null
+++ b/net-misc/strongswan/files/ipsec-install-4.1.11.patch
@@ -0,0 +1,21 @@
+diff -Naur strongswan-4.1.11.orig/src/starter/Makefile.am strongswan-4.1.11/src/starter/Makefile.am
+--- strongswan-4.1.11.orig/src/starter/Makefile.am 2008-03-29 20:40:34.000000000 +0100
++++ strongswan-4.1.11/src/starter/Makefile.am 2008-03-29 20:41:00.000000000 +0100
+@@ -31,4 +31,4 @@
+ $(COMPILE) -c -o $@ $<
+
+ install-exec-local :
+- test -e "$(DESTDIR)$(sysconfdir)/ipsec.conf" || $(INSTALL) ipsec.conf $(DESTDIR)$(sysconfdir)/ipsec.conf
++ test -e "$(DESTDIR)$(sysconfdir)/ipsec.conf" || $(INSTALL) -D ipsec.conf $(DESTDIR)$(sysconfdir)/ipsec.conf
+diff -Naur strongswan-4.1.11.orig/src/starter/Makefile.in strongswan-4.1.11/src/starter/Makefile.in
+--- strongswan-4.1.11.orig/src/starter/Makefile.in 2008-03-29 20:40:34.000000000 +0100
++++ strongswan-4.1.11/src/starter/Makefile.in 2008-03-29 20:40:52.000000000 +0100
+@@ -628,7 +628,7 @@
+ $(COMPILE) -c -o $@ $<
+
+ install-exec-local :
+- test -e "$(DESTDIR)$(sysconfdir)/ipsec.conf" || $(INSTALL) ipsec.conf $(DESTDIR)$(sysconfdir)/ipsec.conf
++ test -e "$(DESTDIR)$(sysconfdir)/ipsec.conf" || $(INSTALL) -D ipsec.conf $(DESTDIR)$(sysconfdir)/ipsec.conf
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/net-misc/strongswan/strongswan-4.1.11.ebuild b/net-misc/strongswan/strongswan-4.1.11.ebuild
new file mode 100644
index 000000000000..f2fa4fd1a0f9
--- /dev/null
+++ b/net-misc/strongswan/strongswan-4.1.11.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/strongswan-4.1.11.ebuild,v 1.1 2008/03/30 09:53:42 pylon Exp $
+
+inherit eutils linux-info
+
+UGID="ipsec"
+
+DESCRIPTION="Open Source implementation of IPsec for the Linux operating system."
+HOMEPAGE="http://www.strongswan.org/"
+SRC_URI="http://download.strongswan.org/${P}.tar.bz2"
+
+LICENSE="GPL-2 RSA-MD2 RSA-MD5 RSA-PKCS11 DES"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="cisco curl debug ldap nat smartcard static xml"
+
+COMMON_DEPEND="!net-misc/openswan
+ dev-libs/gmp"
+DEPEND="${COMMON_DEPEND}
+ virtual/linux-sources
+ sys-kernel/linux-headers
+ curl? ( net-misc/curl )
+ ldap? ( net-nds/openldap )
+ smartcard? ( dev-libs/opensc )
+ xml? ( dev-libs/libxml2 )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/logger
+ sys-apps/iproute2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/ipsec-install-${PV}.patch
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ einfo "Linux kernel is version ${KV_FULL}"
+
+ if kernel_is 2 6; then
+ einfo "This ebuild will set ${P} to use 2.6 native IPsec (KAME)."
+ else
+ eerror "Sorry, no support for your kernel version ${KV_FULL}."
+ die "Install an IPsec enabled 2.6 kernel."
+ fi
+
+ # change to an unprivileged user by default
+ enewgroup ${UGID}
+ enewuser ${UGID} -1 -1 -1 ${UGID}
+}
+
+src_compile() {
+ local myconf=""
+
+ # change to an unprivileged user by default
+ myconf="${myconf} --with-uid=$(id -u ${UGID}) --with-gid=$(id -g ${UGID})"
+ # strongswan enables both by default; switch to the user's wish
+ if use static; then
+ myconf="${myconf} --enable-static --disable-shared"
+ else
+ myconf="${myconf} --disable-static --enable-shared"
+ fi
+
+ econf \
+ $(use_enable curl http) \
+ $(use_enable ldap) \
+ $(use_enable xml) \
+ $(use_enable smartcard) \
+ $(use_enable cisco cisco-quirks) \
+ $(use_enable debug leak-detective) \
+ $(use_enable nat nat-transport) \
+ ${myconf} \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed."
+
+ doinitd "${FILESDIR}"/ipsec
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Starting with the strongswan-4 branch, the configuration files"
+ ewarn "will be installed into the default directory \"/etc/\""
+ ewarn "instead of the Gentoo-specific directory \"/etc/ipsec/\"."
+ ewarn "Please adjust your configuration!"
+ echo
+ einfo "The up-to-date configuration manual is available online at"
+ einfo "http://www.strongswan.org/docs/readme.htm"
+ echo
+}