summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-29 12:20:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-29 12:20:07 +0000
commitee259d905323e44e1af79a8459ae9d616bfbf9f0 (patch)
tree0f56e2d9725a3fab7e37c11eb67397d3335a8d8f /net-misc/tcpsound
parentStable for HPPA too. Version bump. (diff)
downloadgentoo-2-ee259d905323e44e1af79a8459ae9d616bfbf9f0.tar.gz
gentoo-2-ee259d905323e44e1af79a8459ae9d616bfbf9f0.tar.bz2
gentoo-2-ee259d905323e44e1af79a8459ae9d616bfbf9f0.zip
Fix building with -Wl,--as-needed wrt #248143 by Kacper Kowalik.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/tcpsound')
-rw-r--r--net-misc/tcpsound/ChangeLog8
-rw-r--r--net-misc/tcpsound/files/tcpsound-0.3.1-asneeded.patch22
-rw-r--r--net-misc/tcpsound/tcpsound-0.3.1.ebuild14
3 files changed, 38 insertions, 6 deletions
diff --git a/net-misc/tcpsound/ChangeLog b/net-misc/tcpsound/ChangeLog
index e663797ff7de..052548118d8e 100644
--- a/net-misc/tcpsound/ChangeLog
+++ b/net-misc/tcpsound/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/tcpsound
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tcpsound/ChangeLog,v 1.4 2007/10/29 15:36:44 jokey Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tcpsound/ChangeLog,v 1.5 2010/03/29 12:20:07 ssuominen Exp $
+
+ 29 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> tcpsound-0.3.1.ebuild,
+ +files/tcpsound-0.3.1-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #248143 by Kacper Kowalik.
29 Oct 2007; Markus Ullmann <jokey@gentoo.org> tcpsound-0.3.1.ebuild:
Fix quoting
diff --git a/net-misc/tcpsound/files/tcpsound-0.3.1-asneeded.patch b/net-misc/tcpsound/files/tcpsound-0.3.1-asneeded.patch
new file mode 100644
index 000000000000..76f4e2b4d01f
--- /dev/null
+++ b/net-misc/tcpsound/files/tcpsound-0.3.1-asneeded.patch
@@ -0,0 +1,22 @@
+--- Makefile
++++ Makefile
+@@ -10,15 +10,16 @@
+ MAN = tcpsound.1
+ MANGZ = $(MAN:.1=.1.gz)
+ MKTOOL = ./mktool
+-CFLAGS = -c -v -g -W1 -I$(includedir) -L$(libdir) -lSDL -lmba -lpthread
++CFLAGS = -c -v -g -W1 -I$(includedir)
++LIBS = -L$(libdir) -lSDL -lmba -lpthread
+ CC = $(MKTOOL)
+
+ .SUFFIXES: .1 .1.gz
+
+ tcpsound: mktool src/tcpsound.c src/sound.h src/sound.c src/parse.h src/parse.c
+- @$(CC) $(CFLAGS) src/sound.c src/parse.c src/tcpsound.c -o tcpsound
++ @$(CC) $(CFLAGS) src/sound.c src/parse.c src/tcpsound.c -o tcpsound $(LIBS)
+ play: mktool src/play.c
+- @$(CC) $(CFLAGS) src/play.c -o play
++ @$(CC) $(CFLAGS) src/play.c -o play $(LIBS)
+
+ mktool:
+ cc -g -o mktool mktool.c
diff --git a/net-misc/tcpsound/tcpsound-0.3.1.ebuild b/net-misc/tcpsound/tcpsound-0.3.1.ebuild
index ca41c0f464f8..7636235eaed5 100644
--- a/net-misc/tcpsound/tcpsound-0.3.1.ebuild
+++ b/net-misc/tcpsound/tcpsound-0.3.1.ebuild
@@ -1,22 +1,28 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tcpsound/tcpsound-0.3.1.ebuild,v 1.3 2007/10/29 15:36:44 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tcpsound/tcpsound-0.3.1.ebuild,v 1.4 2010/03/29 12:20:07 ssuominen Exp $
inherit eutils
DESCRIPTION="Play sounds in response to network traffic"
HOMEPAGE="http://www.ioplex.com/~miallen/tcpsound/"
SRC_URI="http://www.ioplex.com/~miallen/tcpsound/dl/${P}.tar.gz"
-LICENSE="BSD"
+LICENSE="BSD"
SLOT="0"
KEYWORDS="x86"
-
IUSE=""
+
DEPEND="net-analyzer/tcpdump
media-libs/libsdl
dev-libs/libmba"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
src_compile() {
sed -i -e "s;/usr/share/sounds:/usr/local/share/sounds;/usr/share/tcpsound;g"\
"${S}"/src/tcpsound.c "${S}"/elaborate.conf