summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2005-07-13 01:39:15 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2005-07-13 01:39:15 +0000
commit07f0e56319678ab9b51bd54a350093302cd4c102 (patch)
tree969ca2aad9f033e94a0c48cf8d51ce8d9775287a /net-misc/unison
parentVersion bump. (diff)
downloadgentoo-2-07f0e56319678ab9b51bd54a350093302cd4c102.tar.gz
gentoo-2-07f0e56319678ab9b51bd54a350093302cd4c102.tar.bz2
gentoo-2-07f0e56319678ab9b51bd54a350093302cd4c102.zip
Make threads support optional, minor fixes.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-misc/unison')
-rw-r--r--net-misc/unison/ChangeLog6
-rw-r--r--net-misc/unison/Manifest4
-rw-r--r--net-misc/unison/unison-2.12.0.ebuild11
-rw-r--r--net-misc/unison/unison-2.13.0.ebuild10
4 files changed, 21 insertions, 10 deletions
diff --git a/net-misc/unison/ChangeLog b/net-misc/unison/ChangeLog
index d0eabdb3fa40..85ac969aff59 100644
--- a/net-misc/unison/ChangeLog
+++ b/net-misc/unison/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/unison
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.27 2005/07/12 22:37:16 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.28 2005/07/13 01:39:15 mattam Exp $
+
+ 13 Jul 2005; Matthieu Sozeau <mattam@gentoo.org> unison-2.12.0.ebuild,
+ unison-2.13.0.ebuild:
+ Make thread support configurable, minor fixes (doc flag, wrong cd).
*unison-2.13.0 (12 Jul 2005)
diff --git a/net-misc/unison/Manifest b/net-misc/unison/Manifest
index 337674deb87b..7f8bdc3213b6 100644
--- a/net-misc/unison/Manifest
+++ b/net-misc/unison/Manifest
@@ -1,5 +1,5 @@
-MD5 bf3920dfc4ab1090cb6496239515f01e unison-2.12.0.ebuild 1800
-MD5 93236a9e09f56e12fb1684bd9e11774a unison-2.13.0.ebuild 1868
+MD5 d8d413982a487e57d0ff63439d93178c unison-2.12.0.ebuild 1848
+MD5 d370c48553f0ab9616c6fdb8c71675a0 unison-2.13.0.ebuild 1920
MD5 55d4186daa96858ed375a6da33d75432 ChangeLog 4007
MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
MD5 f2b7bb2888f634f6b2e887a7f6ceda64 files/digest-unison-2.12.0 204
diff --git a/net-misc/unison/unison-2.12.0.ebuild b/net-misc/unison/unison-2.12.0.ebuild
index 9accc6884f15..3bae8c800452 100644
--- a/net-misc/unison/unison-2.12.0.ebuild
+++ b/net-misc/unison/unison-2.12.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.12.0.ebuild,v 1.1 2005/07/12 22:37:16 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.12.0.ebuild,v 1.2 2005/07/13 01:39:15 mattam Exp $
inherit eutils
-IUSE="gtk gtk2 static debug"
+IUSE="gtk gtk2 doc static debug threads"
DESCRIPTION="Two-way cross-platform file synchronizer"
HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
@@ -31,7 +31,11 @@ src_unpack() {
}
src_compile() {
- local myconf="THREADS=true"
+ local myconf
+
+ if use threads; then
+ myconf="$myconf THREADS=true"
+ fi
if use static; then
myconf="$myconf STATIC=true"
@@ -57,7 +61,6 @@ src_compile() {
src_install () {
# install manually, since it's just too much
# work to force the Makefile to do the right thing.
- cd src
dobin unison || die
dodoc BUGS.txt CONTRIB COPYING INSTALL NEWS \
README ROADMAP.txt TODO.txt || die
diff --git a/net-misc/unison/unison-2.13.0.ebuild b/net-misc/unison/unison-2.13.0.ebuild
index 25e9c9862a6b..9d860ed7c6fd 100644
--- a/net-misc/unison/unison-2.13.0.ebuild
+++ b/net-misc/unison/unison-2.13.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.13.0.ebuild,v 1.1 2005/07/12 22:37:16 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.13.0.ebuild,v 1.2 2005/07/13 01:39:15 mattam Exp $
inherit eutils
-IUSE="gtk gtk2 doc static debug"
+IUSE="gtk gtk2 doc static debug threads"
DESCRIPTION="Two-way cross-platform file synchronizer"
HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
@@ -35,7 +35,11 @@ src_unpack() {
}
src_compile() {
- local myconf="THREADS=true"
+ local myconf
+
+ if use threads; then
+ myconf="$myconf THREADS=true"
+ fi
if use static; then
myconf="$myconf STATIC=true"