summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-02-18 11:37:39 +0000
committerPacho Ramos <pacho@gentoo.org>2015-02-18 11:37:39 +0000
commit50245a68be0068e8278fde3d047cca0c5c697fe7 (patch)
treef0b31e546811d59e1a78442b2f9aa6cb1297de8c /net-misc/vino
parentVersion bump, drop old (diff)
downloadgentoo-2-50245a68be0068e8278fde3d047cca0c5c697fe7.tar.gz
gentoo-2-50245a68be0068e8278fde3d047cca0c5c697fe7.tar.bz2
gentoo-2-50245a68be0068e8278fde3d047cca0c5c697fe7.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-misc/vino')
-rw-r--r--net-misc/vino/ChangeLog9
-rw-r--r--net-misc/vino/metadata.xml2
-rw-r--r--net-misc/vino/vino-3.14.2.ebuild69
3 files changed, 78 insertions, 2 deletions
diff --git a/net-misc/vino/ChangeLog b/net-misc/vino/ChangeLog
index 83582c3c0b2b..984fd2630ab8 100644
--- a/net-misc/vino/ChangeLog
+++ b/net-misc/vino/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/vino
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vino/ChangeLog,v 1.217 2014/12/23 23:08:32 eva Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vino/ChangeLog,v 1.218 2015/02/18 11:37:39 pacho Exp $
+
+*vino-3.14.2 (18 Feb 2015)
+
+ 18 Feb 2015; Pacho Ramos <pacho@gentoo.org> +vino-3.14.2.ebuild, metadata.xml:
+ Version bump
*vino-3.14.1 (23 Dec 2014)
diff --git a/net-misc/vino/metadata.xml b/net-misc/vino/metadata.xml
index f140c75c3b91..326077bc4073 100644
--- a/net-misc/vino/metadata.xml
+++ b/net-misc/vino/metadata.xml
@@ -3,6 +3,8 @@
<pkgmetadata>
<herd>gnome</herd>
<use>
+ <flag name="libsecret">Enable app-crypt/libsecret support to store
+ login credentials.</flag>
<flag name="telepathy">Enable desktop sharing through a telepathy client</flag>
</use>
</pkgmetadata>
diff --git a/net-misc/vino/vino-3.14.2.ebuild b/net-misc/vino/vino-3.14.2.ebuild
new file mode 100644
index 000000000000..fe0f0082ed6d
--- /dev/null
+++ b/net-misc/vino/vino-3.14.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vino/vino-3.14.2.ebuild,v 1.1 2015/02/18 11:37:39 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="An integrated VNC server for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Vino"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt libsecret ipv6 jpeg networkmanager ssl +telepathy zeroconf +zlib"
+# bug #394611; tight encoding requires zlib encoding
+REQUIRED_USE="jpeg? ( zlib )"
+
+# cairo used in vino-fb
+# libSM and libICE used in eggsmclient-xsmp
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=x11-libs/gtk+-3.0.0:3
+ >=dev-libs/libgcrypt-1.1.90:0=
+
+ dev-libs/dbus-glib
+ x11-libs/cairo:=
+ x11-libs/pango[X]
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libSM
+ x11-libs/libXtst
+
+ >=x11-libs/libnotify-0.7.0:=
+
+ crypt? ( >=dev-libs/libgcrypt-1.1.90:0= )
+ libsecret? ( app-crypt/libsecret )
+ jpeg? ( virtual/jpeg:0= )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ ssl? ( >=net-libs/gnutls-2.2.0:= )
+ telepathy? ( >=net-libs/telepathy-glib-0.18 )
+ zeroconf? ( >=net-dns/avahi-0.6:=[dbus] )
+ zlib? ( sys-libs/zlib:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+ app-crypt/libsecret
+"
+# libsecret is always required at build time per bug 322763
+
+src_configure() {
+ gnome2_src_configure \
+ --with-gcrypt \
+ $(use_with crypt gcrypt) \
+ $(use_enable ipv6) \
+ $(use_with jpeg) \
+ $(use_with libsecret secret) \
+ $(use_with networkmanager network-manager) \
+ $(use_with ssl gnutls) \
+ $(use_with telepathy) \
+ $(use_with zeroconf avahi) \
+ $(use_with zlib)
+}