summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-12-29 20:04:20 +0000
committerChristian Heim <phreak@gentoo.org>2007-12-29 20:04:20 +0000
commit03c532144909bd54ae17788d62db75d2d44e30fd (patch)
treedd5c99946b85638b04d22b58b8398a24f400b65d /net-misc
parentMarking gcc-config-1.4.0-r4 ppc64 for bug 203576 (diff)
downloadgentoo-2-03c532144909bd54ae17788d62db75d2d44e30fd.tar.gz
gentoo-2-03c532144909bd54ae17788d62db75d2d44e30fd.tar.bz2
gentoo-2-03c532144909bd54ae17788d62db75d2d44e30fd.zip
Adding patch for compilation against dev-libs/popt-1.12, as N is already defined in popt.h. This keeps it working with current stable dev-libs/popt, which doesn't have the define in popt.h. Thanks to Preston Crow <pc_gentoo_bugzilla at crowcastle.net> in #201958 for the idea.
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/pump/ChangeLog9
-rw-r--r--net-misc/pump/files/pump-0.8.24-redefinition.patch12
-rw-r--r--net-misc/pump/pump-0.8.24.ebuild8
3 files changed, 26 insertions, 3 deletions
diff --git a/net-misc/pump/ChangeLog b/net-misc/pump/ChangeLog
index f1f0355d6368..72abc838e464 100644
--- a/net-misc/pump/ChangeLog
+++ b/net-misc/pump/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/pump
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/ChangeLog,v 1.38 2007/12/25 16:26:45 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/ChangeLog,v 1.39 2007/12/29 20:04:20 phreak Exp $
+
+ 29 Dec 2007; Christian Heim <phreak@gentoo.org>
+ +files/pump-0.8.24-redefinition.patch, pump-0.8.24.ebuild:
+ Adding patch for compilation against dev-libs/popt-1.12, as N is already
+ defined in popt.h. This keeps it working with current stable dev-libs/popt,
+ which doesn't have the define in popt.h. Thanks to Preston Crow
+ <pc_gentoo_bugzilla at crowcastle.net> in #201958 for the idea.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing uberlord from metadata.xml as per #199318. Assigning to
diff --git a/net-misc/pump/files/pump-0.8.24-redefinition.patch b/net-misc/pump/files/pump-0.8.24-redefinition.patch
new file mode 100644
index 000000000000..83543379b74d
--- /dev/null
+++ b/net-misc/pump/files/pump-0.8.24-redefinition.patch
@@ -0,0 +1,12 @@
+--- pump-0.8.24/pump.c.orig 2007-12-29 19:51:22.000000000 +0000
++++ pump-0.8.24/pump.c 2007-12-29 19:52:00.000000000 +0000
+@@ -58,7 +58,9 @@
+ int bootp_server_port;
+ #endif
+
++#if !defined(N_)
+ #define N_(foo) (foo)
++#endif
+
+ #define PROGNAME "pump"
+ #define CONTROLSOCKET "/var/run/pump.sock" \ No newline at end of file
diff --git a/net-misc/pump/pump-0.8.24.ebuild b/net-misc/pump/pump-0.8.24.ebuild
index 695212d49614..37712834ccdb 100644
--- a/net-misc/pump/pump-0.8.24.ebuild
+++ b/net-misc/pump/pump-0.8.24.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/pump-0.8.24.ebuild,v 1.8 2006/09/26 05:37:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/pump-0.8.24.ebuild,v 1.9 2007/12/29 20:04:20 phreak Exp $
inherit eutils
@@ -33,6 +33,10 @@ src_unpack() {
# Enable the creation of /etc/ntp.conf and the --no-ntp option
epatch "${FILESDIR}/pump-${PV}-gentoo.patch"
+ # Add an if defined around the definition of foo, just like in popt.h
+ # Fixes #201958
+ epatch "${FILESDIR}/${P}-redefinition.patch"
+
# Only install specific po files if LINGUAS is set
if [[ -n ${LINGUAS} ]]; then
cd po