summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-02-02 22:48:09 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-02-02 22:48:09 +0000
commit6bac69286c0ea7b7f57ab08cd12677d47f896961 (patch)
treec5377c7ee3ba4e8da396ee3d09e348fd2655d378 /net-misc
parentrefmac splitted from ccp4 package (diff)
downloadgentoo-2-6bac69286c0ea7b7f57ab08cd12677d47f896961.tar.gz
gentoo-2-6bac69286c0ea7b7f57ab08cd12677d47f896961.tar.bz2
gentoo-2-6bac69286c0ea7b7f57ab08cd12677d47f896961.zip
Security update for AST-2010-001; remote T.38 over SIP crash by sitting FaxMaxDatagram to a negative or exceptionally large value. Init script update by Jaco Kroon closes bug #303265. Remove vulnerable 1.6.2 branch ebuilds.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/asterisk/ChangeLog12
-rw-r--r--net-misc/asterisk/asterisk-1.6.2.0.ebuild422
-rw-r--r--net-misc/asterisk/asterisk-1.6.2.2.ebuild (renamed from net-misc/asterisk/asterisk-1.6.2.1.ebuild)6
-rw-r--r--net-misc/asterisk/files/1.6.1/asterisk.initd3269
4 files changed, 283 insertions, 426 deletions
diff --git a/net-misc/asterisk/ChangeLog b/net-misc/asterisk/ChangeLog
index f9fb1c857ee2..91f73f99b7d9 100644
--- a/net-misc/asterisk/ChangeLog
+++ b/net-misc/asterisk/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-misc/asterisk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk/ChangeLog,v 1.243 2010/01/27 15:14:38 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk/ChangeLog,v 1.244 2010/02/02 22:48:08 chainsaw Exp $
+
+*asterisk-1.6.2.2 (02 Feb 2010)
+
+ 02 Feb 2010; <chainsaw@gentoo.org> +files/1.6.1/asterisk.initd3,
+ -asterisk-1.6.2.0.ebuild, -asterisk-1.6.2.1.ebuild,
+ +asterisk-1.6.2.2.ebuild:
+ Security update for AST-2010-001; remote T.38 over SIP crash by sitting
+ FaxMaxDatagram to a negative or exceptionally large value. Init script
+ update by Jaco Kroon closes bug #303265. Remove vulnerable 1.6.2 branch
+ ebuilds.
*asterisk-1.6.1.13 (27 Jan 2010)
diff --git a/net-misc/asterisk/asterisk-1.6.2.0.ebuild b/net-misc/asterisk/asterisk-1.6.2.0.ebuild
deleted file mode 100644
index 122934c50a47..000000000000
--- a/net-misc/asterisk/asterisk-1.6.2.0.ebuild
+++ /dev/null
@@ -1,422 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk/asterisk-1.6.2.0.ebuild,v 1.1 2010/01/04 15:11:51 chainsaw Exp $
-
-EAPI=1
-inherit eutils autotools
-
-MY_P="${PN}-${PV/_/-}"
-
-DESCRIPTION="Asterisk: A Modular Open Source PBX System"
-HOMEPAGE="http://www.asterisk.org/"
-SRC_URI="http://downloads.digium.com/pub/asterisk/releases/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="alsa +caps curl dahdi debug freetds iconv jabber ldap keepsrc misdn newt nosamples oss postgres radius snmp span speex ssl sqlite static vorbis"
-
-RDEPEND="sys-libs/ncurses
- dev-libs/popt
- sys-libs/zlib
- alsa? ( media-libs/alsa-lib )
- caps? ( sys-libs/libcap )
- curl? ( net-misc/curl )
- dahdi? ( >=net-libs/libpri-1.4.7
- net-misc/dahdi-tools )
- freetds? ( dev-db/freetds )
- iconv? ( virtual/libiconv )
- jabber? ( dev-libs/iksemel )
- ldap? ( net-nds/openldap )
- misdn? ( net-dialup/misdnuser )
- newt? ( dev-libs/newt )
- postgres? ( virtual/postgresql-base )
- radius? ( net-dialup/radiusclient-ng )
- snmp? ( net-analyzer/net-snmp )
- span? ( media-libs/spandsp )
- speex? ( media-libs/speex )
- sqlite? ( dev-db/sqlite )
- ssl? ( dev-libs/openssl )
- vorbis? ( media-libs/libvorbis )"
-
-DEPEND="${RDEPEND}
- !<net-misc/asterisk-addons-1.6
- !net-misc/asterisk-chan_unistim
- !net-misc/zaptel"
-
-S="${WORKDIR}/${MY_P}"
-
-#
-# shortcuts
-#
-
-# update from asterisk-1.0.x
-is_ast10update() {
- return $(has_version "=net-misc/asterisk-1.0*")
-}
-
-# update from asterisk-1.2.x
-is_ast12update() {
- return $(has_version "=net-misc/asterisk-1.2*")
-}
-
-# update from asterisk 1.4.x
-is_ast14update() {
- return $(has_version "=net-misc/asterisk-1.4*")
-}
-
-# update in the asterisk-1.6.x line
-is_astupdate() {
- if ! is_ast10update && ! is_ast12update && !is_ast14update; then
- return $(has_version "<net-misc/asterisk-${PV}")
- fi
- return 0
-}
-
-get_available_modules() {
- local modules mod x
-
- # build list of available modules...
- for x in app cdr codec format func pbx res; do
-
- for mod in $(find "${S}" -type f -name "${x}_*.c*" -print)
- do
- modules="${modules} $(basename ${mod/%.c*})"
- done
- done
-
- echo "${modules}"
-}
-
-pkg_setup() {
- local checkfailed=0 waitaftermsg=0
-
- if is_ast12update ; then
- ewarn "Please note that the configuration style (particularly the dial plan) has changed significantly."
- ewarn "sip.conf: insecure=very -> insecure=port,invite"
- ewarn "asterisk.conf: please familiarise yourself with [compat]"
- ewarn "extensions.conf: use comma instead of pipe as a separator"
- ewarn "- Please read "${ROOT}"usr/share/doc/${PF}/UPGRADE.txt.bz2 after the installation!"
- echo
- waitaftermsg=1
- fi
-
- if [[ $waitaftermsg -eq 1 ]]; then
- einfo "Press Ctrl+C to abort"
- echo
- ebeep 10
- fi
-
- #
- # Regular checks
- #
- einfo "Running some pre-flight checks..."
- echo
-
- if [[ -n "${ASTERISK_MODULES}" ]] ; then
- ewarn "You are overriding ASTERISK_MODULES. We will assume you know what you are doing. There is no support for this option, try without if you see breakage."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- #
- # fix gsm codec cflags (e.g. i586 core epias) and disable
- # assembler optimizations
- #
- epatch "${FILESDIR}"/1.6.1/${PN}-1.6.1-gsm-pic.patch || die "patch failed"
-
- #
- # add missing LIBS for uclibc
- #
- epatch "${FILESDIR}"/1.6.1/${PN}-1.6.1-uclibc.patch || die "patch failed"
-
- #
- # make sure FXO ports are usable immediately, without requiring an inbound call first
- # https://issues.asterisk.org/view.php?id=14577
- #
- epatch "${FILESDIR}"/1.6.1/${PN}-1.6.1.6-fxsks-hookstate.patch || die "patch failed"
-
- #
- # do not ignore alarm-cleared event while V23 caller ID detection is in progress
- # otherwise automated British Telecom line test causes permanent red alarm
- # https://issues.asterisk.org/view.php?id=14163
- #
- epatch "${FILESDIR}"/1.6.2/${PN}-1.6.2.0-bt-line-test.patch || die "patch failed"
-
- #
- # allow longer CID field so European phone numbers (which are often longer then USA
- # numbers) have a better chance of avoiding truncation
- # https://issues.asterisk.org/view.php?id=16459
- #
-
- epatch "${FILESDIR}"/1.6.1/${PN}-1.6.1.12-longer-sip-cid.patch || die "patch failed"
-
- #
- # sprinkle some plus signs in strategic locations for maximum parallel make happiness
- # https://issues.asterisk.org/view.php?id=16489
- #
- epatch "${FILESDIR}"/1.6.1/${PN}-1.6.1.12-parallel-make-v2.patch || die "patch failed"
-
- AT_M4DIR=autoconf eautoreconf
-
- # parse modules list
- if [[ -n "${ASTERISK_MODULES}" ]]; then
- local x modules="$(get_available_modules)"
-
- einfo "Custom list of modules specified, checking..."
-
- use debug && {
- einfo "Available modules: ${modules}"
- einfo " Selected modules: ${ASTERISK_MODULES}"
- }
-
- for x in ${ASTERISK_MODULES}; do
- if [[ "${x}" = "-*" ]]; then
- MODULES_LIST=""
- else
- if has ${x} ${modules}
- then
- MODULES_LIST="${MODULES_LIST} ${x}"
- else
- eerror "Unknown module: ${x}"
- fi
- fi
- done
-
- export MODULES_LIST
- fi
-}
-
-src_compile() {
- #
- # start with configure
- #
- econf \
- --libdir="/usr/$(get_libdir)" \
- --localstatedir="/var" \
- --with-gsm=internal \
- --with-popt \
- --with-z \
- $(use_with alsa asound) \
- $(use_with caps cap) \
- $(use_with curl) \
- $(use_with dahdi pri) \
- $(use_with dahdi tonezone) \
- $(use_with dahdi) \
- $(use_with freetds tds) \
- $(use_with iconv) \
- $(use_with jabber iksemel) \
- $(use_with misdn isdnnet) \
- $(use_with misdn suppserv) \
- $(use_with misdn) \
- $(use_with newt) \
- $(use_with oss) \
- $(use_with postgres) \
- $(use_with radius) \
- $(use_with snmp netsnmp) \
- $(use_with span spandsp) \
- $(use_with speex) \
- $(use_with speex speexdsp) \
- $(use_with sqlite sqlite3) \
- $(use_with ssl crypto) \
- $(use_with ssl) \
- $(use_with vorbis ogg) \
- $(use_with vorbis) || die "econf failed"
-
- #
- # custom module filter
- # run menuselect to evaluate the list of modules
- # and rewrite the list afterwards
- #
- if [[ -n "${MODULES_LIST}" ]]
- then
- local mod category tmp_list failed_list
-
- ###
- # run menuselect
-
- emake menuselect.makeopts || die "emake menuselect.makeopts failed"
-
- ###
- # get list of modules with failed dependencies
-
- failed_list="$(awk -F= '/^MENUSELECT_DEPSFAILED=/{ print $3 }' menuselect.makeopts)"
-
- ###
- # traverse our list of modules
-
- for category in app cdr codec format func pbx res; do
- tmp_list=""
-
- # search list of modules for matching ones first...
- for mod in ${MODULES_LIST}; do
- # module is from current category?
- if [[ "${mod/%_*}" = "${category}" ]]
- then
- # check menuselect thinks the dependencies are met
- if has ${mod} ${failed_list}
- then
- eerror "${mod}: dependencies required to build this module are not met, NOT BUILDING!"
- else
- tmp_list="${tmp_list} ${mod}"
- fi
- fi
- done
-
- use debug && echo "${category} tmp: ${tmp_list}"
-
- # replace the module list for $category with our custom one
- if [[ -n "${tmp_list}" ]]
- then
- category="$(echo ${category} | tr '[:lower:]' '[:upper:]')"
- sed -i -e "s:^\(MENUSELECT_${category}S?\):\1=${tmp_list}:" \
- menuselect.makeopts || die "failed to set list of ${category} applications"
- fi
- done
- fi
-
- ASTLDFLAGS="${LDFLAGS}" emake || die "emake failed"
-}
-
-src_install() {
- # setup directory structure
- #
- mkdir -p "${D}"usr/lib/pkgconfig
-
- emake DESTDIR="${D}" install || die "emake install failed"
- emake DESTDIR="${D}" samples || die "emake samples failed"
-
- # remove installed sample files if nosamples flag is set
- if use nosamples; then
- einfo "Skipping installation of sample files..."
- rm -f "${D}"var/lib/asterisk/mohmp3/*
- rm -f "${D}"var/lib/asterisk/sounds/demo-*
- rm -f "${D}"var/lib/asterisk/agi-bin/*
- else
- einfo "Sample files have been installed"
- fi
- rm -rf "${D}"var/spool/asterisk/voicemail/default
-
- # move sample configuration files to doc directory
- if is_ast10update || is_ast12update || is_ast14update; then
- einfo "Updating from old (pre-1.6) asterisk version, new configuration files have been installed"
- einfo "into "${ROOT}"etc/asterisk, use etc-update or dispatch-conf to update them"
- fi
-
- einfo "Configuration samples have been moved to: "${ROOT}"/usr/share/doc/${PF}/conf"
- insinto /usr/share/doc/${PF}/conf
- doins "${D}"etc/asterisk/*.conf*
-
- cd "${D}"
- for conffile in etc/asterisk/*.*
- do
- fowners asterisk:asterisk $conffile
- fperms 0660 $conffile
- done
- cd "${S}"
-
- # keep directories
- diropts -m 0770 -o asterisk -g asterisk
- keepdir /etc/asterisk
- keepdir /var/lib/asterisk
- keepdir /var/run/asterisk
- keepdir /var/spool/asterisk
- keepdir /var/spool/asterisk/{system,tmp,meetme,monitor,dictate,voicemail}
- diropts -m 0750 -o asterisk -g asterisk
- keepdir /var/log/asterisk/{cdr-csv,cdr-custom}
-
- newinitd "${FILESDIR}"/1.6.1/asterisk.initd2 asterisk
- newconfd "${FILESDIR}"/1.6.0/asterisk.confd asterisk
-
- # some people like to keep the sources around for custom patching
- # copy the whole source tree to /usr/src/asterisk-${PVF} and run make clean there
- if use keepsrc
- then
- einfo "keepsrc useflag enabled, copying source..."
- dodir /usr/src
-
- cp -dPR "${S}" "${D}"/usr/src/${PF} || die "copying source tree failed"
-
- ebegin "running make clean..."
- emake -C "${D}"/usr/src/${PF} clean >/dev/null || die "make clean failed"
- eend $?
-
- einfo "Source files have been saved to "${ROOT}"usr/src/${PF}"
- fi
-
- # install the upgrade documentation
- #
- dodoc README UPGRADE* BUGS CREDITS
-
- # install snmp mib files
- #
- if use snmp
- then
- insinto /usr/share/snmp/mibs/
- doins doc/digium-mib.txt doc/asterisk-mib.txt
- fi
-}
-
-pkg_preinst() {
- enewgroup asterisk
- enewuser asterisk -1 -1 /var/lib/asterisk "asterisk,dialout"
-}
-
-pkg_postinst() {
- #
- # Announcements, warnings, reminders...
- #
- einfo "Asterisk has been installed"
- echo
- elog "If you want to know more about asterisk, visit these sites:"
- elog "http://www.asteriskdocs.org/"
- elog "http://www.voip-info.org/wiki-Asterisk"
- echo
- elog "http://www.automated.it/guidetoasterisk.htm"
- echo
- elog "Gentoo VoIP IRC Channel:"
- elog "#gentoo-voip @ irc.freenode.net"
- echo
- echo
- elog "1.6.1 -> 1.6.2 changes that you may care about:"
- elog "canreinvite -> directmedia (sip.conf)"
- elog "extensive T.38 (fax) changes"
- elog "http://svn.asterisk.org/svn/asterisk/tags/1.6.2.0/UPGRADE.txt"
-
- #
- # Warning about 1.x -> 1.6 changes...
- #
- if is_ast10update || is_ast12update || is_ast14update; then
- ewarn ""
- ewarn "- Please read "${ROOT}"usr/share/doc/${PF}/UPGRADE.txt.bz2 before continuing"
- ewarn ""
- fi
-}
-
-pkg_config() {
- einfo "Do you want to reset file permissions and ownerships (y/N)?"
-
- read tmp
- tmp="$(echo $tmp | tr '[:upper:]' '[:lower:]')"
-
- if [[ "$tmp" = "y" ]] ||\
- [[ "$tmp" = "yes" ]]
- then
- einfo "Resetting permissions to defaults..."
-
- for x in spool run lib log; do
- chown -R asterisk:asterisk "${ROOT}"var/${x}/asterisk
- chmod -R u=rwX,g=rwX,o= "${ROOT}"var/${x}/asterisk
- done
-
- chown -R root:asterisk "${ROOT}"etc/asterisk
- chmod -R u=rwX,g=rwX,o= "${ROOT}"etc/asterisk
-
- einfo "done"
- else
- einfo "skipping"
- fi
-}
diff --git a/net-misc/asterisk/asterisk-1.6.2.1.ebuild b/net-misc/asterisk/asterisk-1.6.2.2.ebuild
index a787979c4cf4..c78a0c1a8c09 100644
--- a/net-misc/asterisk/asterisk-1.6.2.1.ebuild
+++ b/net-misc/asterisk/asterisk-1.6.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk/asterisk-1.6.2.1.ebuild,v 1.1 2010/01/19 13:12:46 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk/asterisk-1.6.2.2.ebuild,v 1.1 2010/02/02 22:48:08 chainsaw Exp $
EAPI=1
inherit eutils autotools linux-info
@@ -104,7 +104,7 @@ src_unpack() {
# sprinkle some plus signs in strategic locations for maximum parallel make happiness
# https://issues.asterisk.org/view.php?id=16489
#
- epatch "${FILESDIR}"/1.6.2/${P}-parallel-make.patch || die "patch failed"
+ epatch "${FILESDIR}"/1.6.2/${PN}-1.6.2.1-parallel-make.patch || die "patch failed"
AT_M4DIR=autoconf eautoreconf
@@ -268,7 +268,7 @@ src_install() {
diropts -m 0750 -o asterisk -g asterisk
keepdir /var/log/asterisk/{cdr-csv,cdr-custom}
- newinitd "${FILESDIR}"/1.6.1/asterisk.initd2 asterisk
+ newinitd "${FILESDIR}"/1.6.1/asterisk.initd3 asterisk
newconfd "${FILESDIR}"/1.6.0/asterisk.confd asterisk
# some people like to keep the sources around for custom patching
diff --git a/net-misc/asterisk/files/1.6.1/asterisk.initd3 b/net-misc/asterisk/files/1.6.1/asterisk.initd3
new file mode 100644
index 000000000000..cc9e6dc1e052
--- /dev/null
+++ b/net-misc/asterisk/files/1.6.1/asterisk.initd3
@@ -0,0 +1,269 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk/files/1.6.1/asterisk.initd3,v 1.1 2010/02/02 22:48:09 chainsaw Exp $
+
+opts="${opts} forcestop reload"
+
+depend() {
+ need net
+ use nscd dns dahdi mysql postgresql slapd capi
+}
+
+is_running() {
+ if [ -z "$(pidof asterisk)" ]; then
+ return 1
+ else
+ PID="$(cat /var/run/asterisk/asterisk.pid)"
+ for x in $(pidof asterisk); do
+ if [ "${x}" = "${PID}" ]; then
+ return 0
+ fi
+ done
+ fi
+
+ return 1
+}
+
+asterisk_run_loop() {
+ local OPTS ARGS MSG NICE=""
+ local result=0 signal=0
+
+ # default options
+ OPTS="-f" # don't fork / detach breaks wrapper script...
+
+ # filter (redundant) arguments
+ ARGS="$(echo "${@}" | sed -e "s:-c\|-f::g")"
+
+ # mangle yes/no options
+ ASTERISK_CONSOLE="$(echo ${ASTERISK_CONSOLE} | tr '[:lower:]' '[:upper:]')"
+
+ if [ -n "${ASTERISK_CORE_SIZE}" ] &&
+ [ "${ASTERISK_CORE_SIZE}" != "0" ]; then
+ ulimit -c ${ASTERISK_CORE_SIZE}
+
+ if [ -n "${ASTERISK_CORE_DIR}" ] && \
+ [ ! -d "${ASTERISK_CORE_DIR}" ]
+ then
+ mkdir -m750 -p "${ASTERISK_CORE_DIR}"
+
+ if [ -n "${ASTERISK_USER}" ]; then
+ chown -R "${ASTERISK_USER}" "${ASTERISK_CORE_DIR}"
+ fi
+ fi
+ ASTERISK_CORE_DIR="${ASTERISK_CORE_DIR:-/tmp}"
+
+ cd "${ASTERISK_CORE_DIR}"
+ echo " Core dump size : ${ASTERISK_CORE_SIZE}"
+ echo " Core dump location : ${ASTERISK_CORE_DIR}"
+ fi
+
+ if [ -n "${ASTERISK_MAX_FD}" ]; then
+ ulimit -n ${ASTERISK_MAX_FD}
+ echo " Max open filedescriptors : ${ASTERISK_MAX_FD}"
+ fi
+
+ if [ -n "${ASTERISK_NICE}" ]; then
+ echo " Nice level : ${ASTERISK_NICE}"
+ NICE="nice -n ${ASTERISK_NICE} --"
+ fi
+
+ if [ -n "${ASTERISK_NOTIFY_EMAIL}" ]; then
+ if [ -x /usr/sbin/sendmail ]; then
+ echo " Email notifications go to : ${ASTERISK_NOTIFY_EMAIL}"
+ else
+ echo " Notifications disabled, /usr/sbin/sendmail doesn't exist or is not executable!"
+ unset ASTERISK_NOTIFY_EMAIL
+ fi
+ fi
+
+ if [ -n "${ASTERISK_TTY}" ]; then
+ for x in ${ASTERISK_TTY} \
+ /dev/tty${ASTERISK_TTY} \
+ /dev/vc/${ASTERISK_TTY}
+ do
+ if [ -c "${x}" ]; then
+ TTY="${x}"
+ fi
+ done
+ [ -n "${TTY}" ] && \
+ echo " Messages are sent to : ${TTY}"
+ fi
+
+ if [ "${ASTERISK_CONSOLE}" = "YES" ] && [ -n "${TTY}" ]; then
+ echo " Starting Asterisk console : ${ASTERISK_CONSOLE}"
+ OPTS="${OPTS} -c"
+ fi
+
+ OPTS="${OPTS} ${ARGS}"
+
+ trap "rm /var/run/asterisk/wrapper_loop.pid" EXIT
+ cut -f4 -d' ' < /proc/self/stat > /var/run/asterisk/wrapper_loop.pid
+
+ while :; do
+ if [ -n "${TTY}" ]; then
+ /usr/bin/stty -F ${TTY} sane
+ ${NICE} /usr/sbin/asterisk ${OPTS} >${TTY} 2>&1 <${TTY}
+ result=$?
+ else
+ ${NICE} /usr/sbin/asterisk ${OPTS} &>/dev/null
+ result=$?
+ fi
+
+ if [ $result -eq 0 ]; then
+ logger -t asterisk_wrapper "Asterisk terminated normally"
+ break
+ else
+ if [ $result -gt 128 ]; then
+ signal=$((result - 128))
+ MSG="Asterisk terminated with Signal: $signal"
+
+ CORE_TARGET="core-$(date "+%Y%m%d-%h%M%s")"
+
+ local CORE_DUMPED=0
+ if [ -f "${ASTERISK_CORE_DIR}/core" ]; then
+ mv "${ASTERISK_CORE_DIR}/core" \
+ "${ASTERISK_CORE_DIR}/${CORE_TARGET}"
+ CORE_DUMPED=1
+
+ elif [ -f "${ASTERISK_CORE_DIR}/core.${PID}" ]; then
+ mv "${ASTERISK_CORE_DIR}/core.${PID}" \
+ "${ASTERISK_CORE_DIR}/${CORE_TARGET}"
+ CORE_DUMPED=1
+
+ fi
+
+ [ $CORE_DUMPED -eq 1 ] && \
+ MSG="${MSG}\n\rCore dumped: ${ASTERISK_CORE_DIR}/${CORE_TARGET}"
+ else
+ MSG="Asterisk terminated with return code: $result"
+ fi
+
+ # kill left-over tasks
+ for X in ${ASTERISK_CLEANUP_ON_CRASH}; do
+ kill -9 $(pidof ${X});
+ done
+ fi
+
+ [ -n "${TTY}" ] \
+ && echo "${MSG}" >${TTY} \
+ || logger -t asterisk_wrapper "${MSG}"
+
+
+ if [ -n "${ASTERISK_NOTIFY_EMAIL}" ] && \
+ [ -x /usr/sbin/sendmail ]; then
+ echo -e -n "Subject: Asterisk crashed\n\r${MSG}\n\r" |\
+ /usr/sbin/sendmail "${ASTERISK_NOTIFY_EMAIL}"
+ fi
+ sleep 5
+ logger -t asterisk_wrapper "Restarting Asterisk..."
+ done
+ return 0
+}
+
+start() {
+ local OPTS USER GROUP PID
+ local tmp x
+
+ if [ -n "${ASTERISK_NICE}" ]; then
+ if [ ${ASTERISK_NICE} -ge -20 ] && \
+ [ ${ASTERISK_NICE} -le 19 ]; then
+ OPTS="--nicelevel ${ASTERISK_NICE}"
+ else
+ eerror "Nice value must be between -20 and 19"
+ return 1
+ fi
+ fi
+
+ if [ -n "${ASTERISK_USER}" ]; then
+ USER=$(echo $ASTERISK_USER | sed 's/:.*//')
+ GROUP=$(echo $ASTERISK_USER | awk -F: '/.*:.*/ { print $2 }')
+ if [ -n "${USER}" ]; then
+ ASTERISK_OPTS="${ASTERISK_OPTS} -U ${USER}"
+ fi
+ if [ -n "${GROUP}" ]; then
+ ASTERISK_OPTS="${ASTERISK_OPTS} -G ${GROUP}"
+ GROUP=":${GROUP}" # make it look nice...
+ fi
+ for element in $(find /var/{log,run}/asterisk); do
+ if [ $(stat -c %U $element) != ${USER} ]; then
+ ewarn "${USER} is not the owner of $element, fixing."
+ chown -R ${USER} /var/{log,run}/asterisk
+ chmod -R u+r /var/{log,run}/asterisk
+ chmod u+x /var/{log,run}/asterisk
+ fi;
+ done;
+ ebegin "Starting asterisk PBX (as ${USER}${GROUP})"
+ else
+ ebegin "Starting asterisk PBX (as root)"
+ fi
+
+ if [ "$(echo ${ASTERISK_WRAPPER} | tr '[:upper:]' '[:lower:]')" != "yes" ]; then
+ start-stop-daemon --start --exec /usr/sbin/asterisk \
+ ${OPTS} -- ${ASTERISK_OPTS}
+ result=$?
+ else
+ asterisk_run_loop ${ASTERISK_OPTS} 2>/dev/null &
+ result=$?
+ fi
+
+ if [ $result -eq 0 ]; then
+ # 2 seconds should be enough for asterisk to start
+ sleep 2
+ is_running
+ result=$?
+ fi
+
+ eend $result
+}
+
+forcestop() {
+ ebegin "Stopping asterisk PBX"
+ start-stop-daemon --stop --pidfile /var/run/asterisk/asterisk.pid
+ eend $?
+}
+
+stop() {
+ if ! is_running; then
+ eerror "Asterisk is not running!"
+ return 0
+ fi
+
+ if [ -r /var/run/asterisk/wrapper_loop.pid ]; then
+ ebegin "Killing wrapper script"
+ kill $(</var/run/asterisk/wrapper_loop.pid)
+ eend $?
+ fi
+
+ ebegin "Stopping asterisk PBX gracefully"
+ /usr/sbin/asterisk -r -x "core stop gracefully" &>/dev/null
+ # Now we have to wait until asterisk has _really_ stopped.
+ sleep 1
+ if is_running; then
+ einfon "Waiting for asterisk to shutdown ."
+ local cnt=0
+ while is_running; do
+ cnt=`expr $cnt + 1`
+ if [ $cnt -gt 60 ] ; then
+ # Waited 120 seconds now. Fail.
+ echo
+ eend 1 "Failed."
+ return
+ fi
+ sleep 2
+ echo -n "."
+ done
+ echo
+ fi
+ eend 0
+}
+
+reload() {
+ if is_running; then
+ ebegin "Forcing asterisk to reload configuration"
+ /usr/sbin/asterisk -r -x "reload" &>/dev/null
+ eend $?
+ else
+ eerror "Asterisk is not running!"
+ fi
+}