summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMalcolm Lashley <malc@gentoo.org>2004-07-04 10:59:29 +0000
committerMalcolm Lashley <malc@gentoo.org>2004-07-04 10:59:29 +0000
commit6d9c1f2a0c8132fbbab37a27884c89473602abd0 (patch)
tree2abd25fbea92fd997dde607730c8802680fc0aa0 /net-misc
parentStable on alpha. (Manifest recommit) (diff)
downloadgentoo-2-6d9c1f2a0c8132fbbab37a27884c89473602abd0.tar.gz
gentoo-2-6d9c1f2a0c8132fbbab37a27884c89473602abd0.tar.bz2
gentoo-2-6d9c1f2a0c8132fbbab37a27884c89473602abd0.zip
gcc3.4 compilation patch, fixes bug #54010
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/streamtuner/ChangeLog5
-rw-r--r--net-misc/streamtuner/files/streamtuner-0.12.3-gcc34.patch12
-rw-r--r--net-misc/streamtuner/streamtuner-0.12.3.ebuild6
3 files changed, 20 insertions, 3 deletions
diff --git a/net-misc/streamtuner/ChangeLog b/net-misc/streamtuner/ChangeLog
index b9c6039e2096..096ceca5d3fe 100644
--- a/net-misc/streamtuner/ChangeLog
+++ b/net-misc/streamtuner/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/streamtuner
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/streamtuner/ChangeLog,v 1.12 2004/06/25 00:14:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/streamtuner/ChangeLog,v 1.13 2004/07/04 10:59:29 malc Exp $
+
+ 04 Jul 2004; <malc@gentoo.org> streamtuner-0.12.3.ebuild:
+ gcc3.4 compilation patch, fixes bug #54010
24 May 2004; Daniel Ahlberg <aliz@gentoo.org> streamtuner-0.12.3.ebuild:
Added amd64 keyword, closing #51764.
diff --git a/net-misc/streamtuner/files/streamtuner-0.12.3-gcc34.patch b/net-misc/streamtuner/files/streamtuner-0.12.3-gcc34.patch
new file mode 100644
index 000000000000..a8313077104a
--- /dev/null
+++ b/net-misc/streamtuner/files/streamtuner-0.12.3-gcc34.patch
@@ -0,0 +1,12 @@
+--- streamtuner-0.12.3/work/streamtuner-0.12.3/src/sglib/sg-parser.c 2004-05-11 15:40:41.000000000 +0000
++++ streamtuner-0.12.3.fixed/work/streamtuner-0.12.3/src/sglib/sg-parser.c 2004-07-04 10:45:30.968529288 +0000
+@@ -288,6 +288,9 @@
+ break;
+
+ default: /* only to suppress compiler warnings */
++
++ break; /* only to please gcc3.4 strictness ;-) */
++
+ }
+
+ if (statement->terminator)
diff --git a/net-misc/streamtuner/streamtuner-0.12.3.ebuild b/net-misc/streamtuner/streamtuner-0.12.3.ebuild
index de6d7a0f705c..fd27b4d70c63 100644
--- a/net-misc/streamtuner/streamtuner-0.12.3.ebuild
+++ b/net-misc/streamtuner/streamtuner-0.12.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/streamtuner/streamtuner-0.12.3.ebuild,v 1.3 2004/06/25 00:14:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/streamtuner/streamtuner-0.12.3.ebuild,v 1.4 2004/07/04 10:59:29 malc Exp $
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="Stream directory browser for browsing internet radio streams"
SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
@@ -28,4 +28,6 @@ src_unpack() {
cd ${S}
# sandbox errors work around
gnome2_omf_fix ${S}/help/C/Makefile.in
+ epatch ${FILESDIR}/$P-gcc34.patch
+
}