summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-11-14 22:10:51 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-11-14 22:10:51 +0000
commit74b6d02dcadf67998cbb509a4fac66013253627e (patch)
tree4236f4a2e9642b4ec9bae349951a314a5131a117 /net-misc
parentSign Manfiest (diff)
downloadgentoo-2-74b6d02dcadf67998cbb509a4fac66013253627e.tar.gz
gentoo-2-74b6d02dcadf67998cbb509a4fac66013253627e.tar.bz2
gentoo-2-74b6d02dcadf67998cbb509a4fac66013253627e.zip
Version bump and fixed chowns wrt bug #132284.
Thanks to Janne Liimatainen and Randy McCaskill. (Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/siproxd/ChangeLog10
-rw-r--r--net-misc/siproxd/files/digest-siproxd-0.5.133
-rw-r--r--net-misc/siproxd/siproxd-0.5.13.ebuild59
3 files changed, 70 insertions, 2 deletions
diff --git a/net-misc/siproxd/ChangeLog b/net-misc/siproxd/ChangeLog
index 57815bfa530b..842e4cc7ecb7 100644
--- a/net-misc/siproxd/ChangeLog
+++ b/net-misc/siproxd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/siproxd
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/siproxd/ChangeLog,v 1.2 2005/09/22 23:24:06 stkn Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/siproxd/ChangeLog,v 1.3 2006/11/14 22:10:51 drizzt Exp $
+
+*siproxd-0.5.13 (14 Nov 2006)
+
+ 14 Nov 2006; Timothy Redaelli <drizzt@gentoo.org> +siproxd-0.5.13.ebuild:
+ Version bump and fixed chowns wrt bug #132284.
+ Thanks to Janne Liimatainen and Randy McCaskill.
23 Sep 2005; Stefan Knoblich <stkn@gentoo.org> files/siproxd.rc6,
siproxd-0.5.11.ebuild:
diff --git a/net-misc/siproxd/files/digest-siproxd-0.5.13 b/net-misc/siproxd/files/digest-siproxd-0.5.13
new file mode 100644
index 000000000000..634e5229e939
--- /dev/null
+++ b/net-misc/siproxd/files/digest-siproxd-0.5.13
@@ -0,0 +1,3 @@
+MD5 91a572f80dd5a9af5a0f7f207fd34478 siproxd-0.5.13.tar.gz 223109
+RMD160 c5917e47655aa363d6c72ab5a0836cdef002b39a siproxd-0.5.13.tar.gz 223109
+SHA256 b419e2642cff2aea43ebd32139e2fe345003347d09e1a8dc6a289fdc08c1f7cd siproxd-0.5.13.tar.gz 223109
diff --git a/net-misc/siproxd/siproxd-0.5.13.ebuild b/net-misc/siproxd/siproxd-0.5.13.ebuild
new file mode 100644
index 000000000000..e8340c04d824
--- /dev/null
+++ b/net-misc/siproxd/siproxd-0.5.13.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/siproxd/siproxd-0.5.13.ebuild,v 1.1 2006/11/14 22:10:51 drizzt Exp $
+
+inherit eutils autotools
+
+IUSE="static doc"
+
+DESCRIPTION="masquerading SIP proxy"
+HOMEPAGE="http://siproxd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/siproxd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=net-libs/libosip-2.0.0
+ doc? ( app-text/docbook-sgml-utils )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.5.11-configure-docs.diff
+
+ eautoreconf || die "autoreconf failed"
+
+ # Make the daemon run as user 'siproxd' by default
+ sed -i -e "s:nobody:siproxd:" doc/siproxd.conf.example
+}
+
+src_compile() {
+ local myconf
+
+ use static && \
+ myconf="--enable-static"
+
+ econf ${myconf} \
+ `use_enable doc docs` || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ newinitd "${FILESDIR}"/siproxd.rc6 siproxd
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO RELNOTES
+
+ # Set up siproxd directories
+ keepdir /var/{lib,run}/siproxd
+ fowners siproxd:siproxd /var/{lib,run}/siproxd
+}
+
+pkg_postinst() {
+ enewgroup siproxd
+ enewuser siproxd -1 -1 /dev/null siproxd
+}