summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-03-21 15:12:17 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-03-21 15:12:17 +0000
commit7a250af75447fb639a7e5c361d145df084945e74 (patch)
tree5c376de95e53ddc2d836ba605f6e2fff7c47c18c /net-misc
parentMarking boost-1.41.0-r3 ppc64 for bug 306335 (diff)
downloadgentoo-2-7a250af75447fb639a7e5c361d145df084945e74.tar.gz
gentoo-2-7a250af75447fb639a7e5c361d145df084945e74.tar.bz2
gentoo-2-7a250af75447fb639a7e5c361d145df084945e74.zip
Fixing missing quotes in libcurl.m4
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/ChangeLog8
-rw-r--r--net-misc/curl/curl-7.20.0-r2.ebuild115
-rw-r--r--net-misc/curl/files/curl-7.20.0-libcurlm4.patch11
3 files changed, 133 insertions, 1 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index 00bcdb77f342..1395b671747c 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/curl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.154 2010/03/16 21:43:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.155 2010/03/21 15:12:16 tupone Exp $
+
+*curl-7.20.0-r2 (21 Mar 2010)
+
+ 21 Mar 2010; Tupone Alfredo <tupone@gentoo.org> +curl-7.20.0-r2.ebuild,
+ +files/curl-7.20.0-libcurlm4.patch:
+ Fixing missing quotes in libcurl.m4
*curl-7.20.0-r1 (16 Mar 2010)
diff --git a/net-misc/curl/curl-7.20.0-r2.ebuild b/net-misc/curl/curl-7.20.0-r2.ebuild
new file mode 100644
index 000000000000..06da5e0ab948
--- /dev/null
+++ b/net-misc/curl/curl-7.20.0-r2.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.20.0-r2.ebuild,v 1.1 2010/03/21 15:12:16 tupone Exp $
+
+# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
+
+inherit multilib eutils
+
+#MY_P=${P/_pre/-}
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
+#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
+#SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ares gnutls idn ipv6 kerberos ldap libssh2 nss ssl test"
+
+RDEPEND="ldap? ( net-nds/openldap )
+ ssl? (
+ gnutls? ( net-libs/gnutls app-misc/ca-certificates )
+ nss? ( !gnutls? ( dev-libs/nss app-misc/ca-certificates ) )
+ !gnutls? ( !nss? ( dev-libs/openssl ) )
+ )
+ idn? ( net-dns/libidn )
+ ares? ( >=net-dns/c-ares-1.4.0 )
+ kerberos? ( virtual/krb5 )
+ libssh2? ( >=net-libs/libssh2-0.16 )"
+
+# fbopenssl (not in gentoo) --with-spnego
+# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
+
+DEPEND="${RDEPEND}
+ test? (
+ sys-apps/diffutils
+ dev-lang/perl
+ )"
+# used - but can do without in self test: net-misc/stunnel
+
+pkg_setup() {
+ if ! use ssl && ( use gnutls || use nss ) ; then
+ ewarn "USE='gnutls nss' are ignored without USE='ssl'."
+ ewarn "Please review the local USE flags for this package."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-strip-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-7.19.7-test241.patch \
+ "${FILESDIR}"/${P}-libcurlm4.patch
+}
+
+src_compile() {
+
+ myconf="$(use_enable ldap)
+ $(use_enable ldap ldaps)
+ $(use_with idn libidn)
+ $(use_with kerberos gssapi /usr)
+ $(use_with libssh2)
+ $(use_enable ipv6)
+ $(use_enable ares)
+ --enable-http
+ --enable-ftp
+ --enable-gopher
+ --enable-file
+ --enable-dict
+ --enable-manual
+ --enable-telnet
+ --enable-smtp
+ --enable-pop3
+ --enable-imap
+ --enable-rtsp
+ --enable-nonblocking
+ --enable-largefile
+ --enable-maintainer-mode
+ --disable-sspi
+ --without-krb4
+ --without-spnego"
+
+ if use ssl ; then
+ if use gnutls; then
+ myconf="${myconf} --without-ssl --with-gnutls --without-nss"
+ myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
+ elif use nss; then
+ myconf="${myconf} --without-ssl --without-gnutls --with-nss"
+ myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
+ else
+ myconf="${myconf} --without-gnutls --without-nss --with-ssl"
+ myconf="${myconf} --without-ca-bundle --with-ca-path=/etc/ssl/certs"
+ fi
+ else
+ myconf="${myconf} --without-gnutls --without-nss --without-ssl"
+ fi
+
+ econf ${myconf} || die 'configure failed'
+
+ emake || die "install failed for current version"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installed failed for current version"
+ rm -rf "${D}"/etc/
+
+ # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+
+ dodoc CHANGES README
+ dodoc docs/FEATURES docs/INTERNALS
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}
diff --git a/net-misc/curl/files/curl-7.20.0-libcurlm4.patch b/net-misc/curl/files/curl-7.20.0-libcurlm4.patch
new file mode 100644
index 000000000000..16220b87d91e
--- /dev/null
+++ b/net-misc/curl/files/curl-7.20.0-libcurlm4.patch
@@ -0,0 +1,11 @@
+--- docs/libcurl/libcurl.m4.old 2010-03-21 15:50:23.000000000 +0100
++++ docs/libcurl/libcurl.m4 2010-03-21 15:51:41.000000000 +0100
+@@ -198,7 +198,7 @@
+
+ # We don't have --protocols, so just assume that all
+ # protocols are available
+- _libcurl_protocols="HTTP FTP FILE TELNET LDAP DICT TFTP
++ _libcurl_protocols="HTTP FTP FILE TELNET LDAP DICT TFTP"
+
+ if test x$libcurl_feature_SSL = xyes ; then
+ _libcurl_protocols="$_libcurl_protocols HTTPS"