summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Piasek <dagger@gentoo.org>2009-09-03 10:48:16 +0000
committerRobert Piasek <dagger@gentoo.org>2009-09-03 10:48:16 +0000
commit860565cdd3ae7434f3ff323b25a3ca42e46f41f4 (patch)
treefcf687eb6c19a228a5e53ad387483c211c9b9b9d /net-misc
parentAdd lua USE-flag per bug #283407, Fix the patch which did not work with --ena... (diff)
downloadgentoo-2-860565cdd3ae7434f3ff323b25a3ca42e46f41f4.tar.gz
gentoo-2-860565cdd3ae7434f3ff323b25a3ca42e46f41f4.tar.bz2
gentoo-2-860565cdd3ae7434f3ff323b25a3ca42e46f41f4.zip
Version bump
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ofono/ChangeLog7
-rw-r--r--net-misc/ofono/ofono-0.4.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/net-misc/ofono/ChangeLog b/net-misc/ofono/ChangeLog
index f07319c96e3c..c5ad19138b8c 100644
--- a/net-misc/ofono/ChangeLog
+++ b/net-misc/ofono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/ofono
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ofono/ChangeLog,v 1.1 2009/08/24 13:20:40 dagger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ofono/ChangeLog,v 1.2 2009/09/03 10:48:16 dagger Exp $
+
+*ofono-0.4 (03 Sep 2009)
+
+ 03 Sep 2009; Robert Piasek <dagger@gentoo.org> +ofono-0.4.ebuild:
+ Version bump.
*ofono-0.3 (13 Aug 2009)
diff --git a/net-misc/ofono/ofono-0.4.ebuild b/net-misc/ofono/ofono-0.4.ebuild
new file mode 100644
index 000000000000..e885315c0cba
--- /dev/null
+++ b/net-misc/ofono/ofono-0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ofono/ofono-0.4.ebuild,v 1.1 2009/09/03 10:48:16 dagger Exp $
+
+EAPI="2"
+
+DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon."
+HOMEPAGE="http://ofono.org/"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~x86"
+IUSE="threads"
+
+RDEPEND=">=sys-apps/dbus-1.2
+ >=dev-libs/glib-2.16"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable threads) \
+ --localstatedir="${ROOT}"/var
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+}