summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-03-30 04:29:24 +0000
committerTim Harder <radhermit@gentoo.org>2013-03-30 04:29:24 +0000
commit93b621eba71962e48ff4b5b86df189a8c8b59d65 (patch)
tree27b94c3d9e2be0f98689edf38a44dcdab3b0cf9f /net-misc
parentversion bump, improve LINGUAS handling (diff)
downloadgentoo-2-93b621eba71962e48ff4b5b86df189a8c8b59d65.tar.gz
gentoo-2-93b621eba71962e48ff4b5b86df189a8c8b59d65.tar.bz2
gentoo-2-93b621eba71962e48ff4b5b86df189a8c8b59d65.zip
Update glue patches for X509 support.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/ChangeLog7
-rw-r--r--net-misc/openssh/files/openssh-6.2_p1-x509-glue.patch16
-rw-r--r--net-misc/openssh/files/openssh-6.2_p1-x509-hpn-glue.patch51
-rw-r--r--net-misc/openssh/openssh-6.2_p1.ebuild6
4 files changed, 76 insertions, 4 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index 54a4609328f9..28a099143793 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/openssh
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.467 2013/03/24 01:55:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.468 2013/03/30 04:29:24 radhermit Exp $
+
+ 30 Mar 2013; Tim Harder <radhermit@gentoo.org> openssh-6.2_p1.ebuild,
+ +files/openssh-6.2_p1-x509-glue.patch,
+ +files/openssh-6.2_p1-x509-hpn-glue.patch:
+ Update glue patches for X509 support.
*openssh-6.2_p1 (24 Mar 2013)
diff --git a/net-misc/openssh/files/openssh-6.2_p1-x509-glue.patch b/net-misc/openssh/files/openssh-6.2_p1-x509-glue.patch
new file mode 100644
index 000000000000..2c174298d881
--- /dev/null
+++ b/net-misc/openssh/files/openssh-6.2_p1-x509-glue.patch
@@ -0,0 +1,16 @@
+make x509 apply after openssh-5.9_p1-sshd-gssapi-multihomed.patch
+
+--- openssh-6.2p1+x509-7.4.1.diff
++++ openssh-6.2p1+x509-7.4.1.diff
+@@ -14571,10 +14571,9 @@
+ .It Cm ChallengeResponseAuthentication
+ Specifies whether challenge-response authentication is allowed (e.g. via
+ PAM or though authentication styles supported in
+-@@ -487,6 +564,16 @@
++@@ -487,5 +564,15 @@
+ The default is
+ .Dq yes .
+- Note that this option applies to protocol version 2 only.
+ +.It Cm HostbasedAlgorithms
+ +Specifies the protocol version 2 algorithms used in
+ +.Dq hostbased
diff --git a/net-misc/openssh/files/openssh-6.2_p1-x509-hpn-glue.patch b/net-misc/openssh/files/openssh-6.2_p1-x509-hpn-glue.patch
new file mode 100644
index 000000000000..22b9764a4d59
--- /dev/null
+++ b/net-misc/openssh/files/openssh-6.2_p1-x509-hpn-glue.patch
@@ -0,0 +1,51 @@
+--- openssh-6.2p1/Makefile.in
++++ openssh-6.2p1/Makefile.in
+@@ -45,7 +45,7 @@
+ CC=@CC@
+ LD=@LD@
+ CFLAGS=@CFLAGS@
+-CPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@ @LDAP_CPPFLAGS@ $(PATHS) @DEFS@
++CPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@ $(PATHS) @DEFS@
+ LIBS=@LIBS@
+ K5LIBS=@K5LIBS@
+ GSSLIBS=@GSSLIBS@
+@@ -53,6 +53,7 @@
+ SSHDLIBS=@SSHDLIBS@
+ LIBEDIT=@LIBEDIT@
+ LIBLDAP=@LDAP_LDFLAGS@ @LDAP_LIBS@
++CPPFLAGS+=@LDAP_CPPFLAGS@
+ AR=@AR@
+ AWK=@AWK@
+ RANLIB=@RANLIB@
+--- openssh-6.2p1/sshconnect.c
++++ openssh-6.2p1/sshconnect.c
+@@ -458,7 +458,7 @@
+ {
+ /* Send our own protocol version identification. */
+ if (compat20) {
+- xasprintf(&client_version_string, "SSH-%d.%d-%.100s PKIX\r\n",
++ xasprintf(&client_version_string, "SSH-%d.%d-%.100s\r\n",
+ PROTOCOL_MAJOR_2, PROTOCOL_MINOR_2, SSH_VERSION);
+ } else {
+ xasprintf(&client_version_string, "SSH-%d.%d-%.100s\n",
+--- openssh-6.2p1/sshd.c
++++ openssh-6.2p1/sshd.c
+@@ -466,8 +466,8 @@
+ comment = "";
+ }
+
+- xasprintf(&server_version_string, "SSH-%d.%d-%.100s%s%s%s%s",
+- major, minor, SSH_VERSION, comment,
++ xasprintf(&server_version_string, "SSH-%d.%d-%.100s%s%s%s",
++ major, minor, SSH_VERSION,
+ *options.version_addendum == '\0' ? "" : " ",
+ options.version_addendum, newline);
+
+--- openssh-6.2p1/version.h
++++ openssh-6.2p1/version.h
+@@ -3,4 +3,5 @@
+ #define SSH_VERSION "OpenSSH_6.2"
+
+ #define SSH_PORTABLE "p1"
++#define SSH_X509 " PKIX"
+ #define SSH_RELEASE SSH_VERSION SSH_PORTABLE
diff --git a/net-misc/openssh/openssh-6.2_p1.ebuild b/net-misc/openssh/openssh-6.2_p1.ebuild
index ac17d68980e6..95c6cf1dc3c4 100644
--- a/net-misc/openssh/openssh-6.2_p1.ebuild
+++ b/net-misc/openssh/openssh-6.2_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-6.2_p1.ebuild,v 1.1 2013/03/24 01:55:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-6.2_p1.ebuild,v 1.2 2013/03/30 04:29:24 radhermit Exp $
EAPI="4"
inherit eutils user flag-o-matic multilib autotools pam systemd versionator
@@ -101,10 +101,10 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-5.9_p1-sshd-gssapi-multihomed.patch #378361
if use X509 ; then
pushd .. >/dev/null
- epatch "${FILESDIR}"/${PN}-6.1_p1-x509-glue.patch
+ epatch "${FILESDIR}"/${PN}-6.2_p1-x509-glue.patch
popd >/dev/null
epatch "${WORKDIR}"/${X509_PATCH%.*}
- epatch "${FILESDIR}"/${PN}-6.1_p1-x509-hpn-glue.patch
+ epatch "${FILESDIR}"/${PN}-6.2_p1-x509-hpn-glue.patch
save_version X509
fi
if ! use X509 ; then