summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-06-07 12:36:38 +0000
committerJeroen Roovers <jer@gentoo.org>2014-06-07 12:36:38 +0000
commitcb11916ae2f4bf172361e6dd4d787bb36c7ec98c (patch)
tree2a075baf179ce0004b850ca5f72291ca8030db72 /net-misc
parentbump, adjust test phase according to new failaures (diff)
downloadgentoo-2-cb11916ae2f4bf172361e6dd4d787bb36c7ec98c.tar.gz
gentoo-2-cb11916ae2f4bf172361e6dd4d787bb36c7ec98c.tar.bz2
gentoo-2-cb11916ae2f4bf172361e6dd4d787bb36c7ec98c.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/chrony/ChangeLog7
-rw-r--r--net-misc/chrony/chrony-1.30_pre1.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/net-misc/chrony/ChangeLog b/net-misc/chrony/ChangeLog
index 52a35ada0c49..21ee8a0f9bce 100644
--- a/net-misc/chrony/ChangeLog
+++ b/net-misc/chrony/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/chrony
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.130 2014/02/09 12:38:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.131 2014/06/07 12:36:38 jer Exp $
+
+*chrony-1.30_pre1 (07 Jun 2014)
+
+ 07 Jun 2014; Jeroen Roovers <jer@gentoo.org> +chrony-1.30_pre1.ebuild:
+ Version bump.
09 Feb 2014; Jeroen Roovers <jer@gentoo.org> -chrony-1.29-r1.ebuild:
Old.
diff --git a/net-misc/chrony/chrony-1.30_pre1.ebuild b/net-misc/chrony/chrony-1.30_pre1.ebuild
new file mode 100644
index 000000000000..c3f7081ff7a1
--- /dev/null
+++ b/net-misc/chrony/chrony-1.30_pre1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/chrony-1.30_pre1.ebuild,v 1.1 2014/06/07 12:36:38 jer Exp $
+
+EAPI=5
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="http://chrony.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS=""
+IUSE="caps ipv6 +readline +rtc selinux"
+
+RDEPEND="
+ caps? ( sys-libs/libcap )
+ readline? ( >=sys-libs/readline-4.1-r4 )
+ selinux? ( sec-policy/selinux-chronyd )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ sed -i \
+ -e 's:/etc/chrony\.:/etc/chrony/chrony.:g' \
+ -e 's:/var/run:/run:g' \
+ conf.c chrony.texi.in chrony.txt examples/* faq.txt || die
+}
+
+src_configure() {
+ tc-export CC
+
+ # not an autotools generated script
+ ./configure \
+ $(usex caps '' --disable-linuxcaps) \
+ $(usex ipv6 '' --disable-ipv6) \
+ $(usex readline '' --disable-readline) \
+ $(usex rtc '' --disable-rtc) \
+ --docdir=/usr/share/doc/${PF} \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --sysconfdir=/etc/chrony \
+ --without-nss \
+ --without-tomcrypt \
+ ${EXTRA_ECONF} \
+ || die
+}
+
+src_compile() {
+ emake all docs
+}
+
+src_install() {
+ default
+ rm "${D}"/usr/share/doc/${PF}/COPYING || die
+ doinfo chrony.info*
+
+ newinitd "${FILESDIR}"/chronyd.init chronyd
+ newconfd "${FILESDIR}"/chronyd.conf chronyd
+
+ insinto /etc/${PN}
+ newins examples/chrony.conf.example chrony.conf
+ newins examples/chrony.keys.example chrony.keys
+
+ keepdir /var/{lib,log}/chrony
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/chrony.logrotate chrony
+
+ systemd_newunit "${FILESDIR}"/chronyd.service-r1 chronyd.service
+ systemd_enable_ntpunit 50-chrony chronyd.service
+}