summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-02-28 09:29:22 +0000
committerMichael Weber <xmw@gentoo.org>2013-02-28 09:29:22 +0000
commit258bb3ff3516d9d39e948cf11475da0c87e7c205 (patch)
tree7cad9ced855e2d9ff24acd6fbdb95f9fcb59af1a /net-nds/ldapvi
parentVersion bump. Requested in bug #456094. (diff)
downloadgentoo-2-258bb3ff3516d9d39e948cf11475da0c87e7c205.tar.gz
gentoo-2-258bb3ff3516d9d39e948cf11475da0c87e7c205.tar.bz2
gentoo-2-258bb3ff3516d9d39e948cf11475da0c87e7c205.zip
Fix ncuses split (bug 459478).
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-nds/ldapvi')
-rw-r--r--net-nds/ldapvi/ChangeLog9
-rw-r--r--net-nds/ldapvi/ldapvi-1.7-r2.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/net-nds/ldapvi/ChangeLog b/net-nds/ldapvi/ChangeLog
index 9d00ad69505d..cb0c27dbd3d6 100644
--- a/net-nds/ldapvi/ChangeLog
+++ b/net-nds/ldapvi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-nds/ldapvi
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ldapvi/ChangeLog,v 1.30 2012/06/30 11:00:25 xmw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ldapvi/ChangeLog,v 1.31 2013/02/28 09:29:22 xmw Exp $
+
+*ldapvi-1.7-r2 (28 Feb 2013)
+
+ 28 Feb 2013; Michael Weber <xmw@gentoo.org> +ldapvi-1.7-r2.ebuild:
+ Fix ncuses split (bug 459478).
30 Jun 2012; Michael Weber <xmw@gentoo.org> -ldapvi-1.7.ebuild:
Drop old
diff --git a/net-nds/ldapvi/ldapvi-1.7-r2.ebuild b/net-nds/ldapvi/ldapvi-1.7-r2.ebuild
new file mode 100644
index 000000000000..7f9af2616037
--- /dev/null
+++ b/net-nds/ldapvi/ldapvi-1.7-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ldapvi/ldapvi-1.7-r2.ebuild,v 1.1 2013/02/28 09:29:22 xmw Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Manage LDAP entries with a text editor"
+HOMEPAGE="http://www.lichteblau.com/ldapvi/"
+SRC_URI="http://www.lichteblau.com/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="ssl"
+
+RDEPEND="sys-libs/ncurses
+ >=net-nds/openldap-2.2
+ dev-libs/popt
+ >=dev-libs/glib-2
+ sys-libs/readline
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}+glibc-2.10.patch"
+ epatch "${FILESDIR}/${P}-vim-encoding.patch"
+
+ sed -e '/^AC_SEARCH_LIBS/s:curses ncurses:curses ncurses tinfo:' \
+ -i configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with ssl libcrypto openssl)
+}
+
+src_install() {
+ dobin ldapvi
+ doman ldapvi.1
+ dodoc NEWS manual/{bg.png,html.xsl,manual.{css,xml}}
+}