summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-21 14:18:40 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-21 14:18:40 +0000
commit21d99645733252d2bcef8235fcf2ec20ff67d6d6 (patch)
tree7c0e48ea47bf34310cea9fe8d3408a85b7f0b6a5 /net-nds/ypserv
parentOld. Vulnerable. (diff)
downloadgentoo-2-21d99645733252d2bcef8235fcf2ec20ff67d6d6.tar.gz
gentoo-2-21d99645733252d2bcef8235fcf2ec20ff67d6d6.tar.bz2
gentoo-2-21d99645733252d2bcef8235fcf2ec20ff67d6d6.zip
Version bump. Use pidfile now that the RPC server supports it.
(Portage version: 2.2.0_alpha30/cvs/Linux i686)
Diffstat (limited to 'net-nds/ypserv')
-rw-r--r--net-nds/ypserv/ChangeLog10
-rw-r--r--net-nds/ypserv/files/rpc.ypxfrd-2.2322
-rw-r--r--net-nds/ypserv/ypserv-2.19.ebuild71
-rw-r--r--net-nds/ypserv/ypserv-2.23.ebuild6
-rw-r--r--net-nds/ypserv/ypserv-2.24.ebuild77
5 files changed, 110 insertions, 76 deletions
diff --git a/net-nds/ypserv/ChangeLog b/net-nds/ypserv/ChangeLog
index fdb96c4db230..a83b4d6cb7f7 100644
--- a/net-nds/ypserv/ChangeLog
+++ b/net-nds/ypserv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nds/ypserv
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/ChangeLog,v 1.48 2010/09/30 21:38:33 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/ChangeLog,v 1.49 2011/04/21 14:18:40 jer Exp $
+
+*ypserv-2.24 (21 Apr 2011)
+
+ 21 Apr 2011; Jeroen Roovers <jer@gentoo.org> +files/rpc.ypxfrd-2.23,
+ ypserv-2.23.ebuild, +ypserv-2.24.ebuild:
+ Version bump. Use pidfile now that the RPC server supports it.
30 Sep 2010; Brent Baude <ranger@gentoo.org> ypserv-2.22.ebuild:
stable ppc64, bug 320325
diff --git a/net-nds/ypserv/files/rpc.ypxfrd-2.23 b/net-nds/ypserv/files/rpc.ypxfrd-2.23
new file mode 100644
index 000000000000..b1526aa696d8
--- /dev/null
+++ b/net-nds/ypserv/files/rpc.ypxfrd-2.23
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/files/rpc.ypxfrd-2.23,v 1.1 2011/04/21 14:18:40 jer Exp $
+
+depend() {
+ need net portmap ypserv
+}
+
+start() {
+ ebegin "Starting rpc.ypxfrd"
+ YOPTS=""
+ if [ -n "${YPXFRD_OPTS}" ]; then YOPTS="-- ${YPXFRD_OPTS}"; fi
+ start-stop-daemon --start --quiet --pidfile /var/run/ypxfrd.pid --exec /usr/sbin/rpc.ypxfrd ${YOPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping rpc.ypxfrd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/ypxfrd.pid --exec /usr/sbin/rpc.ypxfrd
+ eend $?
+}
diff --git a/net-nds/ypserv/ypserv-2.19.ebuild b/net-nds/ypserv/ypserv-2.19.ebuild
deleted file mode 100644
index 050169e69e04..000000000000
--- a/net-nds/ypserv/ypserv-2.19.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/ypserv-2.19.ebuild,v 1.9 2009/06/20 19:07:32 vapier Exp $
-
-DESCRIPTION="Network Information Service server"
-HOMEPAGE="http://www.linux-nis.org/nis/"
-SRC_URI="mirror://kernel/linux/utils/net/NIS/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
-IUSE="slp"
-
-DEPEND=">=sys-libs/gdbm-1.8.0
- slp? ( net-libs/openslp )"
-RDEPEND="${DEPEND}
- || ( net-nds/rpcbind net-nds/portmap )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e '/^INSTALL_STRIP_PROGRAM/s:-s::' \
- configure || die
- sed -i \
- -e 's:INSTALL_STRIP_FLAG=-s::' \
- -e '/^INSTALL_PROGRAM/s:-s::' \
- Makefile.in */Makefile.in || die
-}
-
-src_compile() {
- econf $(use_enable slp)
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
-
- insinto /etc
- doins etc/ypserv.conf etc/netgroup etc/netmasks
- insinto /var/yp
- newins etc/securenets securenets.default
-
- newconfd "${FILESDIR}/ypserv.confd" ypserv
- newconfd "${FILESDIR}/rpc.yppasswdd.confd" rpc.yppasswdd
- newconfd "${FILESDIR}/rpc.ypxfrd.confd" rpc.ypxfrd
-
- newinitd "${FILESDIR}/ypserv" ypserv
- newinitd "${FILESDIR}/rpc.yppasswdd-r1" rpc.yppasswdd
- newinitd "${FILESDIR}/rpc.ypxfrd" rpc.ypxfrd
-
- # Save the old config into the new package as CONFIG_PROTECT
- # doesn't work for this package.
- if [ -f "${ROOT}/var/yp/Makefile" ]; then
- mv "${D}/var/yp/Makefile" "${D}/var/yp/Makefile.dist"
- cp "${ROOT}/var/yp/Makefile" "${D}/var/yp/Makefile"
- einfo "As you have a previous /var/yp/Makefile, I have added"
- einfo "this file into the new package and installed the new"
- einfo "file as /var/yp/Makefile.dist"
- fi
-}
-
-pkg_postinst() {
- einfo "To complete setup, you will need to edit /var/yp/securenets,"
- einfo "/etc/conf.d/ypserv, /etc/ypserv.conf, /etc/conf.d/rpc.yppasswdd"
- einfo "and possibly /var/yp/Makefile."
-
- einfo "To start the services at boot, you need to enable ypserv and optionally"
- einfo "the rpc.yppasswdd and/or rpc.ypxfrd services"
-}
diff --git a/net-nds/ypserv/ypserv-2.23.ebuild b/net-nds/ypserv/ypserv-2.23.ebuild
index ddfa5b88e6d2..fd60acd95a5c 100644
--- a/net-nds/ypserv/ypserv-2.23.ebuild
+++ b/net-nds/ypserv/ypserv-2.23.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/ypserv-2.23.ebuild,v 1.1 2010/08/28 00:38:12 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/ypserv-2.23.ebuild,v 1.2 2011/04/21 14:18:40 jer Exp $
EAPI="2"
@@ -44,7 +44,7 @@ src_install() {
newinitd "${FILESDIR}/ypserv" ypserv
newinitd "${FILESDIR}/rpc.yppasswdd-r1" rpc.yppasswdd
- newinitd "${FILESDIR}/rpc.ypxfrd" rpc.ypxfrd
+ newinitd "${FILESDIR}/rpc.ypxfrd-2.23" rpc.ypxfrd
echo "CONFIG_PROTECT=\"/var/yp/Makefile\"" > "${T}"/10ypserv
doenvd "${T}"/10ypserv
diff --git a/net-nds/ypserv/ypserv-2.24.ebuild b/net-nds/ypserv/ypserv-2.24.ebuild
new file mode 100644
index 000000000000..a4a9e4700350
--- /dev/null
+++ b/net-nds/ypserv/ypserv-2.24.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/ypserv-2.24.ebuild,v 1.1 2011/04/21 14:18:40 jer Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="Network Information Service server"
+HOMEPAGE="http://www.linux-nis.org/nis/"
+SRC_URI="mirror://kernel/linux/utils/net/NIS/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="slp"
+
+DEPEND=">=sys-libs/gdbm-1.8.0
+ slp? ( net-libs/openslp )"
+RDEPEND="${DEPEND}
+ || ( net-nds/rpcbind net-nds/portmap )"
+
+src_prepare() {
+ # The configure script does not provide a command-line flag to control usage
+ # of slp. Use a brutal method in case we need to disable it.
+ if ! use slp; then
+ sed -i -e 's/USE_SLP=1/USE_SLP=0/g' configure.in
+ eautoreconf
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ insinto /etc
+ doins etc/ypserv.conf etc/netgroup etc/netmasks
+ insinto /var/yp
+ newins etc/securenets securenets.default
+
+ newconfd "${FILESDIR}/ypserv.confd" ypserv
+ newconfd "${FILESDIR}/rpc.yppasswdd.confd" rpc.yppasswdd
+ newconfd "${FILESDIR}/rpc.ypxfrd.confd" rpc.ypxfrd
+
+ newinitd "${FILESDIR}/ypserv" ypserv
+ newinitd "${FILESDIR}/rpc.yppasswdd-r1" rpc.yppasswdd
+ newinitd "${FILESDIR}/rpc.ypxfrd-2.23" rpc.ypxfrd
+
+ echo "CONFIG_PROTECT=\"/var/yp/Makefile\"" > "${T}"/10ypserv
+ doenvd "${T}"/10ypserv
+}
+
+pkg_preinst() {
+ # This ebuilds installs an env file which CONFIG_PROTECTs /var/yp/Makefile,
+ # but if the user is migrating from older ypserv, this won't take effect
+ # immediately. Keep the older setup with Makefile.dist file and ask the user
+ # to migrate.
+ if [ -f "${ROOT}/var/yp/Makefile.dist" ]; then
+ mv "${D}/var/yp/Makefile" "${D}/var/yp/Makefile.dist" \
+ || die "mv failed"
+ cp "${ROOT}/var/yp/Makefile" "${D}/var/yp/Makefile" \
+ || die "cp failed"
+ elog "Please remove ${ROOT}/var/yp/Makefile.dist after making sure that"
+ elog "${ROOT}/var/yp/Makefile looks fine to you. It is now"
+ elog "CONFIG_PROTECTed, so further changes should be managed with"
+ elog "usual config management tools like etc-update or dispatch-conf."
+ fi
+}
+
+pkg_postinst() {
+ einfo "To complete setup, you will need to edit /var/yp/securenets,"
+ einfo "/etc/conf.d/ypserv, /etc/ypserv.conf, /etc/conf.d/rpc.yppasswdd"
+ einfo "and possibly /var/yp/Makefile."
+
+ einfo "To start the services at boot, you need to enable ypserv and optionally"
+ einfo "the rpc.yppasswdd and/or rpc.ypxfrd services"
+}