summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-08-28 00:27:01 +0000
committerJeroen Roovers <jer@gentoo.org>2010-08-28 00:27:01 +0000
commit6c4680fa5c2116db528190e5ce92e0ecd2888f65 (patch)
treea2bdc3457ed68baf1b03bf19b17ee8ae176ce9de /net-nds
parentStable for HPPA (bug #320327). (diff)
downloadgentoo-2-6c4680fa5c2116db528190e5ce92e0ecd2888f65.tar.gz
gentoo-2-6c4680fa5c2116db528190e5ce92e0ecd2888f65.tar.bz2
gentoo-2-6c4680fa5c2116db528190e5ce92e0ecd2888f65.zip
Version bump.
(Portage version: 2.2_rc69/cvs/Linux i686)
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/ypbind/ChangeLog7
-rw-r--r--net-nds/ypbind/ypbind-1.32.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/net-nds/ypbind/ChangeLog b/net-nds/ypbind/ChangeLog
index c047cc3f4b90..90954d118d8b 100644
--- a/net-nds/ypbind/ChangeLog
+++ b/net-nds/ypbind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-nds/ypbind
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ChangeLog,v 1.57 2010/08/28 00:24:08 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ChangeLog,v 1.58 2010/08/28 00:27:01 jer Exp $
+
+*ypbind-1.32 (28 Aug 2010)
+
+ 28 Aug 2010; Jeroen Roovers <jer@gentoo.org> +ypbind-1.32.ebuild:
+ Version bump.
28 Aug 2010; Jeroen Roovers <jer@gentoo.org> ypbind-1.31.ebuild:
Stable for HPPA (bug #320327).
diff --git a/net-nds/ypbind/ypbind-1.32.ebuild b/net-nds/ypbind/ypbind-1.32.ebuild
new file mode 100644
index 000000000000..76bc083f8db9
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.32.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.32.ebuild,v 1.1 2010/08/28 00:27:01 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_P=${PN}-mt-${PV}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Multithreaded NIS bind service (ypbind-mt)"
+HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls slp"
+
+RDEPEND="slp? ( net-libs/openslp )
+ net-nds/yp-tools
+ || ( net-nds/portmap net-nds/rpcbind )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.31-man-port.patch" # bug #77810
+}
+
+src_configure() {
+ econf $(use_enable nls) $(use_enable slp)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc AUTHORS ChangeLog README THANKS TODO
+
+ insinto /etc
+ newins etc/yp.conf yp.conf.example
+
+ newconfd "${FILESDIR}/ypbind.confd-r1" ypbind
+ newinitd "${FILESDIR}/ypbind.initd" ypbind
+}
+
+pkg_postinst() {
+ einfo "To complete setup, you will need to edit /etc/conf.d/ypbind."
+ einfo "If you are using dhcpcd, be sure to add the -Y option to"
+ einfo "dhcpcd_eth0 (or eth1, etc.) to keep dhcpcd from clobbering"
+ einfo "/etc/yp.conf."
+}