summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-03 20:19:44 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-03 20:19:44 +0000
commitb81e5eb0f0fca47fc81e83b223b5f0e9de5fd84b (patch)
treec76729a6598efe24e60b81f047d059bcd7f8a606 /net-news
parentlibexec path fix (diff)
downloadgentoo-2-b81e5eb0f0fca47fc81e83b223b5f0e9de5fd84b.tar.gz
gentoo-2-b81e5eb0f0fca47fc81e83b223b5f0e9de5fd84b.tar.bz2
gentoo-2-b81e5eb0f0fca47fc81e83b223b5f0e9de5fd84b.zip
New version
Diffstat (limited to 'net-news')
-rw-r--r--net-news/pan/ChangeLog7
-rw-r--r--net-news/pan/files/digest-pan-0.13.31
-rw-r--r--net-news/pan/pan-0.13.3.ebuild45
3 files changed, 52 insertions, 1 deletions
diff --git a/net-news/pan/ChangeLog b/net-news/pan/ChangeLog
index d270910d63c8..6d2e995eb466 100644
--- a/net-news/pan/ChangeLog
+++ b/net-news/pan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-news/pan
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-news/pan/ChangeLog,v 1.21 2002/11/29 23:21:07 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/ChangeLog,v 1.22 2003/01/03 20:19:44 foser Exp $
+
+*pan-0.13.3 (03 Jan 2003)
+
+ 03 Jan 2003; foser <foser@gentoo.org> pan-0.13.3.ebuild :
+ New version
*pan-0.13.2 (29 Nov 2002)
diff --git a/net-news/pan/files/digest-pan-0.13.3 b/net-news/pan/files/digest-pan-0.13.3
new file mode 100644
index 000000000000..c784469082db
--- /dev/null
+++ b/net-news/pan/files/digest-pan-0.13.3
@@ -0,0 +1 @@
+MD5 6c3da5b046210f1ca0d3862764327ffe pan-0.13.3.tar.bz2 1790747
diff --git a/net-news/pan/pan-0.13.3.ebuild b/net-news/pan/pan-0.13.3.ebuild
new file mode 100644
index 000000000000..58f457c8886f
--- /dev/null
+++ b/net-news/pan/pan-0.13.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/pan-0.13.3.ebuild,v 1.1 2003/01/03 20:19:44 foser Exp $
+
+IUSE="nls spell"
+
+DESCRIPTION="A newsreader for the Gnome2 desktop"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/SOURCE/${P}.tar.bz2"
+HOMEPAGE="http://pan.rebelbase.com"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ >=dev-libs/libxml2-2.4.22
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.21
+ nls? ( sys-devel/gettext )"
+
+export CONFIG_PROTECT_MASK="/etc/gconf"
+
+src_compile() {
+ local myconf=""
+
+ use nls \
+ && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+ use spell \
+ && myconf="${myconf} --enable-gtkspell" \
+ || myconf="${myconf} --disable-gtkspell"
+
+ econf ${myconf} || die "Configure failure"
+
+ emake || die "Compilation failure"
+}
+
+src_install() {
+ einstall || die "Installation failed"
+
+ dodoc ANNOUNCE AUTHORS ChangeLog COPYING CREDITS INSTALL NEWS README TODO
+}