summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-04-13 10:55:28 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-04-13 10:55:28 +0000
commitb294567022b200ec8ae10a739ab6eac20020dd7f (patch)
tree72d67b6e48e5b4d603829fb2cd8a6113ca61910f /net-nntp
parentStable on ppc64; bug #207663 (diff)
downloadgentoo-2-b294567022b200ec8ae10a739ab6eac20020dd7f.tar.gz
gentoo-2-b294567022b200ec8ae10a739ab6eac20020dd7f.tar.bz2
gentoo-2-b294567022b200ec8ae10a739ab6eac20020dd7f.zip
Fix compilation with gcc-4.3, bug #211670
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/pan/ChangeLog6
-rw-r--r--net-nntp/pan/files/pan-0.132-gcc43-fixes.patch90
-rw-r--r--net-nntp/pan/pan-0.132-r2.ebuild7
3 files changed, 100 insertions, 3 deletions
diff --git a/net-nntp/pan/ChangeLog b/net-nntp/pan/ChangeLog
index 7af0612ef8cb..e1b22b3e93a9 100644
--- a/net-nntp/pan/ChangeLog
+++ b/net-nntp/pan/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nntp/pan
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.56 2008/04/13 10:43:31 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.57 2008/04/13 10:55:27 eva Exp $
+
+ 13 Apr 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/pan-0.132-gcc43-fixes.patch, pan-0.132-r2.ebuild:
+ Fix compilation with gcc-4.3, bug #211670
*pan-0.132-r2 (13 Apr 2008)
diff --git a/net-nntp/pan/files/pan-0.132-gcc43-fixes.patch b/net-nntp/pan/files/pan-0.132-gcc43-fixes.patch
new file mode 100644
index 000000000000..a6f366c90b23
--- /dev/null
+++ b/net-nntp/pan/files/pan-0.132-gcc43-fixes.patch
@@ -0,0 +1,90 @@
+--- pan-0.132/pan/general/file-util.cc
++++ pan-0.132/pan/general/file-util.cc
+@@ -19,6 +19,7 @@
+
+ #include <config.h>
+
++#include <algorithm>
+ #include <cassert>
+ #include <cerrno>
+ #include <cctype>
+--- pan-0.132/pan/general/line-reader.cc
++++ pan-0.132/pan/general/line-reader.cc
+@@ -1,5 +1,6 @@
+ #include <config.h>
+ #include <cstdio>
++#include <cstdlib>
+ extern "C"{
+ #include <glib/gi18n.h>
+ }
+--- pan-0.132/pan/general/string-view.h
++++ pan-0.132/pan/general/string-view.h
+@@ -22,6 +22,7 @@
+
+ #include <iosfwd>
+ #include <string>
++#include <cstring>
+
+ namespace pan
+ {
+--- pan-0.132/pan/gui/prefs.cc
++++ pan-0.132/pan/gui/prefs.cc
+@@ -22,6 +22,7 @@
+ #include <fstream>
+ #include <sstream>
+ #include <string>
++#include <cstdlib>
+ extern "C" {
+ #include <glib.h>
+ #include <glib/gi18n.h>
+--- pan-0.132/pan/tasks/nntp.cc
++++ pan-0.132/pan/tasks/nntp.cc
+@@ -20,6 +20,7 @@
+ #include <config.h>
+ #include <cassert>
+ #include <cstdarg>
++#include <cstdlib>
+ extern "C" {
+ #include <glib.h>
+ #include <glib/gi18n.h>
+--- pan-0.132/pan/tasks/socket-impl-scripted.cc
++++ pan-0.132/pan/tasks/socket-impl-scripted.cc
+@@ -19,6 +19,7 @@
+
+ #include <config.h>
+ #include <cassert>
++#include <cstdlib>
+ #include <pan/general/debug.h>
+ #include <pan/general/messages.h>
+ #include <pan/general/string-view.h>
+--- pan-0.132/pan/usenet-utils/gnksa-test.cc
++++ pan-0.132/pan/usenet-utils/gnksa-test.cc
+@@ -1,6 +1,7 @@
+ #include <config.h>
+ #include <iostream>
+ #include <string>
++#include <climits>
+ #include <pan/general/string-view.h>
+ #include <pan/general/test.h>
+ #include "gnksa.h"
+--- pan-0.132/pan/usenet-utils/numbers.cc
++++ pan-0.132/pan/usenet-utils/numbers.cc
+@@ -19,6 +19,7 @@
+
+ #include <config.h>
+ #include <cctype>
++#include <algorithm>
+ #include <pan/general/string-view.h>
+ #include "numbers.h"
+
+--- pan-0.132/pan/usenet-utils/scorefile.cc
++++ pan-0.132/pan/usenet-utils/scorefile.cc
+@@ -21,6 +21,8 @@
+ #include <iostream>
+ #include <sstream>
+ #include <string>
++#include <algorithm>
++#include <cstdlib>
+ extern "C" {
+ #include <glib/gi18n.h>
+ }
diff --git a/net-nntp/pan/pan-0.132-r2.ebuild b/net-nntp/pan/pan-0.132-r2.ebuild
index d6373af3d9f5..29b8555d8de4 100644
--- a/net-nntp/pan/pan-0.132-r2.ebuild
+++ b/net-nntp/pan/pan-0.132-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-0.132-r2.ebuild,v 1.1 2008/04/13 10:43:31 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-0.132-r2.ebuild,v 1.2 2008/04/13 10:55:27 eva Exp $
inherit eutils
@@ -31,7 +31,10 @@ src_unpack() {
epatch "${FILESDIR}"/load-pixbuf-in-1024-byte-chunks.diff
# Fix compilation with >=glib-2.16, bug #214446
- epatch "${FILESDIR}/pan-0.132-glib-compat.patch"
+ epatch "${FILESDIR}/${P}-glib-compat.patch"
+
+ # Fix compilation with gcc-4.3, bug #211670
+ epatch "${FILESDIR}/${P}-gcc43-fixes.patch"
}
src_compile() {